log viewer lists no log by default (incompatible with rsyslog)

Bug #841085 reported by Thomas de Graaff on 2011-09-04
248
This bug affects 53 people
Affects Status Importance Assigned to Milestone
gnome-utils (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

In 11.10 Beta1 the log file viewer is empty, no logs to be viewed.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-system-log 3.1.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic-pae 3.0.4
Uname: Linux 3.0.0-10-generic-pae i686
Architecture: i386
CheckboxSubmission: 16c1457533412a7140032da930ccf56e
CheckboxSystem: e3f7e64142c9de9cf92c77313821923d
Date: Sun Sep 4 16:47:21 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Changed in gnome-utils (Ubuntu):
status: New → Confirmed
Dylan McCall (dylanmccall) wrote :

I can confirm this behaviour. Looking at /org/gnome/gnome-system-log in dconf-editor, I see there is a logfiles property, which is set to an empty list by default. (The list had a single item to begin with, because I had opened a log file earlier, and clicking the Set to Default button cleared it). The property's description is as follows:
“Specifies a list of log files to open up at startup. A default list is created by reading /etc/syslog.conf.”

The file /etc/syslog.conf does not exist on my system.

Changed in gnome-utils (Ubuntu Oneiric):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Ubuntu uses rsyslog not syslog, either the code should be adapted to work with it or the package should have a default key value that list known logs

nuttzo33 (slucas1979) wrote :

Here is a screenshot of my log file viewer and as you can see it is empty.
?field.comment=Here is a screenshot of my log file viewer and as you can see it is empty.

This bug still exists in release.

nuttzo33 (slucas1979) wrote :

yep it still exists in release.I hope they clean thisbug up asap and not leave it till precise pangolin.I can't believe this didn't get assigned to someone to fix before release date.

nuttzo33 (slucas1979) wrote :

I know it's not a release critical bug but to have one of the system utility gui screens from the launcher appear blank needs to be fixed now and not later.It looks really untidy in an otherwise polished interface

zmago (zmago-fluks) wrote :

I also have same problem. Same view as shayne lucas has.

zmago (zmago-fluks) wrote :

Ah.. i forgot.. i have 64 bit oneiric. On 32 bit versions i dont have this problem. One question.. does here exist any workaround?

zmago, you can view the raw logs in /var/log.

tags: added: amd64
Mary Lockhart (marylockhart40) wrote :

Timothy Mayoh, thanks for posting about /var/log. I didn't know about this :=)

Sebastien Bacher (seb128) wrote :

The bug is confirmed, no need to add such comments

Yes Sebastien, but if nobody is assigned to it, it means not much is going on about it correct? Please suggest an alternative work around in the meantime? e.g. the links to the logs?

nuttzo33 (slucas1979) wrote :

Thats right eshwar,just because it's confirmed doesn't mean it's going to be fixed soon.If you are helping out a newbie with a problem and you say to them check your logs and the newbie clicks on the log file viewer and nothings there he's going to go huh?
That newbie is likely to look for a new distro if he sees that is broken.

Sebastien Bacher (seb128) wrote :

Why do you need to access to the logs and to which one do you need access? Nobody is assigned doesn't mean it's not going to be worked or fixed, you can also use the file menu or ctrl-O and select the log you want to open

Thanks Sebastien!
Access to logs is useful in my case to see the status of dnsmasq and if its issuing ip addresses correctly. I am using it as a dhcp server. Log viewer is a convenient location where I get to see what it is doing without knowing where the logs are located.

Hopefully the bug is fixed soon. All the best!

nick rundy (nrundy) wrote :

I don't consider this a bug anymore!

Big thanks to Timothy Mayoh & Sebastien Bacher. I can't believe my ignorance.

guys, just go to /var/log and right-click whatever log file you're interested in and select "Copy to" and then select your Home folder. Or alternatively you can open the Log File Viewer and press CTRL+O and select whatever log you want. It will then show in the left-side pane. Next time you open Log File Viewer, that Log will still be there.

After learning these things, I actually prefer the Log File Viewer be empty after a new install because the Log Viewer opens quickly and there aren't a gazillion logs present that I never use. I can input whatever log interests me whenever I want.

Maybe this "bug" should be changed to a Won't Fix? I think it's more from ignorance on the user's part. My initially viewing this as a bug certainly was from ignorance on my part.

In my opinion this is still a bug, as in previous versions of Log File Viewer in Ubuntu you could view all system logs without any extra effort.

nick rundy (nrundy) wrote :

Bug 449374, which I agree with, argues there are too many default logs making the Log File Viewer needlessly complex. It also causes the Log File Viewer to be very slow to open because it has to load all the logs (at least on my computer). seems to me that if the user knows about logs and wants to view them he/she will be better served by just loading what log/s they want. Just something to consider.

@Nick Rundy, I guess the solution would be a preferences window of some sort that allows you to select which ones you don't want to see.
But since this logs disappearing behaviour was NOT intentional and only cropped up in oneiric while being fine in the rest it is still a bug.
What you are proposing is a solution based on your preferences and point of view.

summary: - Log File Viewer empty
+ log viewer lists not log by default (incompatible with rsyslog)
Changed in gnome-utils (Ubuntu Precise):
status: Confirmed → Triaged
Changed in gnome-utils (Ubuntu Oneiric):
status: Confirmed → Triaged

I think it is important that the viewer defaults to showing something. It is very confusing for someone inexperienced with linux to open the log file viewer and find it completely empty. It is not obvious that one should use file open to see something. The gui interface is supposed to make it easier for inexperienced users.

Sebastien Bacher (seb128) wrote :

Ok, let's try to get things moving there, I emailed <email address hidden> to see if somebody there knows what file we should be parsing for rsyslog or what if there is a consensus on the list of logs we should display by default.

Fred (eldmannen+launchpad) wrote :

org.gnome.gnome-system-log logfiles is empty.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-utils - 3.2.1-0ubuntu3

---------------
gnome-utils (3.2.1-0ubuntu3) precise; urgency=low

  * debian/gnome-system-log.gsettings-override:
    - define a list of logs to display by default (lp: #841085)
  * debian/patches/10_build_freetype_fix.patch:
    - use -lfreetype since ft symbols are used
 -- Sebastien Bacher <email address hidden> Wed, 25 Jan 2012 12:23:02 +0100

Changed in gnome-utils (Ubuntu Precise):
status: Triaged → Fix Released
summary: - log viewer lists not log by default (incompatible with rsyslog)
+ log viewer lists no log by default (incompatible with rsyslog)
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in gnome-utils (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers