Opening remote (sftp) font file takes a very long time

Bug #802066 reported by Ricardo Graça on 2011-06-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-utils
New
Medium
gnome-utils (Ubuntu)
Low
Unassigned

Bug Description

On nautilus when clicking on a font file that resides on a remote sftp server it takes a very long time for gnome-font-viewer to actually open the file. So far I measured 11 minutes to open a 15,9Kb file. By copying the file to the local filesystem and clicking it opens instantly. I haven't tried other remote protocols. The remote server is running openSUSE 11.3 on a ADSL connection with 768Kbit/s upload speed. Tried with both ttf and otf files and makes no difference. I'm also seeing an abnormal amount of network traffic in system monitor that is much greater than the actual font file size. I've killed the gnome-font-viewer process because I got tired of waiting after it had downloaded 60MB from the said server when trying to open a 195KB font file.

Steps to reproduce:
1. in nautilus open a remote connection to a SFTP server (preferably one with a slow connection so the problem is more evident)
2. click on a font file to open it

Expected results:
The font file opens in the time it would take to download and open it

Actual results:
It takes a very long time to open the file and there is an abnormal amount of network traffic not proportional to the file size

System is Ubuntu 11.04 with all the latest updates and gnome-control-center 2.32.1

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-control-center 1:2.32.1-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sun Jun 26 00:14:15 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=pt:en
 PATH=(custom, user)
 LANG=pt_PT.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Ricardo Graça (devius) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report, not sure how many people uses gnome-font-viewer to access remote folders, but you're welcome to send this bug upstream to bugzilla.gnome.org where the developers can read about it, thanks.

affects: gnome-control-center (Ubuntu) → gnome-utils (Ubuntu)
Changed in gnome-utils (Ubuntu):
importance: Undecided → Low
Changed in gnome-utils:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-utils (Ubuntu):
status: New → Triaged

"[Bug 802066] Re: Opening remote (sftp) font file takes a very long time"
Bug Watch Updater doc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.