gnome-search-tool should make clear than the "files containing text" apply to "text plain" formats only

Bug #66896 reported by Wouter Hanegraaff on 2006-10-19
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-utils
New
Wishlist
gnome-utils (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

How to reproduce:

1. create a .odt file using openoffice.org
2. save this document document
3. search for "files containing text" in gnome-search-tool, and search for text you've entered in the .odt file

Result: you won't find the file you just created. The same applies to all other files in opendocument format, I guess.

Wouter

Sebastien Bacher (seb128) wrote :

Thanks for your bug. Apparently .odt is not a text format, that's not something gnome-utils can change and not really a bug, marking as rejected. Feel free to reopen if you disagree

Changed in gnome-utils:
assignee: nobody → desktop-bugs
status: Unconfirmed → Rejected

Sebastien Bacher schreef:
> Thanks for your bug. Apparently .odt is not a text format, that's not
> something gnome-utils can change and not really a bug, marking as
> rejected. Feel free to reopen if you disagree

Thanks for formulating the bug in another way. However, it's still a
bug. please reopen. As far as I'm concerned, .doc is not a text format
either and gnome-search-tool can still find the text in those documents.

What you're saying is that people who want to search for text in
documents shouldn't be using gnome-searchtool, or ODF. Well, then the
search tool shouldn't be pretending that it can find text in documents,
because it cannot. So maybe that feature should be removed from
gnome-search-tool, because it doesn't work for the people it is intended
for.

If a user is tech-savvy enough to know that ODF files are really
zipfiles containing xml, and that he should use zipgrep if he wants to
find text in a document, he wouldn't be using gnome-search-tool in the
first place.

One can't expect a user that uses gnome-search-tool to know the
technical intricacies of certain file formats. That's why we have
graphical applications, hiding those details. And if those applications
don't do what the user can reasonably expect, it's a bug.

Wouter

Le vendredi 27 octobre 2006 à 07:28 +0000, Wouter Hanegraaff a écrit :
>
> Thanks for formulating the bug in another way. However, it's still a
> bug. please reopen. As far as I'm concerned, .doc is not a text format
> either and gnome-search-tool can still find the text in those documents.

No, it can not, or maybe with a previous version of the format. A small
example stored to win XP .doc format with oowrite does the same as
the .odt. In fact gnome-search-tool uses the grep command to search for
any string occurence and it works only if the text information is not
coded

> What you're saying is that people who want to search for text in
> documents shouldn't be using gnome-searchtool, or ODF. Well, then the
> search tool shouldn't be pretending that it can find text in documents,
> because it cannot. So maybe that feature should be removed from
> gnome-search-tool, because it doesn't work for the people it is intended
> for.

No, what I'm saying is that the tool is not made to search text to non
"plain text" format. I agree that the interface doesn't make that clear
and is confusing and there is a bug there. It should either implement
the function, make it clear it's limited to "plain text" files or drop
the option. I'm going to reopen the bug according to that.

Understanding every formats is really something not easy to do, it would
require having code implemented for each one (an .odt is not structured
the same way than an image which is also different from a .pdf, etc).

> If a user is tech-savvy enough to know that ODF files are really
> zipfiles containing xml, and that he should use zipgrep if he wants to
> find text in a document, he wouldn't be using gnome-search-tool in the
> first place.

Right

> One can't expect a user that uses gnome-search-tool to know the
> technical intricacies of certain file formats. That's why we have
> graphical applications, hiding those details. And if those applications
> don't do what the user can reasonably expect, it's a bug.

Right too. Would you be happy with the option making it clear that it
works only on "plain text" files. I don't think that making the search
tools understanding every document formats users might be using (with
some which are probably proprietary format without documentation) is
realistic, the options are probably either to make the option clearer or
to drop it then

Changed in gnome-utils:
importance: Undecided → Wishlist
status: Rejected → Confirmed
Sebastien Bacher (seb128) wrote :

Upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=331753 is about that topic too. An index like beagle might be better placed for a such job than gnome-search-tool though

Changed in gnome-utils:
status: Confirmed → Triaged
Changed in gnome-utils:
status: Unknown → New
Changed in gnome-utils:
importance: Unknown → Wishlist
anonymous mouse (eeefafe) wrote :

Please just add the wording "(plain text formats only)" after "Contains the text" in the search program. I just got bitten by this one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.