Disk Usage Analyzer should provide contextual menu option "open folder"

Bug #587650 reported by Felix Nawothnig on 2010-05-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-utils
Fix Released
Wishlist
gnome-utils (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-utils

There really should be another context menu item to open the folder directly on the ring charts (maybe also to copy the path to clipboard?) - I know the possibility exists on the left plane (by the way - why is that no integrated nautilus?) but assuming that you have folder A with sub-folders B and C and you want to open folders for both of them (say they both are rather large and you want to examine why)... (and "looking for big folders and checking them out why they are so big" is probably the most used feature of tools like these...)

Assuming you are on right right plane and now the charts you want to inspect, B and C.

- You left-click on the chart. Chart zooms in, giving you information you didn't want (I want to see the files already!).
- You move the mouse to the left pane, find the newly selected entry by hand, move the mouse over it, right/left-click open folder.
- You move the mouse back to the right pane, right/left-click, "Move to parent folder".

Repeat for file C (although you can skip the last step if this is the last folder you want to inspect).

That's - for two files - 10 clicks, two times mouse movement between widget areas which shouldn't be necessary, one "come on, directory where are you" looking session and you lose focus because you visually lose the chart you are currently working with (folder A) on the right pane.

From a usability standpoint I find this horrible.

If the chart provided a context menu it would be 4 clicks, mouse would stay on the right pane, no "directory searching" and the right pane would not change for no reason.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-utils 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun May 30 22:33:15 2010
ExecutablePath: /usr/bin/baobab
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-utils

Felix Nawothnig (fnawothnig) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gnome-utils (Ubuntu):
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in gnome-utils (Ubuntu):
status: New → Triaged
Changed in gnome-utils:
status: Unknown → New
Changed in gnome-utils:
importance: Unknown → Wishlist
Changed in gnome-utils:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.