gnome-screenshot ignores "--area" if called from shortcut

Bug #549935 reported by loe on 2010-03-27
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-screenshot (Ubuntu)
Undecided
Unassigned
gnome-utils (Ubuntu)
Low
Unassigned

Bug Description

By pressing "Print" a screenshot of the whole desktop gets taken. But I would prefer if I could always choose the area of the screenshot by hand. By calling "gnome-screenshot --area" from commandline you can select the area.

So I went into System -> Shortcuts (? have a German layout) and deactivated the shortcut "print" for taking a screenshot.
Now I added a new shortcut with the command: "gnome-screenshot --area" and assigned the "print" key to it. (Theoretically I am done at this point)

 But if I press the print key a screenshot of the whole screen gets taken. And there was NO area selection. If I change the command from "--area" to "--interactive", then by pressing the "print" key the property window pops up (if i select there the checkbox area-selection I can choose the area). Assigning "gnome-screenshot --area" to a different key/ or combination of keys has the same result - the area selection never shows up. (The interactive mode always works)

Do I miss something or did I found a bug? And can anyone tell me if there is a fix?

As a workaround I tried putting the command into a script and then calling the script per shortcut with the same result: the area selection never shows up, (the interactive mode does).

I am using
Ubuntu 9.10 with kernel 2.6.31-20-generic (without compiz or any desktop effects)

loe

AJenbo (ajenbo) on 2010-03-28
affects: ubuntu → gnome-utils (Ubuntu)
loe (thabastlwastl) wrote :

just found out:

 the current ubuntu 10.04 lucid beta/ daily build is although affected

Victor Vargas (kamus) wrote :

I tried to do reproduce this issue here running Ubuntu Lucid but works fine for me (under similar conditions). This is that I did such as a possible work around:

1) Create a new shorcut with name Capture Area and command /usr/bin/gnome-screenshot --area
2) Then assign a shortcut to execute this function (I assigned Control + Impr just for testing porpuses)
3) Press Control + Impr and voila.

Regards

Changed in gnome-utils (Ubuntu):
importance: Undecided → Low
loe (thabastlwastl) wrote :

Your workaround is basically adding a new shortcut. I just tried it again - it is still not working on my machine.

I'am using lucid with 2.6.32-22-generic with an ati x1400 in an thinkpad z61m.

Sina Eetezadi (sina-eetezadi) wrote :

I also have this bug ob 2.6.32-22-generic on a Thinkpad T410s. My Asus EeePC 901 with the Netbook Edition works fine.

Sina Eetezadi (sina-eetezadi) wrote :

Another hint: Sometimes I press in a certain manner it works as it should...but couldn't reproduce how exactly one has to press the keys.

Stefan Thieme (thymian) wrote :

I have the same issue on 2.6.32-23-generic #37-Ubuntu SMP x86_64 GNU/Linux
I can not run /usr/bin/gnome-screenshot --area from a shortcut binding.

I have disabled (backspace) the default keybindings without success, the custom command will ignore the --area option and create a screenshot of both screens.
Please let me know if you need any debug information and which.

Kind regards,
Stefan

Hernando Torque (htorque) wrote :

Confirming in Natty with 2.32.0-0ubuntu1.

However, I'm not sure which package is to blame, as I successfully can run that command form a launcher in the panel. So maybe gnome-settings-daemon is another package to suspect.

Hernando Torque (htorque) wrote :

Pressing the shortcut twice (fast) seems to work.

Krytarik Raido (krytarik) wrote :

Confirming in Ubuntu 10.04 Lucid, with 2.30.0-0ubuntu1

I found a good workaround for that:

"sleep 0.1; gnome-screenshot --area"

That delays its execution for 0.1 seconds.

Greetings.

Krytarik Raido (krytarik) wrote :

I forgot to fine-tune this, at my system a delay of 0.02 secs is just enough:

sleep 0.02; gnome-screenshot --area

Also, if you want to run it through a launcher, you need to set the command like this:

sh -c "sleep 0.02; gnome-screenshot --area"

Sina Eetezadi (sina-eetezadi) wrote :

Nice workaround Krytarik! Works fine on my Lucid

Just holding the keys (ctrl+Print) about a second seems to work for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: gnome-utils (Ubuntu) → gnome-screenshot (Ubuntu)
Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
Changed in gnome-utils (Ubuntu):
status: New → Confirmed
affects: gnome-screenshot (Ubuntu) → gnome-utils (Ubuntu)
Changed in gnome-utils (Ubuntu):
status: New → Confirmed
Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
Hernando Torque (htorque) wrote :

Works fine here in Precise.

Endre Czirbesz (endre) wrote :

Also buggy in Linux Mint 15.

I had to use the
sh -c "sleep 0.07; gnome-screenshot -a"
workaround (70 ms is fine tuned to my machine).

gnome-screenshot 3.6.1-0ubuntu2

affects: gnome-screenshot (Ubuntu) → linuxmint
Changed in linuxmint:
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Endre Czirbesz (endre) on 2013-11-19
affects: linuxmint → gnome-screenshot (Ubuntu)
Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed

"[Bug 549935] Re: gnome-screenshot ignores --area if called from shortcut"
Anders Johansson doc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers