gnome-system-log uses 100%+ Cpu usage

Bug #493811 reported by jtrottier on 2009-12-07
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-utils
New
High
gnome-utils (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-utils

Not sure when this started, when i pull up gnome-system-log, cpu usage goes through the roof. Starts by trying to view /var/log/btmp which is not there, takes 2min then will respond. Then will use an increasing amount if RAM and spike in using both cores. Tried to run it in Terminal to see if there were any errors there doesn't seem to be any. Tried re-install gnome-util that also made no difference. I can open logs with gedit with no problem so assuming that it is just a memory loop or something within the log viewer?

Using Ubuntu 9.10 Karmic
Kernel 2.6.31-16-generic
package gnome-util 2.28.1-0ubuntu1

ProblemType: Bug
Architecture: amd64
Date: Mon Dec 7 14:54:51 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-system-log
InstallationMedia: Mythbuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: gnome-utils 2.28.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.52-generic
SourcePackage: gnome-utils
Uname: Linux 2.6.31-16-generic x86_64

jtrottier (trottier-james) wrote :
Pedro Villavicencio (pedro) wrote :

Please try to obtain a backtrace of that hang you're seeing there following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-utils (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
jtrottier (trottier-james) wrote :

Hope this helps

Changed in gnome-utils (Ubuntu):
status: Incomplete → New
Shaggy (bdmason) wrote :

I can confirm this bug. I am using Lucid Lynx 10.04 x64 on an Intel Q6600. For EACH log I attempt to view it fully pegs a core @ 100%. I have a repository update tool that writes to a log file for each distribution starting with intrepid, so I viewed 4 different logs and it pegged all four cores @ 100% until I shut down the log viewer.

Changed in gnome-utils:
importance: Unknown → High
status: Unknown → New
Teeedubb (teeedubb) wrote :

I was experiencing these issues to with ubuntu 10.04.2 x64. Running gnome-system-log with root privileges has seems to fix the issue.

Changed in gnome-utils (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: New → Triaged

"[Bug 4938] Re: gnome-system-log uses 0%+ Cpu usage"
Teeedubb doc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.