gnome-search-tool does not find a file in a path containing a hidden directory despite option 'Show hidden and backup files'

Bug #275535 reported by Detlef Lechner on 2008-09-28
8
Affects Status Importance Assigned to Milestone
gnome-utils
Fix Released
Medium
gnome-utils (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

"~$ locate places.sqlite
/home/detlef/.gnome2/epiphany/mozilla/epiphany/places.sqlite
/home/detlef/.mozilla/firefox/fya46e9y.default/places.sqlite"

~$ ls -l /home/detlef/.gnome2/epiphany/mozilla/epiphany/places.sqlite
-rw-r--r-- 1 detlef detlef 147456 2008-07-19 10:40 /home/detlef/.gnome2\
/epiphany/mozilla/epiphany/places.sqlite

~$ ls -l /home/detlef/.mozilla/firefox/fya46e9y.default/places.sqlite
-rw-r--r-- 1 detlef detlef 1212416 2008-09-26 20:01 /home/detlef/.mozilla\
/firefox/fya46e9y.default/places.sqlite

'Search for files' as well as gnome-search-tool' do not find these 2 files if the search starts from / but they do find these 2 files if the search starts from the /home/detlef/.gnome or /home/detlef/.mozilla directory. This is true independent of specifying the option "Show hidden and backup files" or "--hidden".

~$ uname -a
Linux MD97600 2.6.24-19-generic #1 SMP Wed Aug 20 22:56:21 UTC 2008 i686 GNU/Linux

Related branches

Hello. I cannot reproduce this bug yet as files and directories in hidden directories are found (I also tested you "places.sqlite" example). Can you attach a screenshot of your search-tool-screen? I assume you probably have not added the "search in hidden..." option though you have selected it (you need to select it and add it - two steps).

Changed in gnome-utils:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :
Changed in gnome-utils:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Incomplete → Triaged

I had a further investigation on this. This error seems only to be reproducable when partitions come into play. On my system the error does not occur, but when you have your /home on a different partition it might occur.

bwallum (rbw2) wrote :

In Places>Search for Files you can set an option to search for 'Show hidden and backup files'. It works. In File Browser you cannot search for 'hidden and backup files' even if you have previously set the option in Search for Files. I'm running AMD64 Intrepid.

bwallum (rbw2) wrote :

You can find a file in a dot directory using Places>Search for File. You most have Select more options activated (arrow down)

I confirm this problem. Can not find file in a dot-directory, although locate is able to find it.

Ansus (neptunia) wrote :

If a hidden file is placed in non-hidden directory, also cannot find.

Changed in gnome-utils:
status: Unknown → New
Changed in gnome-utils:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed to svn now

Changed in gnome-utils (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package gnome-utils - 2.27.1-0ubuntu1

---------------
gnome-utils (2.27.1-0ubuntu1) karmic; urgency=low

  * New upstream version: (LP: #372168)
    - [build] Fix zlib support
    - [dictionary] Port to GtkBuilder
    - [gsearchtool] Minor logic fix
    - [gsearchtool] Typo fix
    - [gsearchtool] Sync open with menu with nautilus
    - [gsearchtool] clean up code
    - [doap] Add project description
    - Move ChangeLog out of the way
    - [build] Generate ChangeLog on dist
    - [build] Generate ChangeLog from the import tag
    - [docs] Add documentation on commit practises
    - [build] Remove the spec file
    - [gitignore] Create ignore file
    - [build] Massive update to the configure template
    - [docs] Update the HACKING file
    - [doap] Add download-page and change shortdesc
    - [build] Export the MAINTAINER_CFLAGS variable
    - [build] Clean up gdict Makefile template
    - [gitignore] Add intltool droppings
    - [gitignore] Add gnome-dictionary ignore file
    - Move gnome-dictionary ChangeLog
    - [build] Use Shave
    - [build] Show generation rules
    - [docs] The help XML file should not be committed
    - [gitignore] Add ignore file for sub-modules
    - [gitignore] Ignore all m4 files that we don't control
    - [build] Fix AS_CASE error condition
    - [doap] rdf:resource requires a URI
    - Fix bug #580139 - invalid help uri (LP: #342753)
    - Fix bug #581002 - Baobab crashes when scan is pointed to a de-selected
       mount point (LP: #369740 fixes also LP: #248005)
    - doap: Add desktop category
    - Fix compiler warning
    - Rework monitoring of the home file dir
    - Remove leftover declaration
  * Rebase on debian 2.24.1-2, remaining ubuntu changes:
    - debian/control{.in}
       - update build-depends for new version
       - replace vcs-tag with launchpad bzr tag
       - libgdict and gnome-utils replace the ubuntu packages
    - debian/watch: Check upstream development versions, too.
    - debian/rules: Update to properly use cdbs, since it uses parts of cdbs
      already; this gives us full translation handling/stripping without
      replicating all those rules; it also drops a lot of obsolete stuff.
      Define gnome.mk after the standard rules so the schemas registration works
    - debian/*.files: Rename to *.install, and drop mixed
      dh_movefiles/dh_install usage.
    - debian/patches
      - Refresh existing patches to apply to new version
      - drop 01_logview_gksu.patch, we have the admin group for this
      - drop 03_screenshot_xinerama.patch, applied upstream
      - add 04_lpi.patch and 99_autoconf.patch to provide lpi
      - add 05_menu_changes.patch for ubuntu menu simplification
  * Fixes at least:
      - use new gvfs-trashsystem (LP: #207434)
      - don't fail search on apostrophe in filename (LP: #202111)
      - don't fail search on invalid encoding (LP: #247299)
      - find also hidden files (LP: #275535)
      - fix throbber rest icon and animation warning (LP: #338848)
        (LP: #352602)
      - scroll to bottom of logfiles automatically (LP: #346558)
      - don't always scan homefolder (LP: #36...

Read more...

Changed in gnome-utils (Ubuntu):
status: Fix Committed → Fix Released
hingerty (hingerty-gmail) wrote :

I gave up on installing Krmic. So I went back to Jaunty and tried to reinstall everything..on a clean "slate". I downloaded .deb for boxee. My synaptic didnt see it. My add/remove also..didnt see it, after I added source to sources.lst. So I used terminal and now I have an icon and the entire dir is in opt/boxee. Is this where it should be..its the only thing there.
So I thought I would try to run it...nothing. 3 secs of black then nothing. Tried to reinstall...but its nowhere to be found. Using search tool it is just not there. BUT I happen to know form browsing that it is in opt.(IT IS) Also hidden files is checked off. SO its not that.
Why is this group of files invisible??
Recently I had some problems with samba..sharing and I only learned that there are two types of sharing..usershares and samba shares? I was using gksudo natilus to change attributes. So I had problems with login because I didnt Own Home. All of that is fixed. Opt appears to be Root. Full accessable. Read/write.
Why does this program appear to be hidden????
Is it boxee? I dont really think so.
BTW I have ati r300 or somesuch video crd, drivers. Using default video drivers.

Changed in gnome-utils:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.