Ubuntu

disk usage analyser shows twice the disk capacity

Reported by Simon Kent on 2008-04-04
12
Affects Status Importance Assigned to Milestone
gnome-utils
Fix Released
Wishlist
gnome-utils (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Intrepid by Greg A

Bug Description

Binary package hint: gnome-utils

The disk usage analyser reports a disk capacity of double the actual size by default. Looking in the preferences, both the /dev/sda1 and gvfs-fuse-daemon are selected by default. gvfs-fuse-daemon should not be selected by default.

Simon Kent (simonkent) wrote :

bug was found on hardy 8.04 beta with all updates applied as of 4th April 2008

A. Walton (awalton) wrote :

Thanks for your report. Work is going on upstream to both port this utility over to GIO and to disable this double scanning, and will likely be incorporated into GNOME 2.24. If Ubuntu wants a patch that disables double-scanning through the .gvfs virtual location in Hardy, it should be possible and minimally invasive.

Changed in gnome-utils:
status: Unknown → Fix Released
Pedro Villavicencio (pedro) wrote :

that's fixed upstream already, thanks.

Changed in gnome-utils:
assignee: nobody → desktop-bugs
status: New → Fix Committed
Changed in gnome-utils:
importance: Undecided → Low
Philip Wyett (philwyett) wrote :

Are we likely to see the fix in gnome-utils (2.20.0.1-2ubuntu1) from intrepid applied as a patch to hardy heron? The LTS should really have this fix and not report bad hdd capacity through a complete LTS life cycle.

Regards

Phil

Sebastien Bacher (seb128) wrote :

did you try if the issue is fixed in intrepid? it should not since upstream didn't roll a new tarball yet. otherwise the update can be considered for hardy is somebody work on backporting the change, there is just too many bugs and not enough volunteers right not to fix everything but you are welcome to contribute

Philip Wyett (philwyett) wrote :

The issue does not appear in intrepid and disk size is reported correctly.

I will see if I can allocate time to have a look at this issue further and what will be involved in a patch for hardy.

Philip Wyett (philwyett) wrote :

Update...

* Intrepid is unaffected by bug.
* Hardy is affected by bug.
* Hardy with intrepid gnome-utils is still affected by bug.

We also have a new report in gnome bugzilla - below.

http://bugzilla.gnome.org/show_bug.cgi?id=548642

Philip Wyett (philwyett) wrote :

See two attached screenshots. Under hardy you see the gvfs fuse daemon is recording the hard disk size also thus creating the hard disk size capacity doubling we see under hardy. On the intrepid shot it is 0.

Philip Wyett (philwyett) wrote :
Greg A (etulfetulf) wrote :

Marking as fixed, as it is working in Intrepid

Changed in gnome-utils:
status: Fix Committed → Fix Released
Changed in gnome-utils:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.