Baobab (Disk usage analyser) reports the total diskspace incorrectly (~/.gvfs must be ignored by default)

Bug #121168 reported by mthakur200x on 2007-06-19
22
Affects Status Importance Assigned to Milestone
gnome-utils (Ubuntu)
Medium
Áron Sisak

Bug Description

Binary package hint: baobab

i have a 40 GB hard disk which is partitioned into 32 GB for Ubuntu (ext3) 1.26 GB for swap and 7.75 GB for windows XP. It used to work correctly but when I installed timevault, it started to report my disk space as 63 GB, and now when I have removed it, it reports it as 32 GB. I haven't tried to reproduce it.

timevault is a snapshot software, see this: http://ubuntuforums.org/showthread.php?t=474973&highlight=timevault
if any more info is needed, please give me a shout as this is my first bug report.
thanks.

Áron Sisak (asisak) wrote :

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" <http://www.chiark.greenend.org.uk/~sgtatham/bugs.html>. We'd be grateful if you would then provide a more complete description of the problem.

Changed in baobab:
assignee: nobody → asisak
importance: Undecided → Medium
status: Unconfirmed → Needs Info

Sorry about that. I have now added the require details.
Thanks.

On Tue, 2007-06-19 at 13:21 +0000, Áron Sisak wrote:

> Thanks for taking the time to report this bug. Unfortunately we can't
> fix it, because your description didn't include enough information. You
> may find it helpful to read "How to report bugs effectively"
> <http://www.chiark.greenend.org.uk/~sgtatham/bugs.html>. We'd be
> grateful if you would then provide a more complete description of the
> problem.
>
>
> ** Changed in: baobab (Ubuntu)
> Importance: Undecided => Medium
> Assignee: (unassigned) => Áron Sisak
> Status: Unconfirmed => Needs Info
>

description: updated

I can report a similar problem.

Just finished building a new computer. Hard drive is a 320GB Seagate with perpendicular recording (http://www.seagate.com/ww/v/index.jsp?vgnextoid=2d1099f4fa74c010VgnVCM100000dd04090aRCRD). OS is Ubuntu 8.04 Hardy Heron beta (AMD64). Partitioning method was automatic with LVM, followed by all default options.

Although the HD has a total capacity of 320GB and the Ubuntu System Monitor correctly reports 264GB available, the Disk Usage Analyzer (baobab) reports 564GB total capacity, 6GB used and 558GB available.

A screenshot demonstrating this is attached.

les marques (lasmarkas) wrote :

similar problem

Ubuntu 8.04 béta
kernel 2.6.24.16 generic
gnome 2.22.1

Hard drive : Maxtor 6E040L0 (40 Go, 7200 RPM, Ultra-ATA/133)

bertrand@bertrand-desktop:~$ df -h
Sys. de fich. Tail. Occ. Disp. %Occ. Monté sur
/dev/sda1 37G 9,9G 25G 29% /
varrun 248M 96K 248M 1% /var/run
varlock 248M 0 248M 0% /var/lock
udev 248M 48K 248M 1% /dev
devshm 248M 272K 248M 1% /dev/shm
lrm 248M 38M 211M 16% /lib/modules/2.6.24-16-generic/volatile
gvfs-fuse-daemon 37G 9,9G 25G 29% /home/bertrand/.gvfs

Frédéric Petit (fraiddo) wrote :

Not a bug: in preferences, we can choose if gvfs is included in the stat or not. If we don't check the case, baobab show correctly the stats.

bye

  • unnamed Edit (830 bytes, text/html; charset=ISO-8859-1)

thanks.

On 14/04/2008, Frédéric Petit <email address hidden> wrote:
>
> Not a bug: in preferences, we can choose if gvfs is included in the stat
> or not. If we don't check the case, baobab show correctly the stats.
>
> bye
>
>
> --
> Baobab (Disk usage analyser) reports the total diskspace incorrectly
> https://bugs.launchpad.net/bugs/121168
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Mrinal

This is default install of Ubuntu 8.04 without any tweaks.I have only one disk 16GB, but baobab shows total capacity 32GB with double the free space because gvfs is selected by default in prefereces. Unless I come across this bug I wouldn't even know there are any preferences to change this I believe this is still confusing to user and should be addressed, possibly by making baobab aware of gvfs and not selecting it by default.

Garoth (garoth) wrote :

+1 to this shouldn't be the default behaviour. I've just spent like 5-10 minutes gathering information and trying to report a bug.

Ricardo Pérez López (ricardo) wrote :

I totally agree with bastafidly & Garoth. IMHO, the default should be not to include gvfs.

I'll change the status to Confirmed, until a consensus has been reached.

Changed in baobab:
status: Incomplete → Confirmed

IMHO, check .gvfs by default in Baobab causes totally disconcerted users.

I've a 135 GB ext3 partition. When I scan my home folder (or the entire filesystem), Baobab shows:

"Total filesystem capacity: 269,8 GB (used: 240,8 GB available: 29,0 GB)".

However, if I uncheck gvfs-fuse-daemon in Edit->Preferences, and then click on "Scan Home" again, I get:

"Total filesystem capacity: 134,9 GB (used: 120,4 GB available: 14,5 GB)".

Which is correct, but not FULLY correct. See the "df -h" output:

Filesystem Size Used Avail Use% Mounted on
/dev/sda2 135G 121G 7.7G 95% /

Baobab says I've 29,0 GB or 14,5 GB available (depending on the options selected in Edit->Preferences), but "df -h" says I've 7,7 GB available.

What is the correct value?

Hew (hew) wrote :

Baobab is part of gnome-utils, changing sourcepackage.

Fabio Marzocca (thesaltydog) wrote :

New release version in Intrepid does not include .gvfs file system as default. The bug is fixed.

Changed in gnome-utils:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers