"You can receive files over Bluetooth into this folder" always visible on XDG_DOWNLOAD_DIR folder, even without a Bluetooth device

Bug #532101 reported by Alvaro Kuolas on 2010-03-04
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gnome-user-share
Fix Released
Medium
gnome-user-share (Ubuntu)
Low
Chris Coulson
Lucid
Low
Chris Coulson

Bug Description

Binary package hint: nautilus

Over the folder "Downloads" is displayed "You can receive files over Bluetooth on this folder", it's always visible and there is no way to dismiss this message. This machine does not have a Blutooth device.

There should be a cross to dismiss the message and this message should be available only to computers with bluetooh devices.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 80e323949b5d778368b39459217fd9fd
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Thu Mar 4 16:44:50 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100217)
Package: nautilus 1:2.29.91-0ubuntu2
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: nautilus
Uname: Linux 2.6.32-15-generic i686

Alvaro Kuolas (kuolas) wrote :
Alvaro Kuolas (kuolas) wrote :

How to dismiss this annoying message?

affects: nautilus (Ubuntu) → gnome-user-share (Ubuntu)
summary: - [Lucid] "You can recive files over Bluetooth on this folder" always
- visible on "Downloads" folder, even without a Blutooth device
+ "You can recive files over Bluetooth on this folder" always visible on
+ "Downloads" folder, even without a Blutooth device

Thank you for your bug report. Chris, do you think you could look at that issue for lucid?

Changed in gnome-user-share (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Low
status: New → Confirmed
Hew (hew) on 2010-03-06
summary: - "You can recive files over Bluetooth on this folder" always visible on
- "Downloads" folder, even without a Blutooth device
+ "You can receive files over Bluetooth into this folder" always visible
+ on "Downloads" folder, even without a Bluetooth device
SilverWave (silverwave) on 2010-03-21
summary: "You can receive files over Bluetooth into this folder" always visible
- on "Downloads" folder, even without a Bluetooth device
+ on "Downloads" and "Desktop" folder, even without a Bluetooth device

This is showing up on my /home/user/Desktop Folder.

10.04 Lucid Beta 1
Ubuntu lucid (development branch) Release:10.04

It only shows up in the Desktop folder for you because you have XDG_DOWNLOAD_DIR set to your desktop folder, which is no longer the default in Ubuntu. The gnome-user-share bar only displays on your designated download folder.

summary: "You can receive files over Bluetooth into this folder" always visible
- on "Downloads" and "Desktop" folder, even without a Bluetooth device
+ on "Downloads" folder, even without a Bluetooth device
SilverWave (silverwave) wrote :

Workaround for users who see message on Desktop.

Transfer annoying message from Desktop to Downloads
gedit ~/.config/user-dirs.dirs

Change XDG_DOWNLOAD_DIR to point to Downloads in place of Desktop.
e.g.
XDG_DOWNLOAD_DIR="$HOME/Downloads"
__________
Still want to download to the Desktop regardless?
Create a link from Desktop rename it Downloads.
__________

summary: "You can receive files over Bluetooth into this folder" always visible
- on "Downloads" folder, even without a Bluetooth device
+ on XDG_DOWNLOAD_DIR folder, even without a Bluetooth device
j^ (j) wrote :

this is also visible with Bluetooth disabled.
It should only show up if Bluetooth is enabled and one enabled the option to receive files.
Even than there should be a way to hide this message.
Download and Desktop folder are used for many other things and this message is most of the time irrelevant.
Like adding a message "Files you download in Firefox might show up in this folder."

dblade (listmail) wrote :

This message is in /usr/lib/nautilus/extensions-2.0/libnautilus-share-extension.so, which is part of gnome-user-share package [Description: User level public file sharing via WebDAV or ObexFTP]

to know whats in this package use, apt-file list gnome-user-package

my workaround, being that I don't require these features, is to remove gnome-user-share and pkill nautilus

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-user-share - 2.30.0-0ubuntu2

---------------
gnome-user-share (2.30.0-0ubuntu2) lucid; urgency=low

  * Don't install the Nautilus bar for Lucid. It's not that useful to people
    who don't have bluetooth hardware and is not easily disabled. In the
    future, this bar will hide when the hardware is not available (LP: #532101)
 -- Chris Coulson <email address hidden> Thu, 15 Apr 2010 01:20:19 +0100

Changed in gnome-user-share (Ubuntu Lucid):
status: Confirmed → Fix Released
Changed in gnome-user-share:
status: Unknown → Confirmed
Changed in gnome-user-share:
importance: Unknown → Medium
Changed in gnome-user-share:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.