Sync gnome-user-share 3.18.3-2 (main) from Debian unstable (main)

Bug #1714821 reported by Jeremy Bicha on 2017-09-03
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-user-share (Ubuntu)
Wishlist
Unassigned
Artful
Wishlist
Unassigned
Bionic
Wishlist
Unassigned

Bug Description

Please sync gnome-user-share 3.18.3-2 (main) from Debian unstable (main)

The version of gnome-user-share currently in Ubuntu has 2 features:
Bluetooth and WebDav.

Ubuntu has installed gnome-user-share by default for many years so that sending and receiving files over Bluetooth works. That feature is now rovided by gnome-bluetooth and gnome-control-center. Therefore, the new version of gnome-user-share dropped the Bluetooth feature.

Ubuntu has delayed packaging a newer version of gnome-user-share because it
was using unity-control-center which did not support the new Bluetooth feature.

Ubuntu has one long-standing diff from Debian. Ubuntu's gnome-user-share
package does not actually include the apache dependencies needed for the
WebDav feature to work (LP: #536766). Since that's now the only feature in
gnome-user-share, dropping this diff makes sense.

$ reverse-depends gnome-user-share
Reverse-Recommends
==================
* cinnamon-desktop-environment
* gnome-control-center

Reverse-Depends
===============
* gnome-core [amd64 arm64 armhf i386 ppc64el]
* ubuntu-budgie-desktop [amd64 arm64 armhf i386 ppc64el]
* ubuntu-gnome-desktop [amd64 arm64 armhf i386 ppc64el]

Step 1
------
Ubuntu and Ubuntu Budgie both use gnome-control-center so gnome-user-share is unused for Bluetooth.

a. Drop the dependency on gnome-user-share from at least
gnome-control-center

b. Demote gnome-user-share to universe.

Step 2
------
Sync gnome-user-share from Debian.

Therefore, I recommend delaying Step 2 until 18.04 development opens.

Explanation of the Ubuntu delta and why it can be dropped:
  * Add git_add_systemd_service.patch:
    - Backport commit from 3.22 to add systemd user service file for
      compatibility with gnome-settings-daemon 3.22
  * debian/control.in:
    - Build-Depend on systemd
  * d/p/0004-revert-remove-help.patch: Bring back the help files
    for users of gnome-file-share-properties (LP: #1570230)
  * debian/patches: 0001-revert-remove-preferences-application.patch
    Fix launching of Prefences from nautilus share bar under unity and
    patch infobar color (LP: #1562515)
  * maintscript: remove old xdg autostart file (lp: #1526894)
  * New Upstream release (LP: #1518813)
  * Merge with Debian, Remaining changes:
    - Suggests the apache2.2-bin and libapache2-mod-dnssd binaries rather than
      depends on those, we want obex push to work out of the box but we don't
      really need webdav and the apache binaries on the default installation.
    - debian/patches:
      + 0001-revert-remove-preferences-application.patch
        0002-revert-data-get-started-by-gsd-sharing.patch
        0003-revert-webdav-fix-launching-server.patch:
         Bring back the preferences app for Unity and modify to allow g-s-d sharing
         panel to also work
      + 01_notification.patch: Display an alert box instead of a notification
        for files received.
    - debian/rules:
      + Don't change path to httpd
      + Remove apache 2.2 config

Changelog entries since current artful version 3.14.2-2ubuntu5:

gnome-user-share (3.18.3-2) unstable; urgency=medium

  * Fully drop Bluetooth from packaging, obsolete since 3.18.0.
  * Bump Standards-Version to 4.1.0

 -- Jeremy Bicha <email address hidden> Sun, 03 Sep 2017 10:28:16 -0400

gnome-user-share (3.18.3-1) unstable; urgency=medium

  * New upstream release.
  * Drop 30-build-Properly-expand-paths-in-gnome-user-share-webd.patch, merged
    upstream.
  * Bump debhelper compat level to 10.
  * Use non-multiarch path (/usr/lib/gnome-user-share) for libexecdir.

 -- Michael Biebl <email address hidden> Tue, 20 Sep 2016 12:48:27 +0200

gnome-user-share (3.18.2-1) unstable; urgency=medium

  * New upstream release.
  * Add Build-Depends on systemd on Linux to get the correct path for the
    systemd user unit directory.
  * Add patch to ensure systemd is not mandatory so we can build on non-Linux
    architectures.
  * Bump Standards-Version to 3.9.8.
  * Drop debian/dirs, no longer needed.
  * Convert from cdbs to dh.
  * Bump debhelper compatibility level to 9.
  * Add patch to properly expand paths in gnome-user-share-webdav.desktop.

 -- Michael Biebl <email address hidden> Fri, 02 Sep 2016 18:16:19 +0200

gnome-user-share (3.18.1-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.7

 -- Andreas Henriksson <email address hidden> Thu, 24 Mar 2016 16:12:22 +0100

gnome-user-share (3.18.0-1) unstable; urgency=medium

  * New upstream release.
    - drops ObexPush support which moved to gnome-bluetooth.
  * debian/rules: drop moving of obexpush autostart files.

 -- Andreas Henriksson <email address hidden> Fri, 25 Sep 2015 10:15:56 +0200

Jeremy Bicha (jbicha) on 2017-09-03
Changed in gnome-user-share (Ubuntu):
importance: Undecided → Wishlist
description: updated
Jeremy Bicha (jbicha) wrote :

Well I guess the recommended package is not a fully functional Apache so maybe Step 1.c. isn't that important and we can consider Step 2 for artful.

Jeremy Bicha (jbicha) on 2017-09-07
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-user-share (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Let's just wait for 18.04 LTS for this. I'm unsubscribing ubuntu-release now.

summary: - FFe: Sync gnome-user-share 3.18.3-2 (main) from Debian unstable (main)
+ Sync gnome-user-share 3.18.3-2 (main) from Debian unstable (main)
Changed in gnome-user-share (Ubuntu Artful):
status: Confirmed → Won't Fix
tags: added: upgrade-software-version
Jeremy Bicha (jbicha) on 2017-10-27
description: updated
description: updated
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package gnome-user-share - 3.18.3-2

---------------
gnome-user-share (3.18.3-2) unstable; urgency=medium

  * Fully drop Bluetooth from packaging, obsolete since 3.18.0.
  * Bump Standards-Version to 4.1.0

 -- Jeremy Bicha <email address hidden> Sun, 03 Sep 2017 10:28:16 -0400

gnome-user-share (3.18.3-1) unstable; urgency=medium

  * New upstream release.
  * Drop 30-build-Properly-expand-paths-in-gnome-user-share-webd.patch, merged
    upstream.
  * Bump debhelper compat level to 10.
  * Use non-multiarch path (/usr/lib/gnome-user-share) for libexecdir.

 -- Michael Biebl <email address hidden> Tue, 20 Sep 2016 12:48:27 +0200

gnome-user-share (3.18.2-1) unstable; urgency=medium

  * New upstream release.
  * Add Build-Depends on systemd on Linux to get the correct path for the
    systemd user unit directory.
  * Add patch to ensure systemd is not mandatory so we can build on non-Linux
    architectures.
  * Bump Standards-Version to 3.9.8.
  * Drop debian/dirs, no longer needed.
  * Convert from cdbs to dh.
  * Bump debhelper compatibility level to 9.
  * Add patch to properly expand paths in gnome-user-share-webdav.desktop.

 -- Michael Biebl <email address hidden> Fri, 02 Sep 2016 18:16:19 +0200

gnome-user-share (3.18.1-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.7

 -- Andreas Henriksson <email address hidden> Thu, 24 Mar 2016 16:12:22 +0100

gnome-user-share (3.18.0-1) unstable; urgency=medium

  * New upstream release.
    - drops ObexPush support which moved to gnome-bluetooth.
  * debian/rules: drop moving of obexpush autostart files.

 -- Andreas Henriksson <email address hidden> Fri, 25 Sep 2015 10:15:56 +0200

Changed in gnome-user-share (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers