network: should list NFS shares too

Bug #43363 reported by RedBoot
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-user-docs (Ubuntu)
Confirmed
Low
Unassigned

Bug Description

Binary package hint: nautilus

I've been trying to use the Shared Folders functionality in Dapper Drake beta (updates through today, 2006-05-07) After successfully exporting an NFS share on server, I ran Places, Network Servers on client. After a short wait, Windows workgroup networks and shared folders were available and functioning. NFS shares from server never appear.

I can go out the the CLI and issue "showmount -e 192.168.1.23" and it displays the available NFS share. I issue "mount -o rw 192.168.1.23:/shared /shared" and the NFS share mounts correctly.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug. You can add a network place to it but I'm not sure than NFS is made to be browsable the way you want. Usually you mount a share and don't browse a NFS network.

Anybody else knowing NFS with an option on that? Is that realistic for NFS or something not standard for the protocol?

Changed in nautilus:
assignee: nobody → desktop-bugs
Revision history for this message
Daniel Holbach (dholbach) wrote :

Maybe this should be turned into a spec.

Revision history for this message
RedBoot (scott-redboot) wrote : Re: [Bug 43363] Re: network: should list NFS shares too

If you mean by "spec" that it should be a feature, I would heartily agree.
The ability to browse for NFS shares would be pretty cool.

On 1/10/07, Daniel Holbach <email address hidden> wrote:
>
> Maybe this should be turned into a spec.
>
> --
> network: should list NFS shares too
> https://launchpad.net/bugs/43363
>

Revision history for this message
Daniel Holbach (dholbach) wrote :

We should probably close this bug and somebody should volunteer to add the spec here: https://blueprints.launchpad.net/ubuntu/+addspec

Revision history for this message
RedBoot (scott-redboot) wrote :

Okay, I gave it a shot. I'm new to this so I went to this site and added a
spec as "nautilus-browse-nfs."
Attached is a screenshot of the spec.
I wasn't sure what to put in the URL. I also don't see how to close the bug.
Scott
On 2/2/07, Daniel Holbach <email address hidden> wrote:
>
> We should probably close this bug and somebody should volunteer to add
> the spec here: https://blueprints.launchpad.net/ubuntu/+addspec
>
> --
> network: should list NFS shares too
> https://launchpad.net/bugs/43363
>

Revision history for this message
Daniel Holbach (dholbach) wrote :

Thanks for working on this.

Changed in nautilus:
status: Unconfirmed → Rejected
Revision history for this message
DaveAbrahams (boostpro) wrote :

In my opinion there's no way this should be marked invalid. As http://ubuntuforums.org/showthread.php?t=421182 describes, the documentation clearly states that you can browse NFS shares through the GUI. If you don't want to implement that right now, that's fine, but then this should be considered a valid documentation bug.

Changed in nautilus:
status: Invalid → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

could you make a screenshot of the dialog describing this or describe steps to get there?

Changed in nautilus:
status: Confirmed → Incomplete
Revision history for this message
DaveAbrahams (boostpro) wrote :

Quoting from the thread referenced above at http://ubuntuforums.org/showthread.php?t=421182 :

Files, Folders and Documents
Working with files
6.11. Navigating Remote Servers
6.11.2 To access network places

Quote:
If your system is configured to access places on a network, you can use the file manager to access the
network places.

To access network places, open the file manager and choose Places → Network Servers. A window opens that displays the network places that you can access. Double-click on the network that you want to access.

To access UNIX shares, double-click on the Unix Network (NFS) object. A list of the UNIX shares available to you is displayed in the file manager window.

To access Windows shares, double-click on the Windows Network (SMB) object. A list of the Windows shares available to you is displayed in the file manager window.
Also found here:

http://www.gnome.org/learn/users-guide/2.6/ch07s08.html

Revision history for this message
DaveAbrahams (boostpro) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

reassigning to documentation

Changed in nautilus:
assignee: desktop-bugs → nobody
status: Incomplete → New
Changed in gnome-user-docs:
importance: Wishlist → Low
Revision history for this message
Noel J. Bergman (noeljb) wrote :

Still broken, even if I publish the NFS shares via AVAHI, which probably ought to be the connection. My SAMBA shares are shown, and my SSH shares (published by AVAHI) are shown, but NOT the NFS shares, despite being published.

If NFS shares are published via AVAHI, they ought to be shown. Ironically, NFS shared published by AVAHI do appear on the Mac, just not on Gnome, q.v., http://ubuntuforums.org/showthread.php?t=523928

Revision history for this message
sevka (sevka) wrote :

Hi guys. I made Nautilus plugin for NFS sharing and browsing. Check it out:
http://nfs-lan.sevka.info/
It based on avahi and autofs.

Ok, it's only alpha version. But it's work on all my PC's and I gonna continue to work on it.

There is a deb package. Source will be soon on the Github I think, because Launchpad is too complicate for me.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-user-docs (Ubuntu):
status: New → Confirmed
Revision history for this message
Tudor Holton (tudor) wrote :

I've also written about the fact that nfs:// as a prefix doesn't work in Nuatilus->Connect to Server on 15.10 either. http://askubuntu.com/questions/748397/how-do-i-mount-nfs-through-nautilus

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers