gnome-tweaks missing dependency for gnome-shell-extension-prefs

Bug #1868932 reported by Jeffrey Bouter on 2020-03-25
74
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gnome-tweaks (Ubuntu)
High
Unassigned

Bug Description

gnome-tweaks does not install gnome-shell-extension-prefs as a dependency, resulting in not being able to configure newly installed gnome-shell extensions (the cogwheel in tweaks > extensions does not work without gnome-shell-extension-prefs)
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu21
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 20.04
InstallationDate: Installed on 2020-03-17 (7 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Alpha amd64 (20200315)
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
Package: gnome-tweaks 3.34.0-2
PackageArchitecture: all
ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
Tags: focal
Uname: Linux 5.4.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip input libvirt lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True

Jeffrey Bouter (jbouter) on 2020-03-25
tags: added: focal gnome-shell-extension-prefs gnome-tweak-tool gnome-tweaks
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-tweaks (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) wrote :

I also found that after installing gnome-shell-extension-prefs the 'cog-wheel' in tweaks then worked by displaying the relevant dialog.

lotuspsychje (lotuspsychje) wrote :

Thank you for reporting this bug and make ubuntu better!

Please when filing bugs on ubuntu use: ubuntu-bug packagename (from terminal)
so relevant info pulls into the bug and developers can debug
better.
You can still pull the info into this bug with: apport-collect 1868932

thank you!

apport information

tags: added: apport-collected
description: updated

apport information

apport information

Jeffrey Bouter (jbouter) wrote :

@lotuspsychje

Thanks for your reply. I've added the information and will do so immediately in the future.

Raymond Kimathi (rmkimathi) wrote :

gnome-shell-extension-prefs seems to have been removed by some updates. Also missing in latest daily ISO clean installs. Extensions App also missing. Gnome-tweaks extension preferences cannot be launched.

Changed in gnome-tweaks (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-tweaks - 3.34.0-2ubuntu1

---------------
gnome-tweaks (3.34.0-2ubuntu1) focal; urgency=medium

  * debian/control.in:
    - Depends on gnome-shell-extension-prefs (lp: #1868932)

 -- Sebastien Bacher <email address hidden> Mon, 06 Apr 2020 10:09:08 +0200

Changed in gnome-tweaks (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers