Ubuntu Dock extension cannot be disabled in the Ubuntu session

Bug #1713020 reported by Alin Andrei on 2017-08-25
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gnome-tweak-tool (Ubuntu)
Wishlist
Unassigned

Bug Description

While using the Ubuntu session, the Ubuntu Dock extension cannot be disabled. After disabling it in the Tweaks application, the dock continues to be displayed, even after restarting GNOME Shell / a session restart. Here's a screenshot: http://i.imgur.com/xEKlEHJ.png

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell-extension-ubuntu-dock 0.3
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
ApportVersion: 2.20.6-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Aug 25 13:00:37 2017
InstallationDate: Installed on 2017-08-11 (14 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170807)
PackageArchitecture: all
SourcePackage: gnome-shell-extension-ubuntu-dock
UpgradeStatus: No upgrade log present (probably fresh install)

Alin Andrei (nilarimogard) wrote :
Mauro Gaspari (ilvipero) wrote :

Affects me as well, I am testing ubuntu 17.10 64bit on a virtualbox VM and I have the same issue.
I tried disabling all extensions, relogging, rebooting, but ubuntu dock extension is always there

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks but that's not a bug, if you want to get a session without the ubuntu dock then log into GNOME and customize your session as you wish. You can read https://didrocks.fr/2017/08/18/ubuntu-gnome-shell-in-artful-day-5/ which gives some details on the ubuntu session customization

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Invalid
Mauro Gaspari (ilvipero) wrote :

Thanks for the clarification and for the link. It is very informative.

Just a quick question to close this request. So, by default I only see Ubuntu and Ubuntu on Xorg.
Will gnome session be available in ubuntu desktop later down the road, or do we need to install it manually using: sudo apt-get install gnome-session?

Thanks
Mauro

Christopher M. Rogers (cajhne) wrote :

If anyone really hates having no option to hide the dock entirely, a work around is to do the following song and dance:

1. Install the dash to dock extension: https://extensions.gnome.org/extension/307/dash-to-dock/
2. Install the tweak tool (sudo apt-get install gnome-tweak-tool)
3. open the tweak tool and navigate to the extensions section
4. Activate dash to dock (flip switch to "ON")
5. Edit settings by clicking the little gear next to the switch
6. Choose position on screen: left
7. Turn "intelligent auto-hide" ON
8. Click the gear button for settings
9. check the "enable push to show" tickbox
10. Set pressure to 300 or higher so you don't accidentally trip it by mistake

Then the dock acts mostly like vanilla gnome again, only coming up when you hit the Super key, or go to the Actions menu.

All this configuration nightmare could be prevented by developers simply adding an "off" option under the new Ubuntu Dock settings for display "right, left, bottom, off".

Thanks for the work everyone.
-C

Joseph Jasson (joseph-jasson) wrote :

@Sebastian Bacher(seb182). In the Gnome Tweak tool the Ubuntu dock is shown with a On/Off switch next to it. When the switch is in the "Off" position the Ubuntu dock is still displayed.

It may not be your intention to allow the Ubuntu dock to be switched off (an incomprehensible stance), but having the Ubuntu dock still displayed when the On/Off switch is in an off position is a bug.

Either the fact that there is an "Off" option is a bug or the fact that the dock is displayed in the "Off" position is a bug. Either way, there is a bug.

It is so frustrating that the Gnome DEVS don't listen to what their users repeatedly say they want, or in this case, don't want. Some of us would like to turn the dock off. It is not such an alien concept, nor is it unreasonable.

Mauro Gaspari (ilvipero) wrote :

Just to clarify my comment.
If you do not want to see the custom "Ubuntu" session with Gnome extensions that cannot be disabled, you can do the following:

1. from terminal, install gnome session: sudo apt-get install gnome-session gnome-session-wayland
2. logout.
3. on login, click the gear icon, select Gnome instead of Ubuntu.
4. Done, you can now enjoy Ubuntu with vanilla Gnome session.

Couple of notes:

- I agree with comments by Joseph Jasson. Having said that, I understand how Canonical is trying to help its user base with a smooth transition, and I appreciate the effort. If "Ubuntu" session's extensions cannot be tweaked it would be great if those few extensions could have their on/off button greyed out or removed, just for clarity.

- Ubuntu-Gnome is no more as far as I understand, so Ubuntu 17.10 will have to serve both Unity and Gnome fans. With this in mind, I believe it would be great if gnome-session gnome-session-wayland could be installed by default. This could help users switch to the desktop environment they prefer.

I hope this helps
Mauro

Gargoyle (g-rgoyle) wrote :

I'm really confused now.

I've upgraded to 17.10. On my login screen I choose "GNOME on X.org" and NOT "Ubuntu".

I too see the option in tweak tool to disable ubuntu dock, but toggling the switch has no effect.

So the answer "Install gnome-session" for a vanilla gnome doesn't seem to actually work. (At least not for some upgrade paths).

So, like Joseph Jasson wrote, one way or another there is a bug. Either in the tweak tool or in the extension itself.

Changed in gnome-shell-extension-ubuntu-dock (Ubuntu):
status: Invalid → Confirmed
Gargoyle (g-rgoyle) wrote :

Sorry. By bad on the login description! I was confusing "Ubuntu" and "Unity" - damn this transition phase :-(

If I choose "Ubuntu on X.org" I cannot disable the dock, but if I choose "GNOME on X.org" I can.

However, I still think this bug stands. Ether stop the extension from showing in Tweak Tool, or allow us to disable it.

Sebastien Bacher (seb128) wrote :

Right, gnome-tweak-tools should communicate better that you can't do the action and why (and maybe what to do if you really want to change those settings, install GNOME vanilla and use that one)

affects: gnome-shell-extension-ubuntu-dock (Ubuntu) → gnome-tweak-tool (Ubuntu)
Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and help make Ubuntu better.

I'm marking this a duplicate of bug 1718850 because that's the bug we're using to track Tweaks not showing that "system" extensions like the Ubuntu Dock cannot be disabled.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers