default set of installed themes needs to be changed

Bug #335888 reported by Kenneth Wimer on 2009-02-28
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-themes (Ubuntu)
High
Martin Pitt
Jaunty
High
Martin Pitt
gnome-themes-ubuntu (Ubuntu)
High
Martin Pitt
Jaunty
High
Martin Pitt
ubuntu-meta (Ubuntu)
High
Martin Pitt
Jaunty
High
Martin Pitt

Bug Description

Binary package hint: gnome-themes

For Jaunty, we need to remove these themes:
Crux
Glider
Glossy
Mist

from gnome-themes package and include these:

https://code.launchpad.net/~dusttheme-dev/dusttheme/0.3
and
https://code.launchpad.net/~ubuntu-new-wave/anton/devel

I'll help getting these new themes ready but the underlying work of splitting the package into pieces still needs to be done.

Kenneth Wimer (kwwii) on 2009-02-28
Changed in gnome-themes:
assignee: nobody → pitti
status: New → Confirmed
Martin Pitt (pitti) wrote :

SABDFL priority

Changed in gnome-themes:
importance: Undecided → High
Pedro Fragoso (ember) wrote :

Should we move that themes to something like gnome-themes-extra?

Martin Pitt (pitti) on 2009-03-03
Changed in gnome-themes:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Right, what Pedro said. Including third party themes into the gnome-themes package is a pain; we should put them into gnome-themes-extra, and if we don't want to install all of those by default, split that too.

I will use this bug for the package split.

Martin Pitt (pitti) wrote :

ubuntu-desktop needs to be changed to point to gnome-themes-selected only (and perhaps -extras).

Changed in ubuntu-meta:
assignee: nobody → pitti
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-themes - 2.25.92-0ubuntu1

---------------
gnome-themes (2.25.92-0ubuntu1) jaunty; urgency=low

  * New upstream release:
    - Translation updates.
  * Split Clearlooks, Inverted, and Simple into a new package
    gnome-themes-selected, so that we don't need to install the less shiny
    ones by default. (LP: #335888)
  * debian/control.in: Drop obsolete Conflicts/Replaces for packages which
    were last seen in dapper.

 -- Martin Pitt <email address hidden> Tue, 03 Mar 2009 16:49:58 +0100

Changed in gnome-themes:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :
Changed in gnome-themes:
status: Fix Released → Fix Committed
Changed in ubuntu-meta:
status: Triaged → Fix Committed
Changed in gnome-themes:
status: Fix Committed → Fix Released
Dan Andreșan (danyer) wrote :

OK, this bug has two parts: removing some "not so nice" Gnome themes and adding New Wave and Dust.
Now it says "fixed", gnome-themes-selected contains only the "nice" Gnome themes (part 1 done), but were are New Wave and Dust (part 2 of the bug)?

community-themes contains New Wave, Dust, Kin ... is this the package I need? Should it be made part of "main"?

Hmm, it seems I'm missing something...

Kenneth Wimer (kwwii) wrote :

Essentially this is the result of Mr Martin Pitt's amazing work (you ROCK!). I didn't expect this to happen so quickly. I'll work on getting the new themes into the package tomorrow and resolving this issue. The community-themes package will be updated accordingly with some stuff from the Jaunty artwork effort as well as, perhaps, some extras for the Dust and NewWave (not sure about this part, just an idea atm.)

Vishal Rao (vishalrao) wrote :

Can we get the "Dust Sand" mod of Dust included as well, if not already there?

Michael Janos (spikeybadooks) wrote :

any chance a theme such as impression will make it in?
https://wiki.ubuntu.com/Artwork/Incoming/Jaunty/Impression

Martin Pitt (pitti) wrote :

Right, I added a g-themes-extras task, where these new themes will be included (I guess). Ken, assigning to you while the new themes themselves get sorted out. Please assign to me once they are ready, I can deal with including them into the packaging and uploading them.

Please also let me know whether the entire -extras package should be added to ubuntu-desktop (i. e. installed by default), or whether it should be split into a default and -extras-extras :) part as well or so.

Changed in gnome-themes-extras:
assignee: nobody → kwwii
status: New → In Progress
Åskar (olskar) wrote :

For the themes to be removed, they can not be added to ubuntu-desktop, am I right? :o

Kenneth Wimer (kwwii) wrote :

they are being added to another package and will still be installable

Dan Andreșan (danyer) wrote :

I guess Åskar wanted to remove gnome-themes package (and remain only with gnome-themes-selected), but this is not yet possible as ubuntu-desktop metapackage requires gnome-themes.

At least this is what I wanted and I was not allowed ;)

Dan Andreșan [2009-03-04 15:38 -0000]:
> I guess Åskar wanted to remove gnome-themes package (and remain only
> with gnome-themes-selected), but this is not yet possible as ubuntu-
> desktop metapackage requires gnome-themes.

That's the ubuntu-meta task on this bug; I didn't upload it yet, since
I wanted to wait for the -extras stuff.

John McHugh (mrmcq2u) wrote :

I think the shiki metacity theme would be a better option, its more coherent than dust. The icon theme is also very good as the icons are of high res and are more complete than human icon set. They include icons for more mimetypes like .java, .php, .html etc. The only bad thing about it is that it replaces the ubuntu icon on the applications menu but that can be fixed easily.

Kenneth Wimer (kwwii) wrote :

The Dust, Dust Sand and New Wave theme will be added to the list of themes installed by default. All of these pieces are included in the attached package (which does not build because the makefiles need love)

Dave Stroud (bigdavesr) wrote :

I have looked into dust themes and am sure some people like them. I do not nor does my grandmother. I think they should be made as extras and not in default. Thanks

Martin Pitt (pitti) on 2009-03-07
Changed in gnome-themes-extras:
assignee: kwwii → pitti
importance: Undecided → High
Mathias Menzer (mfm) wrote :

Dust and Ubuntu New Wave both feature dark window decorations. Using a notebook, you have to set the backlight to a high setting if it should still be usable. Keeping a brighter theme in the default installation should really be considered.

Martin Pitt (pitti) wrote :

Mathias Florian Menzer [2009-03-09 12:09 -0000]:
> Dust and Ubuntu New Wave both feature dark window decorations. Using a
> notebook, you have to set the backlight to a high setting if it should
> still be usable. Keeping a brighter theme in the default installation
> should really be considered.

Please note that we aren't discussing changing the default theme in
Jaunty; this will remain Human. We are just discussing shipping more
themes in a standard installation.

I 100% agree that a dark theme is wrong from both brightness as well
as ergonomics aspects, so I'll argue hard against such a change in any
release. :-)

Martin Pitt (pitti) wrote :

So I fixed up the automake crap, and got the package to build; however, the three new themes don't actually work. They appear in the theme selector, but just with a big question mark preview, and if I select them, it says that it isn't installed. But it's there..

$ dpkg -L gnome-themes-extras | grep NewWave
/usr/share/themes/NewWave
/usr/share/themes/NewWave/metacity-1
/usr/share/themes/NewWave/metacity-1/metacity-theme-1.xml
/usr/share/themes/NewWave/index.theme
/usr/share/themes/NewWave/gtk-2.0
/usr/share/themes/NewWave/gtk-2.0/gtkrc

What else is needed for them to work?

Changed in gnome-themes-extras:
assignee: pitti → kwwii
status: In Progress → Incomplete
Martin Pitt (pitti) on 2009-03-10
Changed in ubuntu-meta:
status: Fix Committed → Triaged
Dilomo (ankere) wrote :

Hello Martin,

I'm the author of New Wave. I noted that there are no other files in these directories that are needed for the theme. Download a copy from gnome-look[1] and examine the structure of the theme newwave-073.tar.gz inside the package. Right now I'm developing version 0.8.0 that is going to be a good improvement over the 0.7.x series but OpenOffice is making problems. Should I consider it for Ubuntu or we should stay with the older 0.7.3?

[1] http://www.gnome-look.org/content/show.php/New+Wave?content=87134

Martin Pitt (pitti) wrote :

current .deb, for testing

Shouldn't there be a conflicts on community-themes <= 0.13?

Download full text (21.2 KiB)

Also, Dilomo is right. None of the needed images are being installed.

For comparison:

andrew@andrew-laptop:~$ dpkg -L community-themes | grep NewWave
/usr/share/themes/NewWave
/usr/share/themes/NewWave/metacity-1
/usr/share/themes/NewWave/metacity-1/icon_restore_u_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_minimize_u_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_close_dlg_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_minimize_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_minimize.png
/usr/share/themes/NewWave/metacity-1/icon_close_dlg_u.png
/usr/share/themes/NewWave/metacity-1/icon_close_utility_u.png
/usr/share/themes/NewWave/metacity-1/icon_minimize_u_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_restore_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_maximize_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_restore_u_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_maximize_u.png
/usr/share/themes/NewWave/metacity-1/icon_maximize_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_restore_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_close_utility_pressed_u.png
/usr/share/themes/NewWave/metacity-1/icon_close_dlg_pressed_u.png
/usr/share/themes/NewWave/metacity-1/icon_close_u_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_restore_u.png
/usr/share/themes/NewWave/metacity-1/menu_bg.png
/usr/share/themes/NewWave/metacity-1/icon_close_dlg_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_maximize_u_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_minimize_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_close_u.png
/usr/share/themes/NewWave/metacity-1/icon_close_utility_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_minimize_u.png
/usr/share/themes/NewWave/metacity-1/icon_close_u_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_close_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_close_utility.png
/usr/share/themes/NewWave/metacity-1/icon_maximize_u_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_close_prelight.png
/usr/share/themes/NewWave/metacity-1/icon_maximize.png
/usr/share/themes/NewWave/metacity-1/icon_restore.png
/usr/share/themes/NewWave/metacity-1/icon_close_utility_pressed.png
/usr/share/themes/NewWave/metacity-1/icon_close.png
/usr/share/themes/NewWave/metacity-1/icon_close_utility_prelight_u.png
/usr/share/themes/NewWave/metacity-1/icon_close_dlg_prelight_u.png
/usr/share/themes/NewWave/metacity-1/icon_close_dlg.png
/usr/share/themes/NewWave/metacity-1/metacity-theme-1.xml
/usr/share/themes/NewWave/gtk-2.0
/usr/share/themes/NewWave/gtk-2.0/gtkrc
/usr/share/themes/NewWave/gtk-2.0/Images
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs/right-gap-start.png
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs/tab-left-active.png
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs/right-gap-end.png
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs/tab-left.png
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs/notebook-left.png
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs/notebook-top.png
/usr/share/themes/NewWave/gtk-2.0/Images/Tabs/tab-bottom-active.png
/usr/share/themes/NewWave/gtk-2.0/I...

Kenneth Wimer (kwwii) wrote :

Right, this appears to be a problem with the makefiles not installing the subdirectories and the files/dir within ithem

Martin Pitt (pitti) wrote :

Ken,

ah, the problem rather seems to be that the tarball you attached above doesn't contain those images at all.

I think I'll just grab the files from the original bzr trees; is there anything I need to throw out of them?

I'm also sufficiently annoyed by this bl***y autotools stuff that I'll just rip it out completely and replace it with a sane and simple dh_install and tiny Makefile for i18n.

Changed in gnome-themes-extras:
assignee: kwwii → pitti
status: Incomplete → In Progress
Dilomo (ankere) wrote :

What version of new wave are we talking about? With dark menus or with light ones? Which one will be included?

Martin:
you should take my theme from gnome-look as in th bzr the folders are not named very good (e.g newwave-theme in bzr and NewWave in the other package). Here's the link:

 http://www.gnome-look.org/content/show.php/New+Wave?content=87134

So I did not understand which version is better for inclusion? 0.7.3 or the new 0.8.0 that is going to be released soon?

Martin Pitt (pitti) wrote :

OK, I gave this another thought. gnome-themes-extras also exists in Debian, so we'd divert even further. Plus, to make this sane in any kind, I'd need to completely restructure the packaging and orig.tar.gz order.

However, it seems that the new themes that Ken added are precisely the ones that we want to install by default. Thus I'll do a completely new source package gnome-themes-ubuntu instead of mess up gnome-themes-extras even further.

Martin Pitt (pitti) wrote :

I packaged gnome-themes-ubuntu now.

bzr: https://code.launchpad.net/~ubuntu-desktop/gnome-themes/gnome-themes-ubuntu
preview package: https://launchpad.net/~ubuntu-desktop/+archive/ppa

However, before I can upload this, I need to ask the author of the Dust theme to declare a copyright and put a license into his branch. I'll contact him now.

Hello Kido,

as discussed in https://launchpad.net/bugs/335888, we'd like to
include the Dust and Dust Sand themes in the Ubuntu default
installation. Many thanks for creating those!

However, in order for us to be able to do this, the sources
(lp:dusttheme) need to have a copyright and license declaration.

The Launchpad project page says that this is intended to be GPL. Thus
can you please copy /usr/share/common-licenses/GPL-3 into your
branch as file "COPYING"? If you want to use a different license, such
as CC-BY-SA 2.5, please do that, of course. But it needs to have a
full copy of the license.

For the copyright, you should add something like this to e. g. README:

  Copyright (C) 2009 Ricardo Mariano II
  Author: Ricardo Mariano II <email address hidden>
  License: GPL v3, see file "COPYING".

Committing those to bzr is enough, since I pull from that to package
gnome-themes-ubuntu.

Thank you!

Martin
--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Dilomo [2009-03-11 9:17 -0000]:
> What version of new wave are we talking about? With dark menus or with
> light ones? Which one will be included?

Ken?

> Martin: you should take my theme from gnome-look as in th bzr the
> folders are not named very good (e.g newwave-theme in bzr and
> NewWave in the other package). Here's the link:

I renamed it to "New Wave", since that's what the theme requires
indeed.

> So I did not understand which version is better for inclusion? 0.7.3 or
> the new 0.8.0 that is going to be released soon?

Sorry, I thought lp:dusttheme was the canonical upstream location. I'm
happy to get it from gnome-look.org if you think that's better.

Dilomo (ankere) wrote :

Well it really doesn't matter as long as the folders are named correctly. Btw lp:dusttheme is only for the Dust theme. You could find New Wave here:

https://launchpad.net/anton

Martin Pitt (pitti) wrote :

Dilomo [2009-03-11 11:29 -0000]:
> Well it really doesn't matter as long as the folders are named
> correctly. Btw lp:dusttheme is only for the Dust theme. You could find
> New Wave here:
>
> https://launchpad.net/anton

I know, that's where I pulled it from. Sorry if I was confusing.

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Colin Watson (cjwatson) on 2009-03-11
Changed in ubuntu-meta:
importance: Undecided → High
Yann Dìnendal (yannbreliere) wrote :

Will there also be the GDM and Lock-Dialog themes?

Kenneth Wimer (kwwii) wrote :

Not sure what you mean...are you talking about the dark gtk theme used in GDM? If so, no, the gtk theme used in GDM is not a full gtk theme, ie. it only covers the parts needed for GDM (and will be changed sometime soon).

No, sorry, I meant the New Wave GDM (
http://www.gnome-look.org/content/show.php/New+Wave+GDM?content=87370), the
New Wave GDM Face browser (
http://www.gnome-look.org/content/show.php/New+Wave+Gdm+Face+Browser?content=88403),
and New Wave Lock-Dialog Theme(
http://www.gnome-look.org/content/show.php/New+Wave+Lock-Dialog+Theme?content=87773).
I think this is especially nice, as I had never seen a theme for the
screensaver dialog!

Yann Dìnendal

Kenneth Wimer (kwwii) wrote :

For Jaunty, I'm happy that we got this theme change finished :-) For Karmic we will be looking into including more theme and more backgrounds by default. Offering users a choice is important, it's just too late in this cycle for such changes.

On Wed, 2009-03-11 at 11:37 +0100, Martin Pitt wrote:
> Hello Kido,
>
> as discussed in https://launchpad.net/bugs/335888, we'd like to
> include the Dust and Dust Sand themes in the Ubuntu default
> installation. Many thanks for creating those!
>
> However, in order for us to be able to do this, the sources
> (lp:dusttheme) need to have a copyright and license declaration.

Thank you so much for including the themes! I've added the required info
to the COPYING and README files.

Kido

Martin Pitt (pitti) wrote :

Thanks Kido! I updated gnome-themes-ubuntu accordingly and uploaded it to Ubuntu, awaiting NEW review now.

Changed in ubuntu-meta:
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

gnome-themes-ubuntu (0.1) jaunty; urgency=low

  * Initial release: (LP: #335888)
    - "Dust" and "Dust Sand" by Ricardo Mariano II, from lp:dusttheme r52.
    - "New Wave" by Dilomo, from lp:anton r6.

 -- Martin Pitt < <email address hidden>> Fri, 13 Mar 2009 19:28:13 +0100

Changed in gnome-themes-extras:
status: In Progress → Fix Committed
Changed in gnome-themes-ubuntu:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Committed to ubuntu desktop seed.

Changed in ubuntu-meta:
status: In Progress → Fix Committed
Dilomo (ankere) wrote :

Thanks Martin,

I want to ask if it is possible to Install two New Wave themes with dark and light menus as the Images sub folder is the same for both themes (could be linked for the dark version)? As this direcory contains data for both themes it is only a matter of adding one small file that modifies the menu system to dark one. I attach both of the themes (ver 0.8 rc) in one package for reference.

Kenneth Wimer (kwwii) wrote :

My mandate for Jaunty was to add these three themes (as reflected in the current package). It is *really* late in the cycle but maybe we can look into adding it as a gtk theme (not a metatheme in the main theme selection UI). I am not promising anything though :-)

Dilomo (ankere) wrote :

If you decide to add and update packages you will probably include version 0.7.3 of the theme. If you want the latest 0.8 please let me know and I will send it to you (the above 0.8.0 beta version has to be changed a bit in order to work in all cases).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.139

---------------
ubuntu-meta (1.139) jaunty; urgency=low

  * Refreshed dependencies
  * Added evolution-indicator to desktop-recommends [hppa]
  * desktop: Replace gnome-themes with gnome-themes-selected and
    gnome-themes-ubuntu. (LP: #335888)

 -- Martin Pitt <email address hidden> Mon, 16 Mar 2009 15:11:52 +0100

Changed in ubuntu-meta:
status: Fix Committed → Fix Released
Dilomo (ankere) wrote :

@Andrew

I can't open up the gtk-2.0 folders to see it's contents. I get a message :

'Not Found

The resource could not be found. '

What could I do in order to see the files?

Dilomo:

There are problems viewing directories with spaces in their names on the on-line interface. If you have Bazaar installed, check out the branch with:

bzr branch lp:~andrewsomething/gnome-themes/new-wave-dark-menus

Kenneth Wimer (kwwii) wrote :

Dilomo: please send me the latest stuff you have which has been tested well enough to be included in Jaunty and has no regressions (ie no new bugs please, preferably fixes!). I will see what I can do to get it in before the beta deadline on thursday.

Kenneth Wimer (kwwii) wrote :

Andrew: it seems you understand the best way to install this theme, with both dark and light options for gtk (only). Do you have the newest stuff together and tested for Jaunty?

Sorry to play catch up, here...but in the last few days before Beta I am working on several different issues at once. It's excellent to have the help and I'd like to make the most of it. Sorry if I've seemed unresponsive (it might have been the week in South Africa working without a decent internet connection!)

Dilomo (ankere) wrote :

I attach the themes of version 0.8 and a firefox theme that is beta version. The dark menus theme is full (no links to new wave). It's size can be greatly reduced by linking the images folder to the new wave one and linking the 'default-gtkrc' file to the new wave 'gtkrc' (they are basically the same resource files).

Ken:
I will try to post( as an attachment) the package to the ubuntu-art list for testing but I think that there is no regression and the theme is better than 0.7.x.

Dilomo (ankere) wrote :

I still haven't tested the theme on Jaunty but I'm downloading it now. If you have time you could try it on your PCs too.

I've opened a new bug (Bug #344953) to discuss these changes since this thread is getting long and the original bugs are now all fix released. I've updated my branch to use the 0.8 versions of New Wave supplied above.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers