Dust window controls broken with new metacity button order

Bug #534728 reported by Kido on 2010-03-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Dust theme
Undecided
James Schriver
gnome-themes-ubuntu (Ubuntu)
Medium
James Schriver

Bug Description

Binary package hint: gnome-themes-ubuntu

With the new metacity button order, the Dust theme window buttons look inconsistent. The buttons were made to be in the old min,max,close order, and the new order is max,min,close. (See attached screenshot.)

Suggested fixes:
* Draw the button shadow (the dark part) separately, if possible.
* Change the buttons such that they look OK for this button order, or any order.

Kido (greasedbolt) wrote :
Changed in gnome-themes-ubuntu (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Kido (greasedbolt) wrote :

Fixed in bzr. (lp:~greasedbolt/dusttheme/0.5, rev 18)

Changed in dusttheme:
status: New → Fix Committed
Changed in gnome-themes-ubuntu (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
tags: added: kernel-series-unknown
tags: removed: kernel-series-unknown
Changed in gnome-themes-ubuntu (Ubuntu):
assignee: Andrew Starr-Bochicchio (andrewsomething) → nobody
status: Triaged → Incomplete

So now window controls seem to be defined by the theme and default to menu:min,max,close unless the theme changes it. So Dust in Lucid now displays correctly. Do we still want lp:~greasedbolt/dusttheme/0.5, rev 18 in Lucid?

James Schriver (dashua) on 2010-03-30
Changed in dusttheme:
assignee: nobody → James Schriver (dashua)
Changed in gnome-themes-ubuntu (Ubuntu):
assignee: nobody → James Schriver (dashua)
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-themes-ubuntu - 0.6.1

---------------
gnome-themes-ubuntu (0.6.1) lucid; urgency=low

  * Dust/Dust Sand: Add new murrine options separatorstyle and solid listview
    - Add terminal theming
    - Add menubar window dragging
    - Add activate slider
    - Add new tooltip style
    - Add gtk-auto-mnemonics
  * Dust: Fix light text in memenu's bar (LP: #532843).
    - Fix dark text on dark background FF dropdown list (LP: #532259).
    - Fix metacity themes to work with reverse button layout (LP: #534728).
    - Fix indicator-sound does not respect theme (LP: #532234).
 -- James Schriver <email address hidden> Tue, 30 Mar 2010 14:12:25 -0400

Changed in gnome-themes-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Paolo Sammicheli (xdatap1) wrote :

This isn't fixed in 5 April CD image. Buttons are still on left and it looks bad. (attached image)

Are you going to move with "max,min,close:" disposition? Since Ambiance/Radiance will stay in left side people are looking to Dust like an alternative for right button dark theme.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers