Update gnome core packages to 3.14

Bug #1399047 reported by Robert Ancell on 2014-12-04
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
clutter-1.0 (Ubuntu)
Undecided
Unassigned
gnome-control-center (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned
gnome-shell-extensions (Ubuntu)
Undecided
Unassigned
gnome-themes-standard (Ubuntu)
Wishlist
Jackson Doak
mutter (Ubuntu)
Undecided
Unassigned

Bug Description

Update to 3.14

Clutter needs syncing when the rest of the stack lands

Staging at https://launchpad.net/~ubuntu-gnome-packaging/+archive/ubuntu/core3.14

Related branches

Robert Ancell (robert-ancell) wrote :

Requires GTK+ 3.14 as the icon theme became the GTK+ default (bug 1399048)

Changed in gnome-themes-standard (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Jackson Doak (noskcaj) wrote :

Mostly fixed in my bzr branch. Awaiting adwaita MIR and clarification on if we need the recommends on gnome-icon-theme-full

Jackson Doak (noskcaj) on 2014-12-18
summary: - Update to 3.14
+ Update gnome core packages to 3.14
Changed in gnome-themes-standard (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Jackson Doak (noskcaj)
Jackson Doak (noskcaj) on 2014-12-18
description: updated
Jackson Doak (noskcaj) on 2014-12-18
description: updated
Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :
Jackson Doak (noskcaj) wrote :
tags: added: patch
Tim Lunn (darkxst) on 2014-12-20
description: updated
Tim Lunn (darkxst) on 2015-01-05
Changed in gnome-shell (Ubuntu):
status: New → Fix Committed
Changed in mutter (Ubuntu):
status: New → Fix Committed
Changed in gnome-shell-extensions (Ubuntu):
status: New → Fix Committed
Iain Lane (laney) on 2015-01-05
Changed in clutter-1.0 (Ubuntu):
status: New → Fix Released
Iain Lane (laney) on 2015-01-05
Changed in gnome-control-center (Ubuntu):
status: New → Fix Committed
Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Committed
Iain Lane (laney) on 2015-01-05
Changed in gnome-themes-standard (Ubuntu):
status: In Progress → Fix Committed
Iain Lane (laney) wrote :

Should be uploaded now, you'll need to get an archive admin to promote the new bits for g-s-d though

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-themes-standard - 3.14.2.3-0ubuntu1

---------------
gnome-themes-standard (3.14.2.3-0ubuntu1) vivid; urgency=medium

  * New upstream release. LP: #1399047
  * Merge from debian. Remaining changes:
    - debian/control.in:
      + Have gnome-themes-standard recommend gnome-icon-theme-full
      + Use Ubuntu Vcs link
    - debian/patches/ubuntu_a11y_fallback.patch:
      + Also have HighContrast inheirit from the Humanity icon theme
  * Depend on gnome-icon-theme | adwaita-icon-theme over adwaita-icon-theme

gnome-themes-standard (3.14.2.2-1) unstable; urgency=medium

  * New upstream stable release.
    + Many improvements in the GTK2 theming.

gnome-themes-standard (3.14.0-1) unstable; urgency=medium

  * New upstream release.

gnome-themes-standard (3.13.90-2) unstable; urgency=medium

  * Upload to unstable.

gnome-themes-standard (3.13.90-1) experimental; urgency=medium

  [ Andreas Henriksson ]
  * New upstream development release.
    - Note: default background moved to gnome-backgrounds.
    - Note: adwaita-icon-theme split out to separate source.
  * gnome-themes-standard-data:
    - stop installing adwaita icon theme, now built from its own source.
    - depend on adwaita-icon-theme
    - stop installing gnome-background-properties xml
  * Stop installing gtk-3.0 theme-engines (themes are now pure css)
  * Bump Standards-Version 3.9.5

  [ Sjoerd Simons ]
  * debian/control.in: Let gnome-themes-standard-data break gtk (<< 3.13). New
    themes can't be rendered by old gtk causing applications to be unusable.
 -- Jackson Doak <email address hidden> Thu, 18 Dec 2014 09:05:38 +1100

Changed in gnome-themes-standard (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

(unsubscribing sponsors, seems like the pending items have been handled)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.14.3-0ubuntu1

---------------
mutter (3.14.3-0ubuntu1) vivid; urgency=medium

  * New upstream release
  * Drop git patches included in new release

  [ Jackson Doak ]
  * Merge with Debian. Remaining changes: LP: #1399047
    - debian/patches/04_ignore_shadow_and_padding.patch:
      + Silently ignore padding and shadow tags (for light-themes)
    - Add Replaces for previous libmutter sonames, so that the library
      upgrades properly.
 -- Tim Lunn <email address hidden> Thu, 25 Dec 2014 07:32:02 +1100

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package gnome-control-center - 1:3.14.2-2ubuntu1

---------------
gnome-control-center (1:3.14.2-2ubuntu1) vivid; urgency=low

  [ Jackson Doak ]
  * Merge with Debian, remaining changes: LP: #1399047
    + debian/patches:
      - revert_git_new_bluetooth_panel.patch,
        revert_new_bluetooth.patch,
        revert-bluetooth-BlueZ5-interface.patch:
         Revert bluetooth back to Bluez4
      - 52_region_language.patch
        Adapt region panel to use Ubuntu style regions and UTF-8
      - 56_use_ubuntu_info_branding.patch,
        ubuntu-gnome-version.patch
         Use Ubuntu GNOME branding
      - 64_restore_terminal_keyboard_shortcut.patch
         Bring back terminal shortcut
      - 92_ubuntu_system_proxy.patch
         Add system proxy support
      - 99_add_lock-on-suspend.patch
         Add option to lock on suspend
      - revert_git_drop_library.patch,
        ubuntu_external_panels.patch
         Reimplement support for external panels
    + debian/control.in:
      - Relax build-deps on gnome-bluetooth
      - Drop Recommends for packages not in main
      - Various other Ubuntu specific changes
    + debian/libgnome-control-center1.symbols:
      - Add new symbols from external panel patch
    + Split out shared data that is used by unity-control-center
    + Add a wrapper to run unity-control-center in Unity
    + Install apport hook
  * Drop our revert_git_dont_hide_zoom.patch, no longer needed.

  [ Iain Lane ]
  * Do install the pkla file so actions work as expected.

gnome-control-center (1:3.14.2-2) unstable; urgency=medium

  * Remove system-config-printer recommendation.

gnome-control-center (1:3.14.2-1) unstable; urgency=medium

  * New upstream translation and bugfix release.
    + Disables SSLv3 because POODLE.
  * 30_stack_overflow.patch: patch from upstream git. Prevents stack
    overflow in sharing panel.
  * 31_printers_border.patch: patch from upstream git. Removes unwanted
    border around printer model name.

gnome-control-center (1:3.14.1-1) unstable; urgency=medium

  * New upstream release.
  * debian/control.in: Bump Standards-Version to 3.9.6 (no further changes)

gnome-control-center (1:3.14.0-1) unstable; urgency=medium

  * Bump gnome-settings-daemon dependency
    - 'org.gnome.settings-daemon.plugins.media-keys' key 'control-center'
      added during 3.13 and needed by gnome-control-center keyboard panel.
  * Drop Recommends on ntp since we now rely on systemd-timesyncd for
    automatic time (and AIUI ntp integration in gnome never really worked
    anyway because of the default configuration the debian package shipped).
  * New upstream release.
  * Upload to unstable.

gnome-control-center (1:3.13.91-1) experimental; urgency=medium

  [ Jordi Mallach ]
  * Add cracklib-runtime to Recommends, it's needed for password changing.

  [ Andreas Henriksson ]
  * New upstream development release.
  * Update build-dependencies according to configure.ac changes:
    - Bump gsettings-desktop-schemas-dev to (>= 3.13.91)
    - Drop libgnome-menu-3-dev
    - Bump libgtk-3-dev to (>= 3.13.0)
  * Update dependencies:
    - Drop gnome-menus
    - Bump gsettings-desktop-schemas to ...

Read more...

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell-extensions - 3.14.3-0ubuntu1

---------------
gnome-shell-extensions (3.14.3-0ubuntu1) vivid; urgency=medium

  * New upstream release (LP: #1399047)
 -- Tim Lunn <email address hidden> Thu, 25 Dec 2014 08:11:50 +1100

Changed in gnome-shell-extensions (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.14.3-0ubuntu1

---------------
gnome-shell (3.14.3-0ubuntu1) vivid; urgency=medium

  * New upstream release (LP: #1399047)
  * Drop git patches included in new release

  [ Jackson Doak ]
  * Merge from debian. Remaining changes:
    - debian/control.in:
      + Recommend gdm instead of gdm3
      + Add Recommends on network-manager since this
        is required for network panel to work.
      + Depend on gnome-session which due to package
        split now contains only the session files
    - debian/patches/ubuntu-lightdm-user-switching.patch:
      + Allow user switching when using LightDM.
    - debian/patches/ubuntu_lock_on_suspend.patch
      + Respect Ubuntu's lock-on-suspend setting.
    - source_gnome_shell.py: Now we have upstart user sessions most
      logging goes into the gnome-session-GNOME.log, so add this to the
      apport hook.
    - debian/patches/revert_new_bluetooth.patch: revert changes requiring Bluez5
  * debian/gnome-shell.gsettings-override: Replace iceweasel with firefox
 -- Tim Lunn <email address hidden> Thu, 25 Dec 2014 07:27:07 +1100

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package gnome-settings-daemon - 3.14.2-2ubuntu1

---------------
gnome-settings-daemon (3.14.2-2ubuntu1) vivid; urgency=low

  [ Jackson Doak ]
  * Merge with Debian, remaining changes: LP: #1399047
    + Split out schemas into gnome-settings-daemon-schemas so
      unity-settings-daemon can use them
    + debian/patches:
       - 05_disable_corner_tapping.patch:
          Disable corner tapping when disabling tap to click
       - 43_disable_locale_settings.patch:
          Don't set locales after sourcing .profile
       - 45_suppress-printer-may-not-be-connected-notification.patch
       - 53_sync_input_sources_to_accountsservice.patch
       - 64_restore_terminal_keyboard_shortcut_schema.patch
       - correct_logout_action.patch
          display the logout action on ctrl-alt-del (lp: #961501)
       - migrate_metacity_keys.patch
          Migrate screenshot/terminal keys from metacity gconf as well
          (LP: #1058004)
       - nexus-orientation.patch
          Fix screen rotation on nexus7
       - ubuntu-lid-close-suspend.patch
          Reimplement support for setting lid close suspend actions
       - ubuntu-force-lock-group.patch
          Lock the XKB group when ISO_Next_Group is pressed (lp: #1318673)
       - revert_background_dropping.patch
          Keep gsettings keys background u-s-d needs them
       - revert-gsettings-removals.patch
          Revert gsettings keys that were dropped since 3.8, for u-s-d
    + debian/gnome-settings-daemon.install: Install apport hook
    + debian/rules: install upstart scripts
  * We now have geoclue-2.0, so drop our revert
  * Disable new sharing plugin this requires Network Manager 0.9.10

  [ Tim Lunn ]
  * Drop ubuntu-force-lock-group.patch, this completely breaks input switching
    and the bug that it fixes is no longer reproducible

gnome-settings-daemon (3.14.2-2) unstable; urgency=medium

  * 01_reinstate_updates_plugin.patch: reinstate the “updates” plugin,
    since gnome-software is not in jessie and we need an update
    mechanism.
  * Use patch-translations.mk.
  * Reintroduce GNOME 3.12 translations.
  * Update packagekit-glib build-dependency.

gnome-settings-daemon (3.14.2-1) unstable; urgency=medium

  * New upstream translation and bugfix release.
  * 30_xrandr_dbus_init.patch: patch from upstream git. Fixes a crash
    due to a race condition in dbus initialization.

gnome-settings-daemon (3.14.1-1) unstable; urgency=medium

  * New upstream release.
  * debian/control.in: Bump Standards-Version to 3.9.6 (no further changes)

gnome-settings-daemon (3.14.0-2) unstable; urgency=medium

  * Do not enable networkmanager support on !linux architectures
  * debian/control.in:
    - Add libnm-util-dev to the build-dependencies
    - Depends against libpam-systemd instead of plain systemd package, g-s-d
      needs logind for several power related functionalities

gnome-settings-daemon (3.14.0-1) unstable; urgency=medium

  * New upstream release.
  * debian/gnome-settings-daemon.install: stop installing
    usr/share/dbus-1/services. See upstream commit
    "keyboard: Remove input sources handling".
  * Bump Breaks on gnome-shell to 3.13.92 because ...

Read more...

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers