Update to 3.6.1

Bug #1067207 reported by Jeremy Bicha
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-themes-standard (Ubuntu)
Medium
Jeremy Bicha

Bug Description

I started on this update, but it's not building with the hack I added to revert dropping the HighContrastInverse and LowContrast themes.

make[4]: Entering directory `/«PKGBUILDDIR»/themes/HighContrast'
gcc -DPACKAGE_NAME=\"gnome-themes-standard\" -DPACKAGE_TARNAME=\"gnome-themes-standard\" -DPACKAGE_VERSION=\"3.6.1\" -DPACKAGE_STRING=\"gnome-themes-$
/bin/bash ../../libtool --tag=CC --mode=link gcc -pthread -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/includ$
libtool: link: gcc -pthread -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/$
make[4]: Leaving directory `/«PKGBUILDDIR»/themes/HighContrast'
make[3]: Leaving directory `/«PKGBUILDDIR»/themes/HighContrast'
Making all in HighContrastInverse
make[3]: *** No rule to make target `all'. Stop.
make[3]: Entering directory `/«PKGBUILDDIR»/themes/HighContrastInverse'
make[3]: Leaving directory `/«PKGBUILDDIR»/themes/HighContrastInverse'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/«PKGBUILDDIR»/themes'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/«PKGBUILDDIR»'

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-themes-standard 3.6.0.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Mon Oct 15 22:08:54 2012
SourcePackage: gnome-themes-standard
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Jeremy Bicha (jbicha) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-themes-standard (Ubuntu):
status: New → Confirmed
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Unless we can get 3.6.1 to build with HighContrastInverse & LowContrast soon, I plan to upload 3.6.1 w/o those themes to raring right after we upload gnome-control-center 3.6.

Changed in gnome-themes-standard (Ubuntu):
importance: Undecided → Medium
status: Confirmed → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Revision history for this message
Sebastien Bacher (seb128) wrote :

is the failing to build version online somewhere? we should drop those anyway imho, cf " #964685 High contrast and High contrast inverse themes are poor quality for the Unity desktop "

Revision history for this message
Žygimantas Beručka (zygis) wrote :

Just noting that during the time v3.6.2 has also been released with the following changes:

* Add assets for insensitive radio/check states for the GTK2 theme
* Fix active spinner when no animations are in use
* Fix gray menu separators under some circumstances
* Fix the build on non-X11 environments
* Fix uneven padding on the notebook tab close button
* Fix minor glitch with borders of tiled WM decorations

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Seb, yes, I plan to upload gnome-themes-standard 3.6.2 to raring without the patch to try to keep HighContrastInverse and LowContrast, but I was waiting for gnome-control-center 3.6 to be uploaded since gnome-control-center 3.4 would need to be patched to not offer those themes.

At the moment, I don't think we'll be able to upload a newer gnome-themes-standard to 12.10 unless someone can figure out how to get the old themes to build. GNOME has made a lot of tweaks to the themes in 3.6.1 and 3.6.2.

Revision history for this message
Sebastien Bacher (seb128) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-themes-standard - 3.6.2-0ubuntu1

---------------
gnome-themes-standard (3.6.2-0ubuntu1) raring; urgency=low

  * New upstream release (LP: #1067207)
    - Fixes hard to read selected desktop items (LP: #1054701)
    - Spinner is now animated (LP: #1051851)
  * debian/control.in:
    - Build-depend on GTK 2
  * debian/patches/revert-drop-a11y-themes, debian/rules,
    debian/source/include-binaries, debian/gnome-accessibility-themes.install
    - Drop poorly maintained LowContrast and HighContrastInverse themes
      so that we can focus on making HighContrast better
      (LP: #964685, #958411)
  * debian/gnome-accessibility-themes.install:
    - Install all the icons
 -- Jeremy Bicha <email address hidden> Thu, 22 Nov 2012 11:24:34 -0500

Changed in gnome-themes-standard (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Žygimantas Beručka (zygis) wrote :

Any chance of getting this in Quantal? If not in quantal-updates then at least in GNOME 3 PPA. Raring is still irrelevant for the majority of users.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers