Ubuntu

Comment 7 for bug 99978

I would prefer to have that patch accept upstream which is the right place for it