Environment variable defaults are not updated when Network Proxy settings change

Bug #933619 reported by Boris Burtin on 2012-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

When network proxy settings change, the default values of http_proxy, ftp_proxy, and https_proxy are not updated. New terminal sessions still have the old proxy settings. To work around this, I have to manually unset the variables every time I start a new terminal session.

To repro:

* Change Method from "Manual" to "None" in the Network proxy tab of the Network settings app.
* Click "Apply system wide".
* Open a new terminal window.

$ env | grep -i proxy
http_proxy=http://proxy.vmware.com:3128/
ftp_proxy=ftp://proxy.vmware.com:3128/
UBUNTU_MENUPROXY=libappmenu.so
https_proxy=https://proxy.vmware.com:3128/

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-terminal 3.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-15.26-generic 3.0.13
Uname: Linux 3.0.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Feb 16 09:09:03 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
UpgradeStatus: No upgrade log present (probably fresh install)

Boris Burtin (boris-burtin) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers