11.10 gnome-terminal global app menu ignores "Show Menubar" setting. Always on.

Bug #888690 reported by Luke Hoersten on 2011-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

The gnome-terminal global app menu is always on despite how the "Show Menubar" setting is configured. This is particularly a pain for they key commands Alt+f and Alt+b which move forward and back by word. Instead, it opens the Menubar. Normally I get around that by disabling the Menubar but since 11.10, that doesn't take affect anymore.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-terminal 3.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Thu Nov 10 12:58:35 2011
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to oneiric on 2011-10-18 (23 days ago)

Luke Hoersten (lukehoersten) wrote :
Jeremy Bicha (jbicha) wrote :

This appears to be fixed with gtk+ 3.3.6-0ubuntu3 for Ubuntu 12.04 "Precise".

Changed in gnome-terminal (Ubuntu):
status: New → Fix Released
Luke Hoersten (lukehoersten) wrote :

This is not fixed in Precise 12.04. Confirmed still broken which makes keyboard shortcuts like "alt+B" not go "back by word" like it should if the app-menu wasn't stealing the keys.

Changed in gnome-terminal (Ubuntu):
status: Fix Released → Confirmed
Jeremy Bicha (jbicha) wrote :

Luke, you need to click Edit > Keyboard Shortcuts and make sure "Enable menu access keys" is unchecked. This has nothing to do with the appmenu.

Luke Hoersten (lukehoersten) wrote :

Jeremy, that's certainly a workaround but I'm not sure it means disabling the menu bar option is working correctly. Currently it basically has no effect.

Jeremy Bicha (jbicha) wrote :

That's not a workaround; that's how it's designed.

Anyway, for the View>Show Menubar option not doing anything in Unity, I'm marking this a duplicate of bug 787465.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers