menubar settings for new terminals are ignored in gnome-shell

Bug #873763 reported by Victor Zamanian on 2011-10-14
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

In gnome-terminal settings, I always disable the "Show menubar by default in new terminals" option. This seems better ignored in Unity since it has its global menu anyway. But this option should not be ignored in gnome-shell, which it seems to be. I disable the option, open new terminals, but the menubar is visible! In the View menu, the "Show Menubar" option is unchecked. I have to *check* that option in the View menu, then *uncheck* it to finally get rid of the menubar in a terminal. If the option is *enabled*, then the option is *checked* in the View menu for new terminals.

Derek Monner (dmonner) wrote :

I see this behavior as well under Unity, even with global menus disabled (i.e. I uninstalled indicator-appmenu). Even with the profile setting "Show menubar by default in new terminals" unchecked, when I launch a new gnome-terminal, the menubar is displayed. As Victor described, the "Show menubar" option in the View menu is unchecked. If I check this option (to show the menu) and then un-check it again, the menubar goes away, but only for the current terminal. A menubar is again shown the next time I start a terminal.

Elias Martenson (lokedhs) wrote :

I found the same problem immediately after upgrading Ubuntu. When opening the terminal there is no menu bar, but within a second or so the menu bar appears.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Victor Zamanian (victorz) wrote :

Elias Martenson:

I get the same behavior with gedit for example. I do expect the menu bar to appear in gedit, but I expect it to appear at the same time as the rest of the application. Not 1 second after the application window is visible. Might this also be a bug, and related to this?

malice (unixpunx83) wrote :

Glad I'm not the only one seeing this. This is very irritating. I guess I'll be moving to Terminator for the time being.... Please fix this, Ubuntu-team! It can't be that difficult?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers