gnome-terminal extremely slow and display buggy

Bug #850649 reported by Christian Theune on 2011-09-15
292
This bug affects 62 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
gnome-terminal (Ubuntu)
Low
Unassigned

Bug Description

After the update to oneiric the gnome-terminal appears to be slow and display is sometimes buggy:

* changing between windows and tabs is slow although other applications (like chromium) are not affected
* sometimes the display is not updated and some parts (exactly on character box boundaries) of the terminal just show the background

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-terminal 3.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Thu Sep 15 08:28:30 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to oneiric on 2011-09-01 (13 days ago)

Christian Theune (ctheune) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Nicolás Lichtmaier (niqueco) wrote :

I use gnome-shell and I see this too.

tags: removed: running-unity
Ricardo Salveti (rsalveti) wrote :

I can confirm that this doesn't happen when using Unity-2D with Metacity (scroll is now fast at both chromium and gnome-console). Will try to run perf against compiz and see if I can find why it's so slow for me with Oneiric (it was fine with Natty).

Jonas Bygdén (jbygden) wrote :

This is hugely frustrating. As said above it affects many apps, but the most frustrating is that it affects all terminals - not just gnome-terminal, but xterm and rxvt as well.

I work as a sysadmin, and the terminals are my most used tool in my daily work. Not getting the output without an extra press on enter or a screen refresh is hugely annoying.

Let me know if there are any tests that I can perform for you to help you figure this out.

Jonas Bygdén (jbygden) wrote :

Oh, just to clarify. I experience this in Unity 3D and Gnome Shell 3D. Not in Unity 2D.

Toby Corkindale (tjc-wintrmute) wrote :

This effects me.. however it's not just gnome-terminal, but google chrome and firefox as well.

Basically, ALL window activity seems to be sluggish now.

This is on a Core i7 system, nVidia Quadro GPU, lots of RAM and a fast RAID array. It ran very snappily under Gnome in Natty!

Terminal tab switching is slower in 11.10 on my machine (Core2Duo@2GHz,4GB RAM) with Unity-2D too. Also workspace switching is a nightmare in vte based terminal implementations: https://bugs.launchpad.net/ubuntu/+source/vte/+bug/665548.
In 11.04 it was also slow however I could live with it.
Maybe vte is the key to this slowliness?

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
Olosta (hameltho) wrote :

On gnome-shell, restarting it fix the situation temporarily : "ALT+F2", command "r".

This looks like some kind of leaking to me.

Russell Nakamu (rhnakamu) wrote :

I use a 'visual beep' and often when I hit tab to complete a word and it 'beeps' the entire screen goes blank until I hit a key. I'm running GNU screen, and sometimes when the display comes back my status bar at the bottom is blank unless I detach and re-attach. Additionally, when I'm working with a debugger (pudb) or ipython sometimes a function will return from a call but since the screen doesn't refresh it looks like the program has hung up until I hit a key.

I've also noticed that sometimes when I re-attach screen the output seems to shrink - with extra whitespace added at the bottom until I exit out completely and re-start. I don't know if that's related or not, but it seems to have popped up at the same time as the terminal output problems.

Russell Nakamu (rhnakamu) wrote :

Just wanted to clarify, that when I said the whole 'screen' goes blank I mean the terminal (I work with it maximized).

Ben Gladwell (bengladwell) wrote :

I am also experiencing the original poster's problem. I can tell why the problem starts or stops, but it does happen frequently.

Olosta (hameltho) wrote :

I thought it was maybe something related to the overlay scrollbars, but disabling them does not change anything.

I also use an nVidia card, is it the same for every persons affected?

I can confirm the problem on 11.10 32-bit. I'm running gnome-session-fallback, without the overlay scrollbars.

Hardware: Acer Aspire laptop, Intel(R) Pentium(R) Dual CPU T3200 @ 2.00 GHz.
Display: Mobile Intel® GM45 Express Chipset x86/MMX/SSE2.

I usually have 3 or 4 tabs open, with unlimited scrolling enabled. It gets slower over time, but it's still about 2 seconds to start the very first tab.

I confirm the problem on Ubuntu 11.10 amd64 desktop. After a while or when the system is under any load, typing and switching tabs in the terminal becomes very slow. htop however often shows high CPU usage (100%) by /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Hardware: Precision WorkStation T5400: Quad Xeon E5420 (2.5GHz), 4GB RAM 667Mhz, SSD drive for root

Zhiyun Qian (qzy888) wrote :

I confirm the problem on Ubuntu 11.10.

Problem: Tab switching in terminal takes a whole second. Terminal window moving is slow. Terminal scrolling is laggy.

Hardware: Intel i7. nVidia card.

Gasol Wu (gasol-wu) wrote :

i have same problem on my Ubuntu 11.10 amd64 desktop since release,
i use lxterminal instead gnome-terminal, but still happen!

Hardware: Intel Core2Duo E5200, 4G RAM

Grzegorz Dyk (grzegorz-dyk) wrote :

I also have this problem. I've noticed that if I turn off background transparency in terminal it works a lot faster (as before). Perhaps it is a video card related issue? (using Nvidia video card)

Grzegorz Dyk (grzegorz-dyk) wrote :

EDIT: I correct myself: turning off transparent background does NOT help. Gnome terminal is still horribly slow.

GeekSmith (lixo-geeksmith) wrote :

I have this problem with a GeForce FX 5200 on Oneiric with the nouveau driver. The nvidia binary driver doesn't work on this system, BTW, but that's a different issue.

Not only is displaying (very!) slow, but the content of the terminal gets borked as well, meaning contents of the terminal are vanishing!

I find myself pressing ctrl-l (refresh display) repeatedly in vim to display my file correctly. This is a pretty serious bug for me, serious enough to consider switching to Fedora, so if I can do anything to help o tdebug this, please step forward and tell.

I made a video showcasing the bug: http://www.youtube.com/watch?v=oOms1TzIKCM

Olosta (hameltho) wrote :

The borked content bug is also on FC16. I switched from Ubuntu two weeks ago but that did not solve that particular problem.

I'm not sure about the slow terminal switching.

Jonas Bygdén (jbygden) wrote :

I concur with comment #23, I'm now running both Oneiric and F16 and both have this problem with nvidia and 3D, not in fallback though.

I suspect this bug is related to https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/877438

What do you think?

Olosta (hameltho) wrote :

Well, maybe (I use multi-monitor often) but :
  * I use gnome-shell and the borked content is definitely present in FC16. Unity can't be blamed here
  * Some people are complaining of the bug with Intel card (see #14), some people see the bug with nouveau driver, so the nvidia driver can't be blamed either
  * This leaves X.org and gnome-terminal

Jonas Bygdén (jbygden) wrote :

Well, I'm seeing this (what you call the "borked content") in xterm and urxvt as well, so that would eliminate gnome-terminal as well.

It can't be related to multi-monitor, since it's my laptop that's giving me the problem.

I'm also experiencing slow output. Scrolling any terminal surface causes instant 100% utilization of one processor core.
I haven't noticed any display corruption though.

some system info:

rafal@arnica:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
rafal@arnica:~$ uname -a
Linux arnica 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:28:43 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
rafal@arnica:~$ cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
rafal@arnica:~$ cat /proc/driver/nvidia/gpus/0/information
Model: Quadro NVS 140M

It's bothering me so much I'm considering using gprof to investigate it. As far as I understand it, I'd have to compile each piece of relevant software from source with special options to get meaningful output, starting from gnome-terminal and then digging into libraries. Is this correct?

Bryce Harrington (bryce) wrote :

Yes, I agree this sounds like it's not gnome-terminal at fault.

Typically issues like these are video driver problems and tend to be hardware-specific. The fact that several people are seeing it on different graphics cards and different drivers is likely coincidental. A lot of different kinds of graphics bugs can result in the generic symptom "slow with visual corruption".

Unfortunately this bug report is not actionable as written. It's missing the X logs and so forth.

There does seem to be a definite issue pertaining to the -nvidia driver, perhaps specific to NVIDIA 8xxx cards, which occurs when an external monitor is configured a certain way. This is bug #877438. If your situation matches those conditions, you can consider that your issue is the same as that bug. Indeed, the original poster's setup appears to match this, so I'm going to dupe this bug to that one.

For those of you who experience similar symptoms but are using a different video driver and/or different graphics cards, or see it with just a single monitor, please file a new bug. Run `ubuntu-bug xorg` to report it, which will collect logs and so on. Also, if you see visual corruption please also include a photo of the screen showing the corruption, as the size and pattern of the corruption often clues developers into where in the driver the failure is coming.

Bryce Harrington (bryce) wrote :

A couple other details which would help for classifying performance bugs:

 * If you have a multi-head arrangement, are you using twinview or xinerama (or xrandr for non-nvidia drivers)?

 * Do you experience it with Unity only, or also Unity 2d? If the issue also occurs with Gnome Shell, that's often well worth mentioning.

 * Does it *only* occur with gnome-terminal, or also with other programs?

 * Is the performance trouble continuous from boot, or does it only come on after some time or after some action? E.g. window movement, alt-tab, desktop switching, etc.

 * When did you first start noticing the performance issue? What ubuntu and driver versions were you using? Since then, what versions have you tested that still had the problem?

Performance problems are notoriously hard to track down, so the more you can do to define the problem (and esp. details on how to reproduce it), the easier it is for developers to pinpoint the problem.

Finally, it bears repeating that since -nvidia is closed source, there's generally little we can do on the Ubuntu end to help, although sometimes the compiz guys can disable features or take other steps to work around or minimize the problem. But more typically we need to forward the bug report upstream, and we generally only do this for really well written, precisely-defined bug reports, since we don't want to waste their time.

Two answer from my side: I'm using twinview multi-head. I only experience it in Unity. Other programs redraw is slowed (for instance it was slow to type in firefox), but generally the issue was much worse in gnome-terminal than other programs. It only comes on some time after start, and sometimes goes away. Goes away quicker on later nvidia drivers (290.03) - on earlier drivers I would need to reboot. Started noticing as soon as I installed 11.10 (I generally reinstall rather than upgrade).

I think it's mainly a compiz/unity/nvidia combination bug, but something is making it hit gnome-terminal worse than other programs.

Christian Theune (ctheune) wrote :

Ah. I just realized how the update mechanism for the NVIDIA driver is structured. I'll try the current/post-release updates now. Have been on 280 since the 11.10 release I guess.

Bo Nygaard Bai (bai-v) wrote :

I believe that this bug is not tied to Nvidia, which may mean that it not a duplicate of bug #877438.

I can confirm the bug on an multi headed Intel i7 system with an ATI Radeon HD6670.

Any gnome-terminal window that scrolls will slow down the entire desktop to crawl. Up to several seconds of delay when typing in another window.

I have tried tha various drivers including the xorg radeon driver from Oneric, the xorg radeon driver from the xorg-edgers PPA, the fglrx driver from Oneric and the latest fglrx driver from AMD. I have 3 active displays when using the radeon driver and 2 when using the fglrx driver. The bug is clearly present using any of these configurations.

I have also tried both the Gnome and the Unity desktops (all modes). They all have the same problem!

I used to have a window showing the live logs from my log server. In 11.04 this will makes my workstation completely unusable. The same setup on the same hardware was extremely fast and responsive when running 11.04.

I do not see the bug if I use an xterm for the scrolling window.

The problem is clearly not specific to neither Nvidia or a single display driver. It is most likely tied to the compiz and multi-head combination.

Bayle Shanks (bshanks) wrote :

There are multiple bugs being discussed in this thread, all of which fit the title and "bug description" at the top, but some of which are limited to various situations, and some of which are not. Not all of them are duplicates of bug #877438, and so the duplicate status should probably be removed.

A request was made above for "ubuntu-bug xorg", so here's one:

https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/919470

Note that in the case of bug 919470, there is slowness but no display corruption; bug DOES occur in Unity-2D; bug DOES occur in terminator as well as gnome-terminal; bug DOES NOT occur with xterm.

Bayle Shanks (bshanks) wrote :

p.s. i think "importance" should be greater than "low" for this bug; having a terminal with a lot of information being rapidly printed to it is an extremely common situation.

I agree. This is becoming more and more frustrating for me. I started to
use stdout redirection to a file to prevent output from being printent on
tje console.

BTW does anyone experience similar problems with gedit window (large
portions of text making it run veeery slowly for scrolling and editing)?
21-01-2012 02:20 użytkownik "Bayle Shanks" <email address hidden>
napisał:
>
> *** This bug is a duplicate of bug 877438 ***
> https://bugs.launchpad.net/bugs/877438
>
> p.s. i think "importance" should be greater than "low" for this bug;
> having a terminal with a lot of information being rapidly printed to it
> is an extremely common situation.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/850649
>
> Title:
> gnome-terminal extremely slow and display buggy
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/850649/+subscriptions

Owen Williams (ywwg) wrote :

This bug occurs for me when dynamic twinview is off, so I don't think it should be a duplicate. This problem *only* occurs with terminal-like programs.

I'm also having this issue with twinwiev on and off.
Gnome-terminal is heavily affected, but Chrome, Thunderbird, Eclipse etc. are not.

Bo Nygaard Bai (bai-v) wrote :

This bug is concerning low performance and graphical corruption of output in terminal like programs on ANY desktop using ANY driver on ANY number of screens!

Having followed discussions for this bug and bug #877438 for some time i am very confident that this is not a duplicate.

I have removed the duplicate status.

Please notice that there are several separate bugs that have similar symptoms but are not the same:

 * If you have an *nVidia* card and *multi headed* setup you may want to check out bug #877438
 * For slow performance in any *multi headed* setup using *Unity* on any driver check out bug #874619

These bugs are not duplicates but have somewhat similar symptoms. It is possible that you can be affected by more than one if these at same time, but they are not the same bug!

Olosta (hameltho) wrote :

I would add that for me, this bug affects gnome-shell (not sure if it's exclusive) and I also have it on FC16.

Actually I just found something that could be related on Fedora bugzilla :
https://bugzilla.redhat.com/show_bug.cgi?id=720605

There is a workaround, I'm testing this under FC16.

Itamar Rogel (itamar-rogel) wrote :

I have this and it is very very frustrating... Like going back to the stone age. Linux flavor that is bad for doing terminal work? That's a first ;-(

My setup is very simple - one screen (an HP laptop), old nVidia card, gnome-shell.

Mi-La (mi-la) wrote :

I would say it's really very ugly behavior even so I'm considering to switch to some other environment (e.g. Unity2D was ok).
I've similar problem also with gedit.
For my using this is the most important bug and I'll definitely stop using gnome-shell if it would be repaired soon :(.

Janne Savikko (jsavikko) wrote :

This affects me too when using precise.
I can resize other windows really nicely, but it takes *ages* to resize gnome terminal windows.

These error messages keep appearing in .xsession-errors file
> 16:00:52.093 E [p2p:240 ] Got bad file info from AP (Size=644)!
> (gnome-terminal:2784): Gtk-WARNING **: Unknown property: GtkHScale.update-policy
> compiz (decor) - Warn: failed to bind pixmap to texture
> 16:12:14.240 E [p2p:391 ] Broken substream a7df5fe31152cb9513b7d3e79f6d1e1525585e2a:12

tags: added: precise
Simon John (sej7278) wrote :

also got this slow resizing problem on debian sid and wheezy with nvidia gfx and gnome-terminal under gnome-shell.

i don't have the problem on any of the four ubuntu 12.04 machines i have, which all have intel gfx, although they run unity not gnome-shell.

i'd pretty much say that makes it an nvidia bug or gnome-shell bug, not a gnome-terminal bug.

Pramod Valavala (saip92) wrote :

This started to bug me since a few days. When I look up previous commands in the terminal, they do not get refreshed. I have to move the cursor from the left to the right to see what the command is.

It also happens in other applications too while typing and in applications that have tabs. When I change from one tab to another, it -doesn't get refreshed.

It doesn't happen when I'm logged into Gnome Shell or Unity 2D. It occurs only in Unity. I tried removing Unity and compiz and re installing them but didn't really help.

Hope this gets fixed soon. It's driving me nuts.

Gábor Udvari (gabor-udvari) wrote :

Similar symptoms as above: frequently switching from gnome-terminal to Firefox causes gnome-terminal to scroll very slowly (takes one or two seconds to scroll a single line). Single monitor display, nVidia GeForce 8400, driver version: 304.43, Ubuntu 12.10 64bit.

Tried to figure out when and why that happens and here are some scenarios:
- happens with every libvte based terminal
- happens with xterm and rxvt-unicode if an xft font is used for display
- does _not_ happen with xterm and rxvt-unicode if a bitmapped xorg core font is used
- happens with every libvte based terminal if system wide font hinting is set to slight and font anti-aliasing is set to none (in this case fonts will look the same as a bitmapped xorg core font)

As you can see, even if the system wide setting is set to look the same as a bitmapped font, it does behave differently in this case. Could this be related to some font rendering performance?

Jonathan Allard (joallard) wrote :

This issue essentially prevents the user from using the terminal properly in a responsive manner.

I am calling for the importance of this bug to be raised.

Jonathan Allard (joallard) wrote :

Still experiencing in Quantal and nvidia 310.14. No multi-head.

Only in gnome-terminal, not xterm.

Does not occur after boot, only occurs after prolonged usage.

Steps to reproduce
--------------------------
1. Use terminal "long enough"
2. Open a file in vim (with a bit of content)
3. Placing the cursor at the beginning of the file, hold the spacebar to advance the cursor

Symptom: You can clearly see the cursor lagging

Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
Jonathan Allard (joallard) wrote :

The issue seems to stop when gnome-terminal is restarted.

Jonathan Allard (joallard) wrote :

When one instance of gnome-terminal has the issue, and another is started, the newer instance does not exhibit the bug.

This is like a speed limit on typing and it can render the user mad. Once again, I ask for importance to be raised.

Jonathan Allard (joallard) wrote :

The issue now does not stop when another instance of gnome-terminal is started. (?)

Jonathan Allard (joallard) wrote :

Still zero response from Nvidia.

Jonathan Allard (joallard) wrote :

Haven't seen it since in Raring; I'll try to update after some stress-testing.

Jonathan Allard (joallard) wrote :

Never mind, just seen in Raring. (nvidia 310.44)

Mateusz Gryzzli (gryzzli) wrote :

For all nvidia users, you could try to remove the GL cache:

rm ~/.nv (driver <346)
rm ~/.cache/.nv (driver 346)

Then disable the cache completely:

echo -e 'export __GL_SHADER_DISK_CACHE=0' >> ~/.profile

Restart / relogin afterwards. This fixed the issue for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.