Unnecessary chrome when showing multiple tabs

Bug #694468 reported by Mark Shuttleworth
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Wishlist
gnome-terminal (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-terminal

When gnome-terminal shifts from showing a single tab to showing two or more tabs, it introduces unnecessary chrome on the left, bottom and right edges of the window. This is particularly visible when the terminal is maximised. Chrome on the right is masked to some extent by the scrollbar there, but should be eliminated as well.

To reproduce:
 * launch gnome-terminal, showing only a single tab, maximised
 * note the lack of chrome around the edges of the screen
 * ctrl-shift-t to create a new tab

What happens:
 * you see a gray border on the left and bottom of the screen

What should happen:
 * there should be no gray border on the left and bottom of the screen

Revision history for this message
Omer Akram (om26er) wrote :

The issue is in gtk+ there is a workaround on the upstream bug report. the workaround is to add it to the following to .gtkrc

style "notebook-borderless" = "default"
{
    xthickness = 0
    ythickness = 0
}
widget "TerminalWindow.*.GtkNotebook" style "notebook-borderless"

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gtk:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Revision history for this message
zwn (zwn) wrote :

Is there a similar workaround for gtk-3?

Revision history for this message
zwn (zwn) wrote :

Ok, there is :). In file /usr/share/themes/Ambiance/gtk-3.0/apps/gnome-terminal.css add this:

TerminalWindow .notebook {
    padding: 1px;
}

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Bug 694468] Re: Unnecessary chrome when showing multiple tabs

@zwn, that's great, thanks! I tested it and it works. Can we get this
applied to Ubuntu please?

Revision history for this message
Varun Vijayaraghavan (varun-kvv) wrote :

Just my 2 cents: 0px padding actually looks better than 1px padding. :)

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Looks like this is fixed now in 14.10. Closing.

Changed in gnome-terminal (Ubuntu):
status: Triaged → Fix Released
Changed in gtk:
status: Confirmed → Incomplete
Changed in gtk:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.