Clicking on a link hangs gnome-terminal until the server responds

Bug #689880 reported by Anders Kaseorg on 2010-12-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GLib
Expired
Medium
gnome-terminal (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-terminal

When you click on a link in gnome-terminal, GNOME now contacts the server before opening a browser. While it is waiting for the server to respond, the gnome-terminal UI totally freezes: no input or output is processed, and the window is not repainted.

To reproduce: open gnome-terminal and type http://andersk.mit.edu/sleep-15.cgi (which has an intentional 15 second delay on the server side), then Ctrl+click on the link to open it. gnome-terminal hangs for 30 (!) seconds, then opens a browser, which waits for an additional 15 seconds and displays the page.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-terminal 2.32.1-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-9.22-generic 2.6.37-rc5
Uname: Linux 2.6.37-9-generic x86_64
Architecture: amd64
Date: Mon Dec 13 16:16:44 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-terminal

Anders Kaseorg (andersk) wrote :
Anders Kaseorg (andersk) wrote :

This also means that “one-use” registration links from terminal-based email clients don’t work, since the link is actually loaded three times before being displayed in the user’s browser.

Anders Kaseorg (andersk) on 2010-12-22
tags: added: regression-release
removed: regression-potential
Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version. Thanks in advance and sorry for the late response.

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Anders Kaseorg (andersk) wrote :

The underlying GLib bug still exists (https://bugzilla.gnome.org/show_bug.cgi?id=643224), but I think it was only showing up for me because of missing x-scheme-handler/http associations during the natty development cycle.

Changed in glib:
importance: Unknown → Medium
status: Unknown → New
Rafał Ochmański (rmopl) wrote :

I'm having this problem in raring right now. Although I'm not sure what is causing the delay (there's a good half a minute between clicking a link and the browser trying to open it).

Changed in glib:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.