Gnome-terminal fails to start when Xinerama enabled with nvidia-glx

Bug #64623 reported by Matthew Haughton on 2006-10-08
2
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

When Xinerama is enabled when using the proprietary nvidia drivers, gnome-terminal fails to start. When run from an alternative terminal (konsole), the error is:

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 105 error_code 2 request_code 78 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I've tried several combinations of xorg.conf with both open-source nv and proprietary nvidia drivers. Each combination worked with gnome-terminal, except when xinerama was enabled.

When I tried commenting xinerama out of my otherwise working xinerama enabled xorg.conf, gnome-terminal worked. Uncommenting xinerama meant that it would not start.

There's more info in bug <a href="https://launchpad.net/distros/ubuntu/+source/gnome-terminal/+bug/58232">#58232</a>.

Daniel Holbach (dholbach) wrote :

Thanks for your bug report. How is this different from bug 58232?

Changed in gnome-terminal:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Matthew Haughton (snafu109) wrote :

Sorry, it's not different. I thought it might get filed against xorg or something other than gnome-terminal.

This is my first bug report, so sorry about the noise :)

Feel free to close this.

Sebastien Bacher (seb128) wrote :

no problem, thank you for the useful informations. You can open tasks on different packages from a same bug, no need to open a different one. I'm marking that one as duplicate

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers