gnome-terminal transparency no longer works reliably (usually opaque, but sometimes shows transparency)

Bug #561370 reported by Le Gluon Du Net on 2010-04-12
168
This bug affects 41 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Medium
Unassigned

Bug Description

gnome-terminal transparency no longer works reliably (usually opaque, but sometimes shows transparency)

Le Gluon Du Net (legluondunet) wrote :

I changed the profil like this: solid color.
I closed gnome terminal.
I put again transparency background on in profil.
I closed gnome-terminal.
At next start I obtain transparency again.
I think it's an update of this program that made transparency off.

LGDN.

Omer Akram (om26er) wrote :

The problem came and gone. marking invalid. Thanks for the bug report

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
status: New → Invalid

This is a real bug wich appears after ubuntu update package.
On another computer wich had terminal transparency, same bug, same
resolution.

LGDN.

Le 12/04/2010 13:13, Omer Akram a écrit :
> The problem came and gone. marking invalid. Thanks for the bug report
>
> ** Changed in: gnome-terminal (Ubuntu)
> Importance: Undecided => Low
>
> ** Changed in: gnome-terminal (Ubuntu)
> Status: New => Invalid
>
>

I want to confirm that I had the same problem. The solution given by LGDN fixed the problem but it it is not obvious at all.

I upgraded from Karmic, my gnome-terminal was already configured with transparency under Karmic.

Changed in gnome-terminal (Ubuntu):
status: Invalid → New
Sergey Prokhorenko (queen3) wrote :

This also affects Tilda. Same trick works for solving the issue (set solid color, restart, change to transparent).

I have the same problem with gnome-terminal, though LGDN's fix works for me.

Tilda is reverting to the old, non-composite transparency behavior and showing me my background, not what's actually underneath, but the fix works here, as well.

I believe the problem may lay in the underlying compositing routines, since it seems to be the same problem for everyone across the board.

Same problem (i think) different symptoms. I did not have transparency enabled, not in compiz, not in the terminal, after the upgrade to lucid, the terminal is like 95% transparent. I am not sure if this is a new "visual feature" or a bug. If this is a feature why turning the "Solid Color" option on the terminal, or its transparency to 100% in compiz revert it back to the old behavior? For now the only workaround i found is to actually turn on terminal transparency, and set it manually (with the slider) to 100%.

Joe Ryan (jryanitpro) wrote :

I have the same issue as Pablo and I also noticed after fixing the transparency slider that was the only way to fix. I'm sure it is a bug since it is not optimal to need to switch to transparency to achieve a solid background.

Thanks
Joe

udude (igal) wrote :

Looks like there's a performance penalty for having the transparency always on. Switching between different tabs is not fast as it used to be on Karmic. It really holds back fast terminal switching, one of the main things I liked in Ubuntu. This issue might need a higher priority

FlagMan (flagman) wrote :

@ pablo, joe, maybe udude:
your problem is probably different from the OPs, and now fixed for maverick, see bug #549552

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Oneiric Ocelot. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnome-terminal (Ubuntu):
status: New → Incomplete
Alistair Buxton (a-j-buxton) wrote :

This bug is not reproducable with the live CD because it only ever affected people doing upgrade installs.

Changed in gnome-terminal (Ubuntu):
status: Incomplete → New
Steve Murphy (murf-parsetree) wrote :

I will experiment with the transparency off-on procedure, but I have maybe 60-80 machines in my list. The
transparency doesn't just not work; it is subject to a fantastic amount of flicker which is extremely disruptive and distracting.
The screen, at rest, with two gnome-terminal windows running, will be alive with flickering screens, going dark and light. As your
cursor moves across a gnome-terminal window, boxes and columns will form and disappear, following the cursor.
It would be well for the developers to try and understand just where this problem originates, and how it might be cured
during the update process; it would seem natural to solve this problem during the package install process.... or the upgrade experience will be harrowing for those going thru the process, and not understanding why the new version of the OS seems to be a downgrade instead of an upgrade for the power users of gnome-terminal.

summary: - gnome-terminal transparency no longer works in lucid
+ gnome-terminal transparency no longer works reliably (often opaque, but
+ sometimes flickers)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Confirmed in Ubuntu 18.04. In fact it's been broken for so long that I think most of us forgot it used to be transparent. But you can still see the transparency flicker in and out sometimes.

tags: added: bionic
tags: added: visual-quality
summary: - gnome-terminal transparency no longer works reliably (often opaque, but
- sometimes flickers)
+ gnome-terminal transparency no longer works reliably (usually opaque,
+ but sometimes shows transparency)
Changed in gnome-terminal (Ubuntu):
importance: Low → Medium
priv (privism) wrote :

On 18.04 if you change setting it will result in a stable transparent background:

1. Uncheck "Use transparency from system theme"
2. "Check Use tranparent background"
3. Re-check "Use transparency from system theme"

Also reported at bug #1726262

tags: added: cosmic
description: updated
John Roberts (jrobfrance) wrote :

Still apparent in 18.04. The workaround posted by 'priv' above to change the settings in gnome-terminal does work.

priv (privism) wrote :

In cosmic the behavior changes.

1. By default gnome-terminal is always opaque.
2. If you set Use transparency background, check/uncheck "Use the transparency from system theme will not affect anything at all.

tags: added: disco
vak (khamenya) wrote :

still present in:

Ubuntu 18.04.2 LTS
gnome-terminal/bionic-updates,now 3.28.2-1ubuntu1~18.04.1 amd64

it looks like gnome-terminal isn't sure whether or not to be semi-transparent when the window is not in front and is overlapped by a foreground window.

So, I see 3 states when the terminal window is not in focus and partially overlapped by a foreground window:

1) Sometimes it is semi-transparent (like it is expected when a window is overlapped by a foreground window)

2) sometimes it is not transparent, albeit it is not in focus and overlapped by a foreground window. also a bug?

3) and finally sometimes it flickers between the above two states: semi-transparent and non-transparent.

tags: removed: cosmic
Sam Stenvall (negge) wrote :

I can confirm that priv's workaround from post #17 works.

Will Hawkins (hawkinsw) wrote :

To bump the date on previous commenters in case there are some who come along reading this in the new year (2020), I can confirm

a) This is still a problem in 18.04.4 LTS (Intel® UHD Graphics (Comet Lake 3x8 GT2))
b) priv's workaround from post #17 still works!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers