[lucid] setup_http_proxy_env constructs no_proxy incorrectly

Bug #534225 reported by David Coles on 2010-03-08
158
This bug affects 31 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Medium
gnome-terminal (Ubuntu)
Low
Unassigned
Lucid
Low
Chris Coulson

Bug Description

Binary package hint: gnome-terminal

After setting a proxy with gnome-network-config, programs run from gnome-terminal that check the http_proxy and no_proxy environment variables (such as wget) will not use the proxy server.

The issue is that gnome-terminal sets the no_proxy environment variable to something similar to "localhost,127.0.0.0/8,*.local," (note the trailing comma), which appears to make this a wildcard match. Removing the comma from the end with `export no_proxy=localhost,127.0.0.0/8,*.local` will cause the proxy to be used again.

ProblemType: Bug
Architecture: amd64
Date: Mon Mar 8 18:41:05 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gnome-network-properties
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: gnome-control-center 1:2.29.91-0ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: gnome-control-center
Uname: Linux 2.6.32-15-generic x86_64

David Coles (dcoles) wrote :
David Coles (dcoles) wrote :

After some investigation, it turns out that it is actually gnome-terminal that constructs the no_proxy environment varible in terminal-screen.c.

affects: gnome-control-center (Ubuntu) → gnome-terminal (Ubuntu)
Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
summary: - [lucid] gnome-network-properties sets no_proxy environment variable
- wrong
+ [lucid] setup_http_proxy_env constructs no_proxy incorrectly
David Coles (dcoles) wrote :

Fixed upstream, See http://git.gnome.org/browse/gnome-terminal/commit/?id=c3ed02adadafa1a07393f64a6d4065de15149601 for the commit. Should be fixed in the next release of gnome-terminal.

description: updated
Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Confirmed → Fix Committed
Siert (sgz) wrote :

Bug still exists in 10.04 with all updates applies:
  gnome-terminal 2.29.6-0ubuntu5
  gnome-control-center 1:2.30.0-0ubuntu4

Uname: Linux htn-ws-1376 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux

tags: added: patch
Changed in gnome-terminal (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Chris Coulson (chrisccoulson)
Changed in gnome-terminal:
status: Unknown → Fix Released
Nigel Babu (nigelbabu) wrote :

Since this patch is commited upstream, adding patch-accepted-upstream tag.

tags: added: patch-accepted-upstream
removed: patch

When will it appear to the repository?

JPM (jpm) wrote :

Also got the problem here. I thought it to be Bug #432631, but this description fits better.

export no_proxy=$(echo $no_proxy | sed 's/,$//')
Does help to alleviate the problem, but does not fix it. Thats why I think both this bug and #432631 is the culprits in breaking apt through a proxy in 10.04.

We on a university campus, behind a proxy server, really want this bug to be fixed. We have local ftp repo's and use http internet repo's. But the ignored hosts in gnome-network-properties is ignored.

Henning Moll (drscott) wrote :

I wonder why gnome-terminal is responsible for setting this environment variable. What if the user is using another terminal programm?

Another point is that http_proxy may be defined system wide, but no_proxy not...

Pedro Villavicencio (pedro) wrote :

This is fixed on Maverick already marking that task as Fixed. Chris is going to work on the SRU for Lucid, thanks all.

Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-terminal (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in gnome-terminal (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
Michal (michal.post) wrote :

Please patch this in Lucid. I know many people affected.
Thank you in advance.

Chris Coulson (chrisccoulson) wrote :

I'll get the stable version update to lucid-proposed in a minute

Changed in gnome-terminal (Ubuntu Lucid):
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :

Ok, I've uploaded 2.30.2 to Lucid now. For anyone reviewing it, here is a debdiff minus all the autotools and translation noise

Changed in gnome-terminal (Ubuntu Lucid):
status: In Progress → Fix Committed
Changed in gnome-terminal:
importance: Unknown → Medium

Accepted gnome-terminal into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Michal (michal.post) wrote :

I confirm, that this bug is FIXED in gnome-terminal 2.30.2-0ubuntu1.

confirmation steps:
1. made copy of /usr/bin/gnome-terminal binary
2. upgraded gnome-terminal from proposed repository to 2.30.2-0ubuntu1
3. setup proxy in gnome
4. verified that issue is reproducible using OLD version of gnome-terminal binary
5. verified that issue is NOT reproducible using NEW version of gnome-terminal binary

This fix make everyday work much easier for me and many people I know.
Thank you very much!

Martin Pitt (pitti) on 2010-09-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 2.30.2-0ubuntu1

---------------
gnome-terminal (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * Update to stable upstream version 2.30.2, fixes:
    - LP: #526437 - Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion
      `entry != NULL && entry->lock_count > 0' failed
    - LP: #534225 - setup_http_proxy_env constructs no_proxy incorrectly
  * Revert commit 8dfe341 - bump VTE req to 0.24.0. This was just bumped to
    the current stable version of VTE for 2.30.0, but it's not actually
    required (and Lucid only has 0.23.5 anyway)
    - add debian/patches/21_dont_bump_vte_version.patch
  * Refresh patches
    - update debian/patches/01_lpi.patch
    - update debian/patches/99_autoreconf.patch
 -- Chris Coulson <email address hidden> Tue, 07 Sep 2010 15:07:22 +0100

Changed in gnome-terminal (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.