Scroll-wheel not causing cursor moves in gnome-terminal any more after latest updates

Bug #533647 reported by pablomme
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Fix Released
Low
Jenni Bruce

Bug Description

Binary package hint: gnome-terminal

This is a feature request - or rather a request for the reinstatement of a feature which has (perhaps by accident) disappeared.

It used to be the case that gnome-terminal (up to 2.28.*) would interpret the use of the scroll-wheel as cursor moves if the terminal had been scroll-locked by the application. For example when using vim, [al]pine, less, terminal-based emacs, etc, one could use the scroll wheel as a way to send 5 (I think) up-arrow or down-arrow strokes. I got quite used to this feature - it allows you to move though a file in vim or an email in pine without focusing the terminal - and I miss it now it's gone. The scroll wheel was working in lucid alpha 3 until recently, when gnome-terminal got its 2.28 -> 2.29 version update.

Has this feature been removed by accident, or is there a reason why it was disabled?

ProblemType: Bug
Architecture: i386
Date: Sun Mar 7 04:46:28 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
Package: gnome-terminal 2.29.6-0ubuntu3
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: gnome-terminal
Uname: Linux 2.6.32-15-generic i686

Revision history for this message
pablomme (pablomme) wrote :
Scott Zawalski (cowbud)
Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Changed in gnome-terminal (Ubuntu):
status: Confirmed → New
importance: Undecided → Low
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Hello pablomme, that works fine for me with latest updates, could you please test the same with a new user created on your system? that's probably due to a broken profile rather than a bug in gnome-terminal, please test and comment back, Thanks in advance.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
Revision history for this message
pablomme (pablomme) wrote :

I've tried logging in as "guest". The mouse wheel doesn't work as usual there either. Might it be the opposite, that you have a tweak in place that is not there by default?

Revision history for this message
pablomme (pablomme) wrote :

Ok, it is a profile issue. The new Ambience profile prevents the feature from working. Selecting the "Legacy" profile (or "Default", depending on whether the ambience theme was installed before or after opening gnome-terminal for the first time) makes it work. However I don't see any gconf key under apps/gnome-terminal/profiles/Ambiance that should affect this...

Revision history for this message
pablomme (pablomme) wrote :

And indeed it's not there.

The problem is that the Ambience profile does not have a Boolean
  /apps/gnome-terminal/profiles/Ambiance/alternate_screen_scroll
key. It just needs one in the default settings. This is the only missing key compared with the "Legacy" profile.

Revision history for this message
sam tygier (samtygier) wrote :

well found pablomme. with ambiance i can't scroll, with default i can.

Revision history for this message
Thanos Lefteris (alefteris) wrote :

Tested with lucid beta 1 unr live image and the ambiance profile in gnome-terminal still hasn't got alternate_screen_scroll enabled

Changed in gnome-terminal (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thanks, i will fix this today

Changed in gnome-terminal (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Chris Coulson (chrisccoulson)
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 2.29.6-0ubuntu4

---------------
gnome-terminal (2.29.6-0ubuntu4) lucid; urgency=low

  * debian/gnome-terminal-ambiance.schemas:
    - Add alternate_screen_scroll schema to Ambiance profile, to fix
      mouse-wheel scrolling (LP: #533647)
 -- Chris Coulson <email address hidden> Tue, 23 Mar 2010 01:37:30 +0000

Changed in gnome-terminal (Ubuntu):
status: In Progress → Fix Released
Jenni Bruce (jennib57)
Changed in gnome-terminal (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → Jenni Bruce (jennib57)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers