Ubuntu

Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed

Reported by Hernando Torque on 2010-02-23
124
This bug affects 22 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Medium
Chris Coulson
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: gnome-terminal

I'm getting this message upon starting gnome-terminal (starting additional terminals doesn't cause it).

ProblemType: Bug
Architecture: i386
Date: Tue Feb 23 14:06:26 2010
DistroRelease: Ubuntu 10.04
Package: gnome-terminal 2.29.6-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: gnome-terminal
Uname: Linux 2.6.32-14-generic i686

Hernando Torque (htorque) wrote :
Hernando Torque (htorque) wrote :
Hernando Torque (htorque) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report Hernando, are you still getting this with gnome-terminal 2.29.6 ? are you any custom keyboard shortcuts with gnome-terminal ?

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
Hernando Torque (htorque) wrote :

Yes, it's still an issue on my two testing systems (also confirmed with a current daily live CD). I don't have any custom gnome-terminal keybindings and the value of '/apps/gnome-terminal/keybindings/save_contents' is 'disabled'.

This bug still exists in this version:

Package: gnome-terminal
Version: 2.29.6-0ubuntu5

and libraries updated as of now.

Changed in gnome-terminal (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-terminal (Ubuntu):
status: Confirmed → New
Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Hernando Torque (htorque) wrote :

Seems the 'Save Contents' KeyEntry in 'src/terminal-accels.c' is missing the last value (gboolean accel_path_unlocked). I'm no C programmer, but I guess accessing that value returns NULL which is interpreted as FALSE thus causing the warning?

Anyways, attached a patch that sets 'accel_path_unlocked' to TRUE.

Hernando Torque (htorque) wrote :

This already has been fixed (and later disabled) upstream:

*) 2010-02-23 Fix FileSaveContents accel
http://git.gnome.org/browse/gnome-terminal/commit/?id=ba5ad86295605d33b05d12c80bdfdd01625cced7

*) 2010-03-14 Hide the Save Contents menu entry
http://git.gnome.org/browse/gnome-terminal/commit/?id=0db44783cef479e6f91b2b70f3dbe437f6a27615

*) 2010-03-15 Comment out the FileSaveContents UI entry too
http://git.gnome.org/browse/gnome-terminal/commit/?id=ab5b81916633d9fa1afa1e9bc459c50841f5bc7e

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Fix Committed
Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Confirmed

This bug does not exists in Debian sid with this package version:

Package: gnome-terminal
Version: 2.30.0-1

BTW, why did lucid ship with a non final gnome-terminal version ?

Changed in gnome-terminal (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Chris Coulson (chrisccoulson)
status: Confirmed → Fix Committed
tekstr1der (tekstr1der) wrote :

Still seeing this on up-to-date lucid. Being fixed upstream, will lucid-proposed be seeing gnome-terminal 2.30.1 soon?

David Robert Lewis (afrodeity) wrote :

I see this in my .xsession-errors log after lucid upgrade and might be linked to the failure of nautilus

Oedipe (oedipe) wrote :

Everything up-to-date here with gnome-terminal 2.29.6.
Still seeing that bug... first reported 3 months ago.... Any update soon ?...

Chris Coulson (chrisccoulson) wrote :

This is acually fixed in maverick. I'll try and do a SRU for lucid, but I'm not sure when I'll have time

Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Fix Released
mishabhi (mishabhi) wrote :

tried re-installing the package. Did not help.
Can someone explain what triggered this. Things were running fine before i hit this

mishabhi (mishabhi) wrote :

i see the state of this bug is fix released. but i don't find a higher version through synaptic. Where can i get a patch to install if i don't want to build my own using the attachment in here ?

Pedro Villavicencio (pedro) wrote :

The bug is fixed on Maverick not in Lucid BTW.

mishabhi (mishabhi) wrote :

i hope i don't have to wait till that release. isn't there a patch i can install ?
I am sorry I am a new convert from windows and not really smooth on building a patch for myself.
what's an SRU .. can anyone do it ?
my work needs a terminal. Is there a workaround .. some other program i can use ?

rwmarch (rwmarch) wrote :

As another terminal option, you can use konsole as I am doing on Lucid gnome to avoid this problem.

mishabhi (mishabhi) wrote :

i don't want to be a helpless-can't-do but can someone build a patch for lucid and upload
I have downloaded the code and am trying to build it but the ./configure keeps throwing endless requirements.

tekstr1der (tekstr1der) wrote :

Is there any chance gnome-terminal 2.30.2 will make it into lucid as an SRU prior to the first point release 10.04.1?

Lachezar Dobrev (lachezar) wrote :

I removed the i386 tag, since x86_64 is also affected.

tags: removed: i386
RichardN (richardn) wrote :

I can confirm that I see this bug on x86_64. It would be good to get a fix into lucid.

tekstr1der (tekstr1der) wrote :

The fix for this bug is committed upstream, but not released to ubuntu lucid yet. Although ubuntu's About > Gnome claims to be version 2.30.2, for some reason, gnome-terminal was never updated from the 2.29 development branch. Hope this is resolved soon.

Changed in gnome-terminal (Ubuntu):
status: Fix Released → Fix Committed
Oedipe (oedipe) wrote :

Can we hope to see one day the so-called "fix released" reaching ALSO the Lucid LTS... ?????? Seems to me more important than a Maverick beta ! :-(

Mackenzie Morgan (maco.m) wrote :
Mackenzie Morgan (maco.m) wrote :

(Well, it's still building, but it'll be there)

Accepted gnome-terminal into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-terminal (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
aslam karachiwala (akwala) wrote :

Tested v. 2.30.2-0ubuntu1 from lucid-proposed -- the error didn't appear.

Fix verified.

Version 2.30.2-0ubuntu1 from lucid-proposed also fixes the problem for me. Thanks!

Martin Pitt (pitti) on 2010-09-17
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 2.30.2-0ubuntu1

---------------
gnome-terminal (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * Update to stable upstream version 2.30.2, fixes:
    - LP: #526437 - Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion
      `entry != NULL && entry->lock_count > 0' failed
    - LP: #534225 - setup_http_proxy_env constructs no_proxy incorrectly
  * Revert commit 8dfe341 - bump VTE req to 0.24.0. This was just bumped to
    the current stable version of VTE for 2.30.0, but it's not actually
    required (and Lucid only has 0.23.5 anyway)
    - add debian/patches/21_dont_bump_vte_version.patch
  * Refresh patches
    - update debian/patches/01_lpi.patch
    - update debian/patches/99_autoreconf.patch
 -- Chris Coulson <email address hidden> Tue, 07 Sep 2010 15:07:22 +0100

Changed in gnome-terminal (Ubuntu Lucid):
status: Fix Committed → Fix Released
kenorb (kenorb) wrote :

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers