bad colour on ls listing

Bug #502888 reported by Andy Stanford-Clark on 2010-01-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Terminal
New
Wishlist
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

See bug https://bugs.launchpad.net/ubuntu/+source/coreutils/+bug/498212

<summary>
if a directory is chmod o+w and you do an ls from the gnome terminal command line, the directory gets coloured blue text on dark green background, making it almost impossible to read.

Suggest removing the green background stripe.

Can be worked-around by "unalias ls" in every shell window, but would be better if it was actually fixed ;)
</summary>

The coreutils bug referenced has been closed as "won't fix" as it only affects Gnome Terminal users.

There is no debate that the colour combination used by ls for o+w directories, is very hard to read by most people.

Having a directory as o+w isn't *necessarily* a Bad Thing - I certainly shouldn't be forced to chmod a directory just to be able to read its name!

And this is a basic accessibility bug.

ProblemType: Bug
Architecture: i386
Date: Mon Jan 4 10:22:37 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-terminal
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: gnome-terminal 2.28.1-0ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: gnome-terminal
Uname: Linux 2.6.31-16-generic i686

Andy Stanford-Clark (andysc) wrote :
Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. Thanks in advance!

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Andy Stanford-Clark (andysc) wrote :

Hi Pedro - I tried that, and they dismissed it as only applicable to gnome terminal. (see the link to the previous bug).

I think this has to be dealt with "down here"...

Andy Stanford-Clark (andysc) wrote :

ah, upstream as-in Gnome... sorry... yes, you're right

Andy Stanford-Clark (andysc) wrote :

raised upstream to gnome-terminal
https://bugzilla.gnome.org/show_bug.cgi?id=606064

C de-Avillez (hggdh2) wrote :

Added upstream link.

@Andy -- it might have helped if you had correctly stated the issue upstream -- it is *not* that blue over green is not visible, but that gnome-terminal does not render it correctly (or, alternatively, that every other terminal does a better job). I reopened upstream with a request for reconsideration.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Andy Stanford-Clark (andysc) wrote :

@C thank you for clarifying that... I don't think blue on green is a good combination in *any* terminal, but (as the examples I've now posted on the gnome-terminal bug show) you're right, they are rendered much worse in gnome-terminal than on other terminals (e.g. konsole)

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Triaged
C de-Avillez (hggdh2) wrote :

Adjusted upstream bug -- original was closed DUP

Changed in gnome-terminal:
importance: Unknown → Wishlist
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.