Open link feature opens wrong URLs (extra less than sign at the end)

Bug #479940 reported by shankao
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Low
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

Links contained in a XML file with the format:

<source_url>http://www.website/2746530</source_url>

Are opened with gnome-terminal using the "open link" feature with an extra less than sign ("<") added at the end. It shouldn't be there.

ProblemType: Bug
Architecture: i386
Date: Tue Nov 10 12:23:12 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-terminal
Package: gnome-terminal 2.28.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-15.49-generic
SourcePackage: gnome-terminal
Uname: Linux 2.6.31-15-generic i686

Revision history for this message
shankao (shankao) wrote :
Revision history for this message
Pedro Villavicencio (pedro) wrote :

just passing the mouse over the link you paste there i get a similar behavior "http://www.website/2746530</source_url" is highlighted there, is that what you're referring to? could you take an screenshot of the terminal? thanks.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
shankao (shankao) wrote :

Here it is. It seems like I have found an error in the screenshot application in the process, cause that black band always show when I try to do it. Will report it also :)

For the current error, I think that the code searching for URL's under the cursor is broken (regexp?). Only a supposition anyway.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

confirming, that's likely a duplicate though.

Changed in gnome-terminal (Ubuntu):
status: Incomplete → Confirmed
tags: added: likely-dup
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=604563

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-terminal:
importance: Unknown → Low
status: Unknown → New
Changed in gnome-terminal:
status: New → Confirmed
Changed in gnome-terminal:
status: Confirmed → Fix Released
Revision history for this message
Paul White (paulw2u) wrote :

Upstream bug closed "RESOLVED FIXED" on 2016-02-21
Checked working as intended in Ubuntu 18.04
Changing to "Fix Released" to close

Changed in gnome-terminal (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.