URL matching fails on second colon

Bug #372449 reported by aarons on 2009-05-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Invalid
Low
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

The URL matching in gnome-terminal fails at a second colon in the url. For example, with the following URL:

http://en.wikipedia.org/wiki/File:Hawat-1984.jpg

gnome-terminal (2.26.0) will only recognize http://en.wikipedia.org/wiki/File. Since a colon is a valid character in a URL, it should correctly match the entire string.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

this is a side effect of bug 352395, removing that from the select-by-word should allow you to do that, but it doesn't work at all. marking this as duplicate.

Changed in gnome-terminal (Ubuntu):
status: New → Invalid
Allan Feid (crayz) wrote :

I believe this duplicate status is wrong. I have no problem double clicking to select a link with a ':' in it, but the ability to open this link fails as it cuts off the link at the ':'. There has been numerous bug reports about this problem, and here is one with a patch attached:

https://bugzilla.gnome.org/show_bug.cgi?id=640727

Unmarking as a duplicate of the other bug as there is a direct fix for this bug (but not the other one) available in the upstream bugtracker (now linked).

Changed in gnome-terminal (Ubuntu):
status: Invalid → Triaged
Changed in gnome-terminal:
importance: Unknown → Medium
status: Unknown → Invalid
Changed in gnome-terminal:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in gnome-terminal:
importance: Unknown → Low
status: Unknown → New
Changed in gnome-terminal:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.