Only first instance responses --class cmd line option

Bug #366776 reported by KonishchevDmitry on 2009-04-25
2
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

I am start several instances of gnome-terminal:
gnome-terminal --class=Class_1
gnome-terminal --class=Class_2
gnome-terminal --class=Class_3

If I run
xprop | grep WM_CLASS
I get
WM_CLASS(STRING) = "gnome-terminal", "Class_1"
for all running instances. So, only first instance of gnome-terminal responses --class command line option. All further instances "inherits" it from the first instance.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-terminal
NonfreeKernelModules: nvidia
Package: gnome-terminal 2.26.0-0ubuntu2
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LC_MESSAGES=C
 LANG=ru_RU.UTF-8
SourcePackage: gnome-terminal
Uname: Linux 2.6.28-11-generic i686

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Thanks for the report, I'm not sure if it should create another process please send this directly upstream at bugzilla.gnome.org where the upstream developers can read about it, for forwarding instructions please have a look to http://wiki.ubuntu.com/Bugs/Upstream/GNOME ; thanks in advance.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version.Thanks in advance.

Changed in gnome-terminal (Ubuntu):
status: New → Incomplete

Yes, it's the same, but it can be fixed by running gnome-terminal as
gnome-terminal --disable-factory --class=Class_1
gnome-terminal --disable-factory --class=Class_2

So, I think that the issue may be considered as solved. Thanks.

Changed in gnome-terminal (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers