gnome-terminal does not launch on upgrade to jaunty

Bug #360160 reported by Ninad S Pundalik on 2009-04-12
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

Package: gnome-terminal ( 2.26.0-0ubuntu2 )

Description: Ubuntu upgraded from Intrepid to Jaunty using alternate iso and the latest packages over the net. After the upgrade completed ( with one small error in tzdata-java, which was rectified with a dpkg --configure -a )m I rebooted the system, and logged into GNOME. When I attempted to launch gnome-terminal, "There was an error creating the child process for this terminal" was the error it reported. Konsole on the other hand just spawned a new window and did not respond to anything after that.

Note (2009-04-25): Two reasons for this have been found:
    1. The order in /etc/rcS.d is messed up (bug 321927). Fix:
        a. $ ls /etc/rcS.d | grep mountdevsubfs.sh
            Note the number next to the "S" in the returned filename (e.g. the 05 in S05mountdevsubfs.sh).
        b. $ sudo mv /etc/rcS.d/S_mountdevsubfs.sh /etc/rcS.d/S11mountdevsubfs.sh
            where _ is the number in the old filename.
    2. Or, you modified /etc/init.d/mountdevsubfs.sh (maybe to get VirtualBox to work; that workaround is no longer needed) and dpkg refuses to update it (this bug). Fix:
        $ sudo cp /etc/init.d/mountdevsubfs.sh.dpkg-dist /etc/init.d/mountdevsubfs.sh
If you do one of these fixes, reboot afterwards.
    --scottywz

Fix [workaround]: Searching on the net pointed me to these two links:

1. Launchpad Bug - SSH results in "There was an error creating the child process for this terminal" ( https://bugs.launchpad.net/gnome-terminal/+bug/332517 ).

2. LinuxQuestions.org forum : http://www.linuxquestions.org/questions/slackware-14/cant-start-a-terminal-200544/

Both the work arounds required that a line be added to /etc/fstab :

devpts /dev/pts devpts gid=5,mode=620 0 0

Rebooting after this edit fixed the issue. However, this seems more like a hack than a solution.

Attachments: The bug report produced by 'apport-cli -fp gnome-terminal' after fixing /etc/fstab
Current system, as reported by lsb_release -rd:
Description: Ubuntu jaunty (development branch)
Release: 9.04

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 321927, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → High
status: New → Invalid
Ninad S Pundalik (ninadsp16289) wrote :

@Andreas:

As per comment #62 on bug 321927, this bug is not related to that bug, and hence should be looked into.

I am new here, so will need help. Please let me know any additional information that you need, to confirm this as a bug or invalid.

Andreas Moog (ampelbein) on 2009-04-14
Changed in gnome-terminal (Ubuntu):
importance: High → Low
status: Invalid → New

If you boot without "quiet splash" on the kernel command-line do you see any messages about /dev/pts on your screen?

Please attach the contents of your /etc/rcS.d, /etc/init.d and /lib/udev/devices directories; also attach /var/log/udev

Thanks,

Changed in gnome-terminal (Ubuntu):
status: New → Incomplete
David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :
Changed in gnome-terminal (Ubuntu):
status: Incomplete → Confirmed

On Tue, 2009-04-14 at 15:24 +0000, David Henningsson wrote:

> ** Attachment added: "initd.txt"
> http://launchpadlibrarian.net/25457773/initd.txt
>
Your mountdevsubfs.sh script has been modified:

-rwxr-xr-x 1 root root 1479 2008-01-26 12:45 mountdevsubfs.sh
-rw-r--r-- 1 root root 1465 2007-10-04 13:17 mountdevsubfs.sh~

Please supply both of these files.

(You're running hardy, right?)

Scott
--
Scott James Remnant
<email address hidden>

On Tue, 2009-04-14 at 15:24 +0000, David Henningsson wrote:

> ** Attachment added: "initd.txt"
> http://launchpadlibrarian.net/25457773/initd.txt
>
In fact, I've noticed something else:

-rwxr-xr-x 1 root root 1479 2008-01-26 12:45 mountdevsubfs.sh
-rw-r--r-- 1 root root 1465 2007-10-04 13:17 mountdevsubfs.sh~
-rwxr-xr-x 1 root root 1351 2008-10-14 15:02 mountdevsubfs.sh.dpkg-dist

Not only have you modified the mountdevsubfs.sh from the hardy version,
but you opted to not replace it with the jaunty version.

This is very likely a bug of your own causing; modifying the very script
that mounts /dev/pts is a very probably cause for it not being mounted
anymore.

Scott
--
Scott James Remnant
<email address hidden>

Marking as Invalid. Please re-open if replacing /etc/init.d/mountdevsubfs.sh with /etc/init.d/mountdevsubfs.sh does not solve your problem.

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Invalid

Here are my outputs of /etc/rcS.d, /etc/init.d, /lib/udev/devices and /var/log/udev. All these outputs are on a system where the /etc/fstab has been modified and the ptys are now accessible. If you need the above with no changes to fstab, let me know, I'll post them as well.

David Henningsson (diwic) wrote :

Okay, using mountdevsubfs.sh.dpkg-dist fixed the problem, thanks for helping out. It seems like Ninad also has a mountdevsubfs.sh.dpkg-dist.

But, I can't remember anything about "opting out", and /var/log/dpkg.log does not show anything unusual about the initscripts package (and there's nothing about mountdevsubfs.sh at all). If dpkg decided for itself that replacing my changed mountdevsubfs.sh was a bad idea, shouldn't it be writing a note about it?

I'm using Jaunty, upgraded a few days ago from Intrepid (which was an upgrade from Hardy).

I do remember modifying the mountdevusbfs.sh in my Intrepid install for a work around needed in VirtualBox. But I also remember asking the dist-upgrader to replace mountdevusbfs.sh with the package maintainers version while upgrading to Jaunty. That must be the reason for this bug.

I'll try what David did and get back to you all. However, it will take a little time as I have an exam in a few hours.

P.S.: Attaching the term.log of dist-upgrade. I did not find any mention of mountdevusbfs.sh in the log. So I might be wrong altogether.

I do remember modifying the mountdevusbfs.sh in my Intrepid install for a work around needed in VirtualBox. But I also remember asking the dist-upgrader to replace mountdevusbfs.sh with the package maintainers version while upgrading to Jaunty. That must be the reason for this bug.

I'll try what David did and get back to you all. However, it will take a little time as I have an exam in a few hours.

P.S.: Attaching the term.log of dist-upgrade. I did not find any mention of mountdevusbfs.sh in the log. So I might be wrong altogether.

I confirm that replacing mountdevusbfs.sh with mountdevusbfs.sh.dpkg-dist fixed the issue. This was done along with commenting the line in /etc/fstab.

A side-by-side diff of the two mountdevusbfs is attached. Line 41 of the file shows that the options for 'domount devpts' have been changed. While I remember that any fiddling that I had done was in the next few lines, the ones after the comment "Magic to make /proc/bus/usb work", I did not touch any other parts of the file.

I, too, had changed my mountdevusbfs.sh at one point (in fact, for the same reason). However, I don't understand how you managed to fix it? This problem is really bugging me. The "hack" you mention enables gnome-terminal but for some reason my TTYs are still not active. I'm hoping to get it fixed like you have it. Could you post your new mountdevusbfs.sh or tell me how to install a package-maintainer's version? I don't know what package this would be included in.

@Githlar: If you upgraded from an earlier version of Ubuntu, then there will be a mountdevusbfs.sh.dpkg-dist file in your /etc/init.d/ directory. Create a backup copy of the existing moundevusbfs.sh, and then replace it with the dpkg-dist file. If you don't have a dpkg-dist file due to some reasons, please download the file attached to this post, and copy it to /etc/init.d/ with 755 as the permission and root as the user and group of the file. At the same time, comment/remove the hack in the /etc/fstab, and then reboot.

I do not have a mountdevsubfs.sh.dpkg-dist file. This is a Hardy > Intrepid > Jaunty install.

Disregard the last post. I kind of jumped the gun haha

Kyle Brandt (kyle-kbrandt) wrote :

I am having this issue as well, a diff between the mountdevsubfs.sh that Ninad posted above shows no differences (and md5sum is identical). When I try adding the devpts line to my fstab and then mount -a I get devpts mounted already or /dev/pts is busy . Mount does not show it as being mounted ...

Kyle Brandt (kyle-kbrandt) wrote :

Fixed it, I need to put mountdevsubfs earlier as stated at the end of: https://bugs.launchpad.net/ubuntu/+bug/245956

putin_ai (putin-ai) wrote :

I fix in like this:

I booted in recovery mode (press ESC in GRUB loader),
choosed root console and start "chkconfig mountdevsubfs.sh 1".
After that everything you need is just restart.

Scott Zeid (scottywz) on 2009-04-25
description: updated
Scott Zeid (scottywz) on 2009-04-25
description: updated
marcohnunez (marcohnunez) wrote :

Hello everybody,

I've tried to replace mountdevsubfs.sh with mountdevsubfs.sh.dpkg-dist, but I got the message: "file doesn't exists" that means mountdevsubfs.sh.dpkg-dist is not in my system, so does anybody knows where to find it? That's 'cause the gnome terminal stops working from GUI.

The error I'm getting is: "There was an error creating the child process for this terminal" that's from the Ubuntu 9.04 GUI.

Any comments are welcome.

Best Regards,
Marco Hernandez

marcohnunez (marcohnunez) wrote :

The following is the error:

kenorb (kenorb) wrote :

The same problem.
Done:
mount --bind /proc /mnt/proc
mount --bind /dev /mnt/dev
chroot /mnt
gnome-terminal &
And I see this error? Why?

kenorb (kenorb) wrote :

I did as well (from root system):
mount --bind /var/run /mnt/var/run
chown -R root /mnt/var/run
mount --bind /dev/pts /mnt/dev/pts
mount --bind /mnt/etc /etc
chmod 777 /dev/shm
Now it works!
Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers