Ubuntu

Ctrl modifier doesn't work in xterm and gnome-terminal

Reported by Beowulf on 2008-12-20
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Low
Unassigned

Bug Description

 After upgrading to Ubuntu 8.10 I can't use Ctrl modifier in gnome-terminal. I have two keyboard layouts, ,English and Russian.
I switched keyboard layout to en US. Then I opened gnome terminal. Then I noticed that pressing Ctrl-C combination in gnome-terminal instead of interrupting the current comand prints russian "с" letter.
 Then I opened Midnight Commander from gnome-terminal and pressed Ctrl-O to hide panels, and it resulted into printing "щ" character. So I can't use Ctrl modifier in gnome-terminal because pressing Ctrl in conjunction with english letter switches layout and prints russian letter.

Beowulf (s-highlander) wrote :
Beowulf (s-highlander) wrote :
Pedro Villavicencio (pedro) wrote :

must be something else which is causing the issue since you're not having that key and both programs, could be an x issue.

teju (teju) on 2009-08-30
affects: ubuntu → gnome-terminal (Ubuntu)
Pedro Villavicencio (pedro) wrote :

could you please try the same with a new user created on your system? Thanks in advance.

Changed in gnome-terminal (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gnome-terminal (Ubuntu):
status: Incomplete → Invalid
Dmitriy Balakin (0x0000.ru) wrote :

I can confirm. This bug is appears only if in GNOME keyboard preferences first in the list is the Russian layout.

The Lucid's gnome-terminal is also affected by this bug.

Changed in gnome-terminal (Ubuntu):
status: Invalid → New
Dmitriy Balakin (0x0000.ru) wrote :

However xterm in lucid works fine

Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

Changed in gnome-terminal (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Dmitriy Balakin (0x0000.ru) wrote :

Bug in upstream https://bugzilla.gnome.org/show_bug.cgi?id=162726 marked as fixed and closed.

All similar bug reports on this issue marked as a duplicate of closed upstream bug 162726.

Anton (ademaro-mail) wrote :

When russian lang in keyboard layouts first (English - second) - in gnome-terminal (and guake) prints russian letter with Ctrl modifier. Also not work keyboard shorcuts in NetBeans.
Ubuntu 10.04 x64

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.