Ubuntu

Intrepid: gnome-terminal crashes on X redirection over ssh in Ubuntu 8.10

Reported by mjw on 2008-11-15
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Low
gnome-terminal (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

Since upgrading to Ubuntu 8.10, I am unable to start gnome-terminal from my local pc via ssh

Basically, gnome-terminal does a fatal exit with the following error message:

$ ssh -Y <email address hidden> gnome-terminal
<email address hidden>'s password:
**
ERROR:terminal-app.c:1525:terminal_app_init: assertion failed: (app->default_profile_id != NULL)

other users have noticed this:
http://ubuntuforums.org/showthread.php?t=977932
http://ubuntuforums.org/showthread.php?t=968008

p.s.

$ ssh -Y <email address hidden> xterm

and

$ ssh -Y <email address hidden> uxterm

works fine

mjw (fofftorrent) on 2008-11-15
description: updated
description: updated
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instuctions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in gnome-terminal:
status: New → Invalid
ronm99 (ronm99) wrote :

I'm having the same problem. I have 2 8.10 systems. One I can use 'ssh -YC <system name> gnome-terminal' the other fails with:
-> ssh -YC -l ron server gnome-terminal
**
ERROR:terminal-app.c:1525:terminal_app_init: assertion failed: (app->default_profile_id != NULL)

No crash is produced in /var/crash on either system.

Imperial Line (quangtonthat) wrote :

I seconded with ronm99. There is no crash, gnome-terminal just decides to quit by itself and it should very very simple to re-produce this problem (as described above).

I think this bug is very fundamental if you use the system to do serious works.

Imperial Line (quangtonthat) wrote :

I am not sure the status is invalid. It is a critical bug in Ubuntu 8.10

Changed in gnome-terminal:
status: Invalid → Confirmed
Pedro Villavicencio (pedro) wrote :

It's if you don't submit a backtrace. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-terminal:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Confirmed → Incomplete
Imperial Line (quangtonthat) wrote :

Here is the stack dump as requested. Hope this helps:

**
ERROR:terminal-app.c:1525:terminal_app_init: assertion failed: (app->default_profile_id != NULL)

Breakpoint 1, 0x00007fcf2c20a9c0 in abort () from /lib/libc.so.6
(gdb) bt
#0 0x00007fcf2c20a9c0 in abort () from /lib/libc.so.6
#1 0x00007fcf2c7c3d43 in g_assertion_message () from /usr/lib/libglib-2.0.so.0
#2 0x00007fcf2c7c41e2 in g_assertion_message_expr () from /usr/lib/libglib-2.0.so.0
#3 0x0000000000418be4 in ?? ()
#4 0x00007fcf2ca5701a in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#5 0x00007fcf2ca3b5cb in ?? () from /usr/lib/libgobject-2.0.so.0
#6 0x00007fcf2ca3bc13 in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#7 0x00007fcf2ca3c767 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#8 0x00007fcf2ca3c8ac in g_object_new () from /usr/lib/libgobject-2.0.so.0
#9 0x00000000004183b1 in ?? ()
#10 0x00000000004168da in ?? ()
#11 0x00007fcf2c1f4466 in __libc_start_main () from /lib/libc.so.6
#12 0x0000000000411709 in ?? ()
#13 0x00007fff37ac9208 in ?? ()
#14 0x000000000000001c in ?? ()
#15 0x0000000000000001 in ?? ()
#16 0x00007fff37ac995e in ?? ()
#17 0x0000000000000000 in ?? ()
(gdb)

Pedro Villavicencio (pedro) wrote :

could you install the gnome-terminal-dbgsym package and get a new one? the previous you submitted is missing a few symbols and please also submit your ~/.xsession-errors file, thanks!.

Imperial Line (quangtonthat) wrote :

Pedro,

Just curious - why can't you re-produce the bug or let the developer who is responsible to the gnome-terminal to do it? As mentioned before, it is VERY simple and obvious to generate this problem. All you need to do is to start gnome-terminal via ssh on a local PC and that is all.

No offense intended but I wonder if you actually use Ubuntu?

Btw, there is no ~/.xsession-errors since there is no X session or gnome session.

Pedro Villavicencio (pedro) wrote :

Thanks for the kind reply, I've asked you because i cannot reproduce this, there's a couple of reports upstream (http://bugzilla.gnome.org/show_bug.cgi?id=559465) with a similar backtrace and i'd like to see if there's the same one or not, I'm the person responsible for triaging these bugs and the developer who is in charge of gnome-terminal also read these emails so you're not talking to a person who don't use Ubuntu.

Imperial Line (quangtonthat) wrote :

Hi Petro,

Here is a full stack trace with the debugging symbols.

Starting program: /usr/bin/gnome-terminal
[Thread debugging using libthread_db enabled]
[New Thread 0x7f22ba964770 (LWP 21305)]

**
ERROR:terminal-app.c:1525:terminal_app_init: assertion failed: (app->default_profile_id != NULL)
[Switching to Thread 0x7f22ba964770 (LWP 21305)]

Breakpoint 1, 0x00007f22b70df9c0 in abort () from /lib/libc.so.6
(gdb)
(gdb) bt
#0 0x00007f22b70df9c0 in abort () from /lib/libc.so.6
#1 0x00007f22b7698d43 in g_assertion_message () from /usr/lib/libglib-2.0.so.0
#2 0x00007f22b76991e2 in g_assertion_message_expr () from /usr/lib/libglib-2.0.so.0
#3 0x0000000000418be4 in terminal_app_init (app=0x23948f0) at terminal-app.c:1525
#4 0x00007f22b792c01a in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#5 0x00007f22b79105cb in ?? () from /usr/lib/libgobject-2.0.so.0
#6 0x00007f22b7910c13 in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#7 0x00007f22b7911767 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#8 0x00007f22b79118ac in g_object_new () from /usr/lib/libgobject-2.0.so.0
#9 0x00000000004183b1 in terminal_app_initialize (use_factory=1) at terminal-app.c:1708
#10 0x00000000004168da in main (argc=1, argv=0x7fffc299c0e8) at terminal.c:1242
(gdb)

BTW, without looking at the report (http://bugzilla.gnome.org/show_bug.cgi?id=559465) that you mentioned earlier, it is clear to me that they are not the same since it involves a crash whereas the problem that we are talking about now is that the gnome-terminal just does an abort i.e. they are two distinct bugs.

Pedro Villavicencio (pedro) wrote :

thanks, i've sent it upstream to http://bugzilla.gnome.org/show_bug.cgi?id=561663.

Changed in gnome-terminal:
status: Incomplete → Triaged
Pedro Villavicencio (pedro) wrote :

upstream commented:

"I bet you do have

GConf Error: Failed to contact configuration server; some possible causes are
that you need to enable TCP/IP networking for ORBit, or you have stale NFS
locks due to a system crash. See http://www.gnome.org/projects/gconf/ for
information.

in your ~/.xsession-errors.

The cause is that since 2.24, gconf uses dbus to locate the gconfd server. On
the remote end, no dbus session bus is running and/or the dbus session bus
address env var isn't set.
"

do you also have those errors?

Imperial Line (quangtonthat) wrote :

This is a backward incompatibility bug introduced by some careless developers. I have stopped using Ubuntu because of this and others.

Suse is now my choice. More stability.

ronm99 (ronm99) wrote :

I had 2 systems, one I was able to start a remote gnome-terminal, (using ssh -YC <system name> gnome-terminal), the other failed with the assertion error.

One difference I found was in /etc/ssh/ssh_config

In the working system there was a line (added months ago to stop ssh from autologging out):
ServerAliveInterval 60

This wasn't in the failing system, I added the line and can now run remote gnome-terminals.

ronm99 (ronm99) wrote :

Must of been a coincidence, not working after a reboot. Didn't think it make any sense...

Imperial Line (quangtonthat) wrote :

Thanks for the tip ronm99!

I have also found a workaround by the following script:

#!/bin/bash

if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
        eval `dbus-launch --sh-syntax --exit-with-session`
fi

gnome-terminal $* &

gnome-terminal used to be my favorite term app but since I cannot disable blinking cursor (via ssh) and I cannot pick a cursor color. I have decided to use other system.

The blinking cursor really makes me go nuts!!!

zorblek (zorblek) wrote :

I have filed a report for a more severe bug that may be related at https://bugs.launchpad.net/ubuntu/+bug/303461 . Same setup, except pretty much every gnome app crashes on startup rather than just the terminal.

Pedro Villavicencio (pedro) wrote :

this has been fixed upstream, thanks for reporting.

Changed in gnome-terminal:
status: Triaged → Fix Committed
mjw (fofftorrent) wrote :

when will the fix be released? is there a beta that can be tested?

Changed in gnome-terminal:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 2.25.3-0ubuntu1

---------------
gnome-terminal (2.25.3-0ubuntu1) jaunty; urgency=low

  * New upstream version (LP: #316186):
    - Now uses DBus for single instance/factory setup
    - Bugs fixed (LP: #212761, LP: #298426, LP: #258775,
      LP: #279046, LP: #290777, LP: #194065).
  * debian/control{.in}:
    - Bumped build-dependency on libvte-dev to 1:0.19.1.
    - Dropped build-dependency on libgnomeui-dev.
    - Added build-dependency on libdbus-glib-1-dev (>= 0.6).
    - Dropped build-dependency on libxft-dev, as the xft VTE
      backend has gone.
  * debian/patches/01_lpi.patch:
    - New version update.
  * Dropped 05_restore_tab_switching_shortcuts.patch:
    - Merged upstream.
  * debian/patches/99_autoreconf.patch:
    - New version update.
  * debian/copyright:
    - Updated authors.
  * debian/gnome-terminal-data.install:
    - Don't try to install /usr/lib/bonobo, as it no longer exists.

 -- Chris Coulson <email address hidden> Sun, 11 Jan 2009 21:42:27 +0000

Changed in gnome-terminal:
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

This bug appears to be back:

  bug #436188 + dups

Changed in gnome-terminal:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.