apturl support

Bug #217611 reported by Artem Popov on 2008-04-15
34
Affects Status Importance Assigned to Milestone
Pidgin
Fix Released
Unknown
xchat
Unknown
Unknown
gnome-terminal (Ubuntu)
Wishlist
Unassigned
Declined for Hardy by Steve Langasek
Declined for Intrepid by Brian Murray
Declined for Jaunty by Brian Murray
pidgin (Ubuntu)
Wishlist
Unassigned
Declined for Hardy by Steve Langasek
Declined for Intrepid by Brian Murray
Declined for Jaunty by Brian Murray
xchat (Ubuntu)
Wishlist
Unassigned
Declined for Hardy by Steve Langasek
Declined for Intrepid by Brian Murray
Declined for Jaunty by Brian Murray
xchat-gnome (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Declined for Hardy by Steve Langasek
Declined for Intrepid by Brian Murray
Declined for Jaunty by Brian Murray

Bug Description

Binary package hint: gnome-terminal

apturl support for gnome-terminal, as specified in the apturl-omnipresence blueprint:
https://blueprints.edge.launchpad.net/ubuntu/+spec/apturl-omnipresence

Artem Popov (artfwo) wrote :

Attached a debdiff against 2.22.1-0ubuntu2, actually implementing the functionality. Working binary available for testing through my PPA (currently underway):
https://launchpad.net/~artfwo/+archive

Thanks for your report, Sebastien may you take a look to it later? thanks.

Changed in gnome-terminal:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → Confirmed

Same thing for pidgin, original bug marked as duplicate of this one.

Same thing for xchat-gnome (including urlscraper plugin).

Same thing for xchat. Working binaries for all mentioned packages available for testing in PPA:
https://launchpad.net/~artfwo/+archive

antistress (antistress) wrote :

see also Bug #144301 apturl doesn't work with Evince in PDF files

Artem Popov (artfwo) wrote :

It's fixed in Hardy, got apturl working in PDF, exported from OO.o

Changed in pidgin:
status: Unknown → Confirmed
Richard Laager (rlaager) on 2008-06-01
Changed in pidgin:
status: New → Confirmed
Changed in pidgin:
status: Confirmed → New
Siegfried Gevatter (rainct) wrote :

What's the status of this?

Andreas Moog (ampelbein) on 2008-09-18
Changed in xchat:
importance: Undecided → Wishlist
status: New → Confirmed
Andreas Moog (ampelbein) on 2008-09-22
Changed in xchat-gnome:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xchat-gnome - 1:0.24.0-0ubuntu1

---------------
xchat-gnome (1:0.24.0-0ubuntu1) intrepid; urgency=low

  * New upstream release: (LP: #273328)
    - Bug fixes (#431785, #551515)
    - Translation updates
  * debian/patches:
    - Remove 90_configure_ac.patch, merged upstream
    - Updated 98_autoconf.patch to apply cleanly
    - Added 95_apturl-support.patch for apturl integration (LP: #217611)

 -- Andreas Moog <email address hidden> Mon, 22 Sep 2008 23:26:43 +0200

Changed in xchat-gnome:
status: In Progress → Fix Released
KillerKiwi (killerkiwi2005) wrote :

Why is this protocol not registered in gconf instead?

That is a very good question.

Artem Popov (artfwo) wrote :

In fact, it is. See /desktop/gnome/url-handlers/apt

It is normally registered by installing apturl package, that is included on CD by default since gutsy, I think.

Changed in pidgin:
status: New → Fix Released
Changed in pidgin (Ubuntu):
importance: Undecided → Wishlist
summary: - [patch] apturl support
+ apturl support
Nigel Babu (nigelbabu) on 2010-08-21
tags: added: patch-forwarded-upstream
removed: patch
Changed in pidgin (Ubuntu):
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

The xchat patch didn't apply but was fairly trivial to update, so I'll sponsor that.

I looked at the gnome-terminal patch but looks like that codebase has changed a good bit. If this patch is still wanted it probably should be redone and retested. Feel free to re-sub ubuntu-sponsors once that's been done.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xchat - 2.8.8-3ubuntu12

---------------
xchat (2.8.8-3ubuntu12) precise; urgency=low

  * debian/patches/75_apturl-support.dpatch:
    - Add support for linkifying apturls (LP: #217611)
 -- Artem Popov <email address hidden> Wed, 16 Apr 2008 16:18:43 +0700

Changed in xchat (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2013-08-04
Changed in gnome-terminal (Ubuntu):
status: Confirmed → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.12.2-0ubuntu1

---------------
gnome-terminal (3.12.2-0ubuntu1) vivid; urgency=low

  [ Iain Lane ]
  * NOTE: This version changes behaviour around the "Switch to tab" keyboard
    shortcuts. They are now active all the time, whereas previously they were
    only active when you had a corresponding number of tabs open. If you need
    to send these keys to your terminal, clear the shortcuts in the
    preferences dialog.
  * Drop 03_add_keywords.desktop: Not useful any more.
  * Drop 20_add_alt_screen_toggle_ui.patch: Too much effort to maintain, not
    deemed important enough to keep.
  * Resynchronise with Debian, remaining changes:
    - debian/patches/50_add_unity_quicklist.patch: Add Unity quicklist menu
      item.
    - debian/patches/60_add_lp_handler.patch: Add a handler for launchpad bug
      URLs.
  * Disable shell provider, we don't want to build-dep on gnome-shell.
  * Bump build-dependencies according to configure.ac:
    - intltool 0.50.0
    - vte 0.36.0
    - glib 2.39.2
  * Make debian/patches/10_kfreebsd-f_dupfd_cloexec.patch apply again.
  * Add build-dependency on libnautilus-extension-dev
  * Add new patch debian/patches/nautilus-x11.patch
    - build fails because of -Wl,-z,defs missing -lX11 in nautilus extension
  * Include autoreconf.mk cdbs snippet and build-depend on dh-autoreconf
  * Install new files in gnome-terminal
    - nautilus extension
  * debian/patches/0001-Restore-transparency.patch: Patch from Debarishi Ray
    to re-add support for transparent terminals. Updated to support loading a
    transparency value from the theme, if it provides one and to migrate the
    settings from GConf.

  [ Jeremy Bicha ]
  * debian/rules:
    - Build with --enable-distro-packaging to not override Ubuntu
      environment variables
  * debian/patches/52_support_apturl.patch:
    - Support apt: URIs (LP: #217611)

  [ Martin Pitt ]
  * Add 61_cwd_fallback.patch: Provide fallback for reading current directory
    if OSC 7 fails. (LP: #1132700)
 -- Iain Lane <email address hidden> Wed, 05 Nov 2014 15:55:30 +0000

Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.