[SRU] 3.28.2 / 0.52.2

Bug #1774167 reported by Iain Lane on 2018-05-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane
vte2.91 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Iain Lane

Bug Description

[ Description ]

The second stable release in the 3.28 series.

[ QA ]

Check you can launch the terminal and use it. Maybe check that different themes, launching a custom command, custom terminal launchers, etc work.

We're allowed to believe upstream's bug fixes without explicitly verifying them:

https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

[ Regresison potential ]

If the update is rotten then the terminal might not work at all. There are fixes related to the list of encodings; if that's bad then you might not be able to use this functionality.

Iain Lane (laney) on 2018-05-30
summary: - [SRU] 3.28.2
+ [SRU] 3.28.2 / 0.52.2
Egmont Koblinger (egmont-gmail) wrote :

Yes please :)

For both components, there are only very few and tiny changes.

vte 0.52.2 (ftp://ftp.gnome.org/pub/GNOME/sources/vte/0.52/vte-0.52.2.changes) fixes a crash which I've also filed with further details as LP bug 1772506, hence releasing a fix is highly desirable.

> here are fixes related to the list of encodings; if that's bad then you might not be able to use this functionality.

gnome-terminal 3.28.2 (ftp://ftp.gnome.org/pub/GNOME/sources/gnome-terminal/3.28/gnome-terminal-3.28.2.changes) now translates the encoding names which were accidentally shown in the Preferences dialog in English. It simply adds a _(...) function call to the displayed string and does not affect the underlying behavior. That being said, of course it's appreciated if you double check the functionality.

Thanks!

Iain Lane (laney) on 2018-05-30
Changed in gnome-terminal (Ubuntu Bionic):
status: New → In Progress
Changed in vte2.91 (Ubuntu Bionic):
status: New → In Progress
Changed in gnome-terminal (Ubuntu):
status: New → Fix Committed
Changed in vte2.91 (Ubuntu):
status: New → Fix Committed
Changed in gnome-terminal (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
Changed in vte2.91 (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.52.2-1ubuntu1

---------------
vte2.91 (0.52.2-1ubuntu1) cosmic; urgency=medium

  [ Iain Lane ]
  * Merge with Debian. Remaining changes:
    - debian/rules:
      + Use --without-pcre2
    - Add revert-pcre2.patch:
      + Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
    - Add 91_keep_fds.patch since gdebi still requires it (LP: #1756238)
    - 0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
      + Keep as it is required for the Ubuntu theming
  * debian/gbp.conf: Update for Ubuntu

   [ Rico Tzschichholz ]
   * revert-pcre2.patch:
     - Don't revert unrelated g-i annotation changes to avoid unnecessary
       gir/vapi API changes compared to upstream (LP: #1765389)
  * revert-pcre2.patch: Refresh, fix a conflict.
  * debian/control{,.in}: Update Vcs-* for LP git

vte2.91 (0.52.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 0.52.2 (LP: #1774167):
    + [5966e8b] ring: Proper boundary checking for hyperlink position.
      This fixes a rare crash around hyperlinks in a non grid aligned VTE
      widget when the mouse enters the extra padding at the bottom. (LP:
      #1772506)
    + [7322c27] all: Fix spelling

 -- Iain Lane <email address hidden> Wed, 30 May 2018 13:09:28 +0100

Changed in vte2.91 (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.28.2-1ubuntu1

---------------
gnome-terminal (3.28.2-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian. Remaining changes:
    + debian/rules:
      - Install compatibility version of gnome-terminal.desktop
    + gnome-terminal.wrap, debian/rules:
      - Add a wrapper script to restore command line compatibility.
    + debian/control.in:
      - gnome-terminal depends on python3, python3-gi and gir1.2-glib-2.0 for
        the wrapper script.
      - Don't Build-Depend on PCRE2
    + Add 0001-Restore-transparency.patch:
      - Restore transparency support
    + Add 0001-Add-style-classes-and-CSS-names-to-some-of-our-widge.patch:
      - Add CSS names and style classes so we can theme things more easily.
    + Add 0001-screen-window-Extra-padding-around-transparent-termi.patch:
      - Fix transparency on Wayland. Patch by Owen Taylor, via Debarshi Ray @
        Fedora (LP: #1650395)
    + Add 50_add_unity_quicklist.patch:
      - Add Unity quicklist menu item.
    + Add 52_support_apturl.patch:
      - Support apt: urls.
    + Add 60_add_lp_handler.patch:
      - Add a handler for launchpad bug URLs.
    + Add scrollbar-background-theming.patch:
      - Draw background under the scrollbar that matches the actual terminal
        background color. This allows proper theming.
    + Add debian/patches/revert-pcre2.patch:
      - Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
  * Keep 006-fix-invalid-appstream-metadata.patch:
    - Ubuntu's AppStream versions and http://appstream.ubuntu.com/
      don't support gnome-terminal's syntax yet
  * debian/{gbp.conf,control{,.in}}: Update for Ubuntu

gnome-terminal (3.28.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 3.28.2 (LP: #1774167)
    + [47a9491] client: legacy: Fix output commenting.
      Make sure each line starts with '#' even if the message contains
      embedded newlines.
    + [1828cb6] prefs: editor: Translate encoding names (LP: #1771290)
  * Bump required vte to 2.52.2, per upstream.

gnome-terminal (3.28.1-2) unstable; urgency=medium

  * Restore File > New Tab menu item. Thanks Debarshi Ray for the suggestion.
    (LP: #1747171) (Closes: #783903)

 -- Iain Lane <email address hidden> Wed, 30 May 2018 13:47:09 +0100

Changed in gnome-terminal (Ubuntu):
status: Fix Committed → Fix Released
Robie Basak (racb) wrote :

SRU review: +1

It was quite painful to handle the quilt noise in revert-pcre2.patch and slowed down my review quite a bit to identify the real changes in there. I'd appreciate it if everyone could normalise their quilt refreshing in the future by using "-p ab --no-timestamps --no-index" or equivalent as recommended in https://wiki.debian.org/UsingQuilt please.

Changed in vte2.91 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello Iain, or anyone else affected,

Accepted vte2.91 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vte2.91/0.52.2-1ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-terminal (Ubuntu Bionic):
status: In Progress → Fix Committed
Iain Lane (laney) wrote :

I've been running it and it seems good to me.

Sorry, Robie, for the difficulty. I usually `quilt push' patches and look at the resulting diff in the source so I would tend to overlook people who read the diff.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.52.2-1ubuntu1~18.04.1

---------------
vte2.91 (0.52.2-1ubuntu1~18.04.1) bionic; urgency=medium

  * debian/{gbp.conf,control{,.in}}: Update for bionic.
  * Backport from cosmic to bionic.

vte2.91 (0.52.2-1ubuntu1) cosmic; urgency=medium

  [ Iain Lane ]
  * Merge with Debian. Remaining changes:
    - debian/rules:
      + Use --without-pcre2
    - Add revert-pcre2.patch:
      + Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
    - Add 91_keep_fds.patch since gdebi still requires it (LP: #1756238)
    - 0001-Add-the-style-context-provider-with-FALLBACK-priorit.patch:
      + Keep as it is required for the Ubuntu theming
  * debian/gbp.conf: Update for Ubuntu

   [ Rico Tzschichholz ]
   * revert-pcre2.patch:
     - Don't revert unrelated g-i annotation changes to avoid unnecessary
       gir/vapi API changes compared to upstream (LP: #1765389)
  * revert-pcre2.patch: Refresh, fix a conflict.
  * debian/control{,.in}: Update Vcs-* for LP git

vte2.91 (0.52.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 0.52.2 (LP: #1774167):
    + [5966e8b] ring: Proper boundary checking for hyperlink position.
      This fixes a rare crash around hyperlinks in a non grid aligned VTE
      widget when the mouse enters the extra padding at the bottom. (LP:
      #1772506)
    + [7322c27] all: Fix spelling

 -- Iain Lane <email address hidden> Wed, 30 May 2018 13:19:02 +0100

Changed in vte2.91 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for vte2.91 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.28.2-1ubuntu1~18.04.1

---------------
gnome-terminal (3.28.2-1ubuntu1~18.04.1) bionic; urgency=medium

  * debian/{gbp.conf,control{,.in}}: Update for Ubuntu bionic
  * Backport from cosmic to bionic.

gnome-terminal (3.28.2-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian. Remaining changes:
    + debian/rules:
      - Install compatibility version of gnome-terminal.desktop
    + gnome-terminal.wrap, debian/rules:
      - Add a wrapper script to restore command line compatibility.
    + debian/control.in:
      - gnome-terminal depends on python3, python3-gi and gir1.2-glib-2.0 for
        the wrapper script.
      - Don't Build-Depend on PCRE2
    + Add 0001-Restore-transparency.patch:
      - Restore transparency support
    + Add 0001-Add-style-classes-and-CSS-names-to-some-of-our-widge.patch:
      - Add CSS names and style classes so we can theme things more easily.
    + Add 0001-screen-window-Extra-padding-around-transparent-termi.patch:
      - Fix transparency on Wayland. Patch by Owen Taylor, via Debarshi Ray @
        Fedora (LP: #1650395)
    + Add 50_add_unity_quicklist.patch:
      - Add Unity quicklist menu item.
    + Add 52_support_apturl.patch:
      - Support apt: urls.
    + Add 60_add_lp_handler.patch:
      - Add a handler for launchpad bug URLs.
    + Add scrollbar-background-theming.patch:
      - Draw background under the scrollbar that matches the actual terminal
        background color. This allows proper theming.
    + Add debian/patches/revert-pcre2.patch:
      - Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
  * Keep 006-fix-invalid-appstream-metadata.patch:
    - Ubuntu's AppStream versions and http://appstream.ubuntu.com/
      don't support gnome-terminal's syntax yet
  * debian/{gbp.conf,control{,.in}}: Update for Ubuntu

gnome-terminal (3.28.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 3.28.2 (LP: #1774167)
    + [47a9491] client: legacy: Fix output commenting.
      Make sure each line starts with '#' even if the message contains
      embedded newlines.
    + [1828cb6] prefs: editor: Translate encoding names (LP: #1771290)
  * Bump required vte to 2.52.2, per upstream.

gnome-terminal (3.28.1-2) unstable; urgency=medium

  * Restore File > New Tab menu item. Thanks Debarshi Ray for the suggestion.
    (LP: #1747171) (Closes: #783903)

gnome-terminal (3.28.1-1ubuntu2) cosmic; urgency=medium

  * Restore File > New Tab menu item. Thanks Debarshi Ray for the suggestion.
    (LP: #1747171)

 -- Iain Lane <email address hidden> Wed, 30 May 2018 14:03:45 +0100

Changed in gnome-terminal (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers