Untranslated list of encodings in preferences

Bug #1771290 reported by Egmont Koblinger on 2018-05-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Medium
Iain Lane
Bionic
Medium
Iain Lane

Bug Description

[ Description ]

The list of encodings in Preferences → Compatibility is in English. The list in the Terminal → Set Character Encoding menu is properly translated, though.

Upstream bugreport: https://bugzilla.gnome.org/show_bug.cgi?id=795358

Upstream trivial fix: https://git.gnome.org/browse/gnome-terminal/commit/?h=gnome-3-28&id=1828cb6d5

[ QA ]

If you're using English, install another locale and its translations and then-

LC_ALL=fr_FR.UTF-8 /usr/lib/gnome-terminal/gnome-terminal-server --app-id=com.foo

in another terminal

/usr/bin/gnome-terminal.real --app-id=com.foo

Navigate to Edit -> Preferences -> <a profile> -> Compatibility and have a look at the Encoding combo (the third one down since this is not actually in English for you). Check that e.g. Hebrew says Hébreu.

[ Regression potential ]

Under the upstream MRE, you can believe this is fixed.

[ Original description ]

Could you please backport this tiny fix to Bionic LTS?

(We're planning to release gnome-terminal 3.28.2 containing this plus at least one other tiny fix in about a week.)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-terminal 3.28.1-1ubuntu1 [modified: usr/bin/gnome-terminal usr/lib/gnome-terminal/gnome-terminal-server usr/share/applications/org.gnome.Terminal.desktop usr/share/glib-2.0/schemas/org.gnome.Terminal.gschema.xml usr/share/metainfo/org.gnome.Terminal.appdata.xml]
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Tue May 15 09:46:24 2018
InstallationDate: Installed on 2016-11-09 (551 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to bionic on 2018-03-14 (61 days ago)

Egmont Koblinger (egmont-gmail) wrote :
Jeremy Bicha (jbicha) on 2018-05-15
Changed in gnome-terminal (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-terminal (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Triaged
Iain Lane (laney) wrote :
Changed in gnome-terminal (Ubuntu):
assignee: nobody → Iain Lane (laney)
Changed in gnome-terminal (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.28.2-1ubuntu1

---------------
gnome-terminal (3.28.2-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian. Remaining changes:
    + debian/rules:
      - Install compatibility version of gnome-terminal.desktop
    + gnome-terminal.wrap, debian/rules:
      - Add a wrapper script to restore command line compatibility.
    + debian/control.in:
      - gnome-terminal depends on python3, python3-gi and gir1.2-glib-2.0 for
        the wrapper script.
      - Don't Build-Depend on PCRE2
    + Add 0001-Restore-transparency.patch:
      - Restore transparency support
    + Add 0001-Add-style-classes-and-CSS-names-to-some-of-our-widge.patch:
      - Add CSS names and style classes so we can theme things more easily.
    + Add 0001-screen-window-Extra-padding-around-transparent-termi.patch:
      - Fix transparency on Wayland. Patch by Owen Taylor, via Debarshi Ray @
        Fedora (LP: #1650395)
    + Add 50_add_unity_quicklist.patch:
      - Add Unity quicklist menu item.
    + Add 52_support_apturl.patch:
      - Support apt: urls.
    + Add 60_add_lp_handler.patch:
      - Add a handler for launchpad bug URLs.
    + Add scrollbar-background-theming.patch:
      - Draw background under the scrollbar that matches the actual terminal
        background color. This allows proper theming.
    + Add debian/patches/revert-pcre2.patch:
      - Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
  * Keep 006-fix-invalid-appstream-metadata.patch:
    - Ubuntu's AppStream versions and http://appstream.ubuntu.com/
      don't support gnome-terminal's syntax yet
  * debian/{gbp.conf,control{,.in}}: Update for Ubuntu

gnome-terminal (3.28.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 3.28.2 (LP: #1774167)
    + [47a9491] client: legacy: Fix output commenting.
      Make sure each line starts with '#' even if the message contains
      embedded newlines.
    + [1828cb6] prefs: editor: Translate encoding names (LP: #1771290)
  * Bump required vte to 2.52.2, per upstream.

gnome-terminal (3.28.1-2) unstable; urgency=medium

  * Restore File > New Tab menu item. Thanks Debarshi Ray for the suggestion.
    (LP: #1747171) (Closes: #783903)

 -- Iain Lane <email address hidden> Wed, 30 May 2018 13:47:09 +0100

Changed in gnome-terminal (Ubuntu):
status: Triaged → Fix Released
Łukasz Zemczak (sil2100) wrote :

Since this bug has been linked from an SRU, we would need it to have the SRU template information filled in. Could that be done?

Iain Lane (laney) wrote :

SGTM in bionic-proposed.

description: updated
Changed in gnome-terminal (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-done-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-terminal - 3.28.2-1ubuntu1~18.04.1

---------------
gnome-terminal (3.28.2-1ubuntu1~18.04.1) bionic; urgency=medium

  * debian/{gbp.conf,control{,.in}}: Update for Ubuntu bionic
  * Backport from cosmic to bionic.

gnome-terminal (3.28.2-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian. Remaining changes:
    + debian/rules:
      - Install compatibility version of gnome-terminal.desktop
    + gnome-terminal.wrap, debian/rules:
      - Add a wrapper script to restore command line compatibility.
    + debian/control.in:
      - gnome-terminal depends on python3, python3-gi and gir1.2-glib-2.0 for
        the wrapper script.
      - Don't Build-Depend on PCRE2
    + Add 0001-Restore-transparency.patch:
      - Restore transparency support
    + Add 0001-Add-style-classes-and-CSS-names-to-some-of-our-widge.patch:
      - Add CSS names and style classes so we can theme things more easily.
    + Add 0001-screen-window-Extra-padding-around-transparent-termi.patch:
      - Fix transparency on Wayland. Patch by Owen Taylor, via Debarshi Ray @
        Fedora (LP: #1650395)
    + Add 50_add_unity_quicklist.patch:
      - Add Unity quicklist menu item.
    + Add 52_support_apturl.patch:
      - Support apt: urls.
    + Add 60_add_lp_handler.patch:
      - Add a handler for launchpad bug URLs.
    + Add scrollbar-background-theming.patch:
      - Draw background under the scrollbar that matches the actual terminal
        background color. This allows proper theming.
    + Add debian/patches/revert-pcre2.patch:
      - Revert changes that require PCRE2 since it's not in main
        (see MIR #163666)
  * Keep 006-fix-invalid-appstream-metadata.patch:
    - Ubuntu's AppStream versions and http://appstream.ubuntu.com/
      don't support gnome-terminal's syntax yet
  * debian/{gbp.conf,control{,.in}}: Update for Ubuntu

gnome-terminal (3.28.2-1) unstable; urgency=medium

  [ Iain Lane ]
  * New upstream release 3.28.2 (LP: #1774167)
    + [47a9491] client: legacy: Fix output commenting.
      Make sure each line starts with '#' even if the message contains
      embedded newlines.
    + [1828cb6] prefs: editor: Translate encoding names (LP: #1771290)
  * Bump required vte to 2.52.2, per upstream.

gnome-terminal (3.28.1-2) unstable; urgency=medium

  * Restore File > New Tab menu item. Thanks Debarshi Ray for the suggestion.
    (LP: #1747171) (Closes: #783903)

gnome-terminal (3.28.1-1ubuntu2) cosmic; urgency=medium

  * Restore File > New Tab menu item. Thanks Debarshi Ray for the suggestion.
    (LP: #1747171)

 -- Iain Lane <email address hidden> Wed, 30 May 2018 14:03:45 +0100

Changed in gnome-terminal (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-terminal has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers