Terminal size information isn't displayed during window resizing (in Wayland sessions)

Bug #1728078 reported by Jonathan Kamens on 2017-10-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-shell (Fedora)
Fix Released
Undecided
gnome-shell (Ubuntu)
Low
Unassigned
gnome-terminal (Ubuntu)
Wishlist
Unassigned

Bug Description

I like seeing the window geometry when I'm resizing a window. This makes it easy, e.g., to resize a terminal window to one of the standard sizes like 80x24, or to ensure that an Emacs window has the number of columns that I want it to when I'm done editing a file with longer lines than that.

In 17.04 and earlier, the "Resize Info" compiz plugin provided this functionality.

I believe compiz is no longer used in 17.10 with Wayland sessions, and this functionality appears to be gone with no way to get it back.

Please bring back resize info.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.26.1-0ubuntu4
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Oct 27 11:28:35 2017
DisplayManager: gdm3
InstallationDate: Installed on 2017-05-19 (160 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to artful on 2017-10-20 (7 days ago)

Description of problem:
When resizing a gnome-terminal window in a GNOME on Xorg session, the familiar tooltip in the center of the window which displays the window dimensions is missing.

Version-Release number of selected component (if applicable):
gnome-shell-3.19.4-2.fc24

How reproducible:
Always.

Steps to Reproduce:
1. Launch GNOME on Xorg session.
2. Launch gnome-terminal.
3. Resize terminal window.

Actual results:
Window gets resized but no window dimensions are displayed.

Expected results:
Window gets resized and window dimensions are displayed.

Additional info:
1. The tooltip is displayed correctly for current Fedora 23.
2. Installed packages include xorg-x11-server-Xorg-1.18.1-1.fc24.

This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

*** Bug 1350506 has been marked as a duplicate of this bug. ***

I'm seeing this on F24 with all windows, not just gnome-terminal.

Partial duplicate of Bug 1349688.

Presently, I have two F24 systems which I upgraded from F22. In F22, I got correct dimensions displayed for all windows when resizing, on both systems. (gnome-terminal and gvim showed columns and rows, everything else showed width and height in pixels.)

What I have after upgrading to F24 is one system where I get no dimensions tooltip for anything, and one system where I still get the dimensions tooltips, but for gnome-terminal the dimensions are now in pixels.

I'd love to help troubleshoot this so we can get it fixed. Please let me know what information is needed.

It is caused by Wayland. After changing /etc/gdm/custom.conf to use
Xorg:

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false

I got back the geometry when resizing.

*** This bug has been marked as a duplicate of bug 1269097 ***

(In reply to H.J. Lu from comment #6)
Issue appears to have been resolved for both of current Fedora 24 and Fedora 25 with the standard setup of GDM (running on top of Wayland). I have checked for Fedora 24 running inside a virtual machine:
- window geometry is shown when choosing GNOME on Xorg session.
- window geometry is not shown GNOME (on Wayland) session.
For Fedora 25, the issue is gone both when running on bare metal and inside a virtual machine.

I am not sure if this is the same bug, but it appears to be closely related:

Using Fedora 25:
cppad_mixed.git>uname -a
Linux localhost.localdomain 4.9.14-200.fc25.x86_64 #1 SMP Mon Mar 13 19:26:40 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
when I resize a gnome terminal window it does not display the window size in characters during the resize operation.

When I use Fedora 23:
~>uname -a
Linux brad-home 4.7.5-100.fc23.x86_64 #1 SMP Mon Sep 26 19:29:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
and I resize a terminal window, the size of the window in characters is displayed in the center of the widow during the resize operation

P.S.
I am using a virtual machine for both of these tests.

(In reply to Brad Bell from comment #8)
Please make sure that you run a GNOME on Xorg session under Fedora 25. The default session type is GNOME on Wayland now.

Selecting the gear icon on the login screen, and then Xorg, worked. Thanks.

(In reply to Brad Bell from comment #10)
Here, things work as expected both under Fedora 25 and Fedora 26. To make sure that your actual session type is really "GNOME on Xorg", verify that your environment satisfies DESKTOP_SESSION=gnome-xorg, thanks.

Jonathan Kamens (jik) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-shell (Ubuntu):
importance: Undecided → Wishlist

This feature does exist if you log into "Ubuntu on Xorg". Strange it's missing in Wayland logins...

summary: - "Resize Info" (compiz plugin) no longer available in 17.10 with Wayland
+ Terminal size information isn't displayed during resizing
summary: - Terminal size information isn't displayed during resizing
+ Terminal size information isn't displayed during resizing (in Wayland
+ sessions)
summary: - Terminal size information isn't displayed during resizing (in Wayland
- sessions)
+ Terminal size information isn't displayed during window resizing (in
+ Wayland sessions)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in gnome-shell (Ubuntu):
importance: Wishlist → Low
Changed in gnome-shell (Fedora):
importance: Unknown → Undecided
status: Unknown → Fix Released
Daniel van Vugt (vanvugt) wrote :

Actually it sounds like in a Wayland world, the individual apps might have to display this information themselves. So that's also an enhancement for Gnome Terminal.

Changed in gnome-terminal (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: bionic cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.