keyboard autorepeat not happening when I hold down any key

Bug #1722298 reported by Jim Kolberg on 2017-10-09
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

The failure to auto repeat happens in all terminal apps I've tried in Artful. If I open a virtual console, it looks like a phantom is typing ^@ about once per second. This prevents successfully typing a password, and is probably what is breaking autorepeat in the GUI terminals, although they don't show the ^@. Gnome terminal and guake also can't stay scrolled up in the buffer for more than a second before popping back down to the bottom.

This problem happens in the Ubuntu desktop or Gnome and it doesn't matter if I pick the xorg or default Wayland options. It happens under both the open source and proprietary nvidia drivers. It also happens with a newly created user with no home directory baggage.

xev reports a constant stream of the following about the same frequency as the ^@ in console:
KeyPress event, serial 62, synthetic NO, window 0x3800001,
    root 0x1dd, subw 0x0, time 2243032, (20,-13), root:(1375,501),
    state 0x10, keycode 221 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

If I boot into a recovery shell, the problem does _not_ appear.

My system was built with a fresh install of 17.04, installed my usual packages, then upgrade to 17.10 when the problem began. I'm certain it was not present in 17.04 for the few days before I upgraded. There were similar bugs reported a decade ago, but didn't help me.

Expectation: Hold down any key in terminal window. After a moment, the letter should repeat until key is released.

Actually: Key will repeat 0 or a few times, but stop repeating before I release the key.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-terminal 3.24.2-0ubuntu4
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Mon Oct 9 10:43:56 2017
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-10-05 (4 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to artful on 2017-10-05 (3 days ago)

Jim Kolberg (jimko) wrote :
Jim Kolberg (jimko) wrote :

I wanted to open this while my PC was still in an "upgraded" state, but I just did a clean install of 17.10 with today's daily image and the problem persists as reported. I can even reproduce it booting off the the install media and clicking the Try Ubuntu option. Any advice on narrowing it down is welcome.

Gunar Dierigen (ranug) wrote :

I have the same problem, using a Lenovo Laptop.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Ronaldo Passanha (passanha) wrote :

I have the same problem, using the Positivo S1991.

Marius Gedminas (mgedmin) wrote :

This doesn't look like a terminal problem. It looks like a kernel problem -- some input device is spamming fake key press events.

It would be useful if you could determine which device is sending these events. I would run `sudo evemu-record`, pick each device in turn, to see if it sees repeating events or not.

Alessandro Stamatto (astamatto) wrote :

I'm having the same problem, following Marius Tip theres one Input Device that keeps repeating events. Is this normal? It's really annoying, it interrupts all key holdings (even the arrow ones, ugh). The device that keeps repeating the events, and the repeated events:

/dev/input/event9: PEAQ WMI hotkeys

E: 0.000001 0001 00d5 0001 # EV_KEY / KEY_SOUND 1
E: 0.000001 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +0ms
E: 0.000017 0001 00d5 0000 # EV_KEY / KEY_SOUND 0
E: 0.000017 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +0ms
E: 0.768001 0001 00d5 0001 # EV_KEY / KEY_SOUND 1
E: 0.768001 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +768ms
E: 0.768017 0001 00d5 0000 # EV_KEY / KEY_SOUND 0
E: 0.768017 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +0ms
E: 1.535971 0001 00d5 0001 # EV_KEY / KEY_SOUND 1
E: 1.535971 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +767ms
E: 1.535988 0001 00d5 0000 # EV_KEY / KEY_SOUND 0
E: 1.535988 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +0ms
E: 2.303989 0001 00d5 0001 # EV_KEY / KEY_SOUND 1
E: 2.303989 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +768ms
E: 2.304007 0001 00d5 0000 # EV_KEY / KEY_SOUND 0
E: 2.304007 0000 0000 0000 # ------------ SYN_REPORT (0) ---------- +1ms

Ronaldo Passanha (passanha) wrote :

I fund a problem with the peaq wmi module. I just executed rmmod peaq_wmi and now it's OK, but I do not know anything about this module. Can you help me?

Alessandro Stamatto (astamatto) wrote :

"sudo rmmod peaq_wmi" also fixed the problem for me (thanks Ronaldo!).

peaq_wmi was spamming ^@ non stop. It made the system complete nonoperational, insane lag and it crashed after some time when a text input appeared.

Workaround solution:

sudo rmmod peaq_wmi
sudo gedit /etc/modprobe.d/blacklist.conf

#add at the end:
#spams ^@
blacklist peaq_wmi

Ronaldo Passanha (passanha) wrote :

Perfect , thanks Alessandro.

Jim Kolberg (jimko) wrote :

I finally got the evemu program to work, same results as above. Now that I know what module, there are lot of other reports. Looks like a longterm fix is coming from upstream. Sorry for the dupe, but thanks for helping track it down and workaround.

Vadzim (osvadimos) wrote :

Helped me. Thanks Alessandro.

Jonathan (jsenn1995) wrote :

I had the same problem on Ubuntu 16.04.3 LTS, also Lenovo Ideapad 700. The fix above worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers