Gnome Terminal doesn't launch

Bug #1652451 reported by Cerin on 2016-12-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

I'm unable to launch Gnome Terminal. I had to install Terminator so I could get a working terminal so I could get the error message:

$ gnome-terminal
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.gnome.Terminal exited with status 8

I tried purging and reinstalling Gnome Terminal, but the problem persists.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-terminal 3.18.3-1ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-47.68-generic 4.4.24
Uname: Linux 4.4.0-47-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.4
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Dec 24 12:02:49 2016
InstallationDate: Installed on 2015-10-20 (430 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to xenial on 2016-09-16 (99 days ago)

Cerin (chrisspen) wrote :
Mason Loring Bliss (y-mason) wrote :

Note: 1474927, 1578830, and 1652451 all seem to refer to the same issue. The
error code noted is documented here:

    https://wiki.gnome.org/Apps/Terminal/FAQ#Exit_status_8

This followed by a reboot or logging back in ought to resolve the issue:

    sudo localectl set-locale LANG=en_US.utf8

If you've done something invasive with locales, you might need to do something
more invasive to resolve the issue, as noted here:

    https://askubuntu.com/questions/608330/problem-with-gnome-terminal-on-gnome-3-12-2/651169#651169

Thanks to timeless on Freenode for the link to the exit status.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers