Ubuntu

[suggestion] allow to pick non anti-aliased fonts un GNOME terminal

Reported by Dominique Pellé on 2007-11-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

1/ In the GNOME terminal settings, it is not possible to select a non anti-aliased font by default.

I personally find this very annoying. Anti-aliased fonts are great for plenty of things,
but for a terminal, I very much prefer a crisp, small, non anti aliased font.

OK, after tweaking a bit, it is possible to set up a non anti aliased font, but it's definitely
not easy for newbies. I managed to use the MiscFixed font by looking at information
posted here:

http://izumi.plan99.net/blog/index.php/2007/04/15/non-antialiased-fonts-in-gnome-terminal/

I can't remember now exactly how I did it (it was a while ago) but I think I needed
to reconfigure a font rendering package to allow for non anti aliased font.

With the non antialiased MiscFixed font, the GNOME terminal is also faster, and allows
to chose a very small fonts (so I can put more terminals on the screen).

This is not a bug, but something on the wishlist. I think it's fairly important though
because the GNOME terminal is one of the most important application of Ubuntu.

2/ As an additional remark, when selecting a font in the GNOME terminal, most of
the available fonts are non fixed size. I think it does not make much sense to use
a non fixed font size in a terminal. It's also hard to spot the fixed font size among
all the variable size fonts. Perhaps fixed font size should be somehow highlighted,
or variable size fonts should perhaps even be filtered out by default (with a checkbox
to allow them)

I've put screenshot only with:

- default system font (antialiased, too big for my taste)
   http://dominique.pelle.free.fr/pic/antialiased-term.png

- the MiscFixed font, non antialiased (better in my opinion).
   http://dominique.pelle.free.fr/pic/non-antialiased-term.png

I'm not saying it should be the default font, but at least
GNOME terminal should allow user to pick non antialiased
fonts without having to tweak, reconfigure package etc.

description: updated
SK (stephantom) wrote :

Someone should set this to 'wishlist'.

Changed in gnome-terminal:
status: New → Confirmed
Changed in gnome-terminal:
importance: Undecided → Wishlist

A WORKAROUND:

You can enable non TrueType fonts with

sudo dpkg-reconfigure fontconfig-config
# answer the Question "Enable bitmapped fonts by default?" with "Yes"
sudo fc-cache -fv

You are now able to select "Terminal","Clean" etc. fonts in the fonts menu.

The question is, do the defaults (disabling bitmap-fonts) of 'fontconfig-config' package make sense?

Pedro Villavicencio (pedro) wrote :

thanks for the report, to be forwarded upstream by someone interested on the feature, for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving this as incomplete until that, thanks you.

Changed in gnome-terminal:
assignee: nobody → desktop-bugs
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in gnome-terminal:
status: Incomplete → Invalid
Changed in gnome-terminal (Ubuntu):
status: Invalid → New
Eugenia Loli-Queru (eloli) wrote :

I've re-opened the bug because I'd like gnome-terminal to be able to "see" xterm's bitmap font too, EVEN if bitmap fonts are turned off in the rest of the Gnome configuration. I'm not convinced that this is an upstream feature request only, since it was ubuntu decision to turn off bitmap fonts (Debian ships with bitmap fonts ON, for example.). Xterm/Terminal has a huge legacy in terms of history of using it, and people need small size fonts that its characters don't collide (something that's not possible with the current Ubuntu font engine and monospace TTF fonts). Therefore, the xterm font (whatever xterm is using), is preferable to many old timers. Maybe younger users don't care much, but people who use the terminal a lot, and have a bunch of them open in the screen, do.

So please either enable bitmap fonts on ubuntu by default (although I'm not advocating that this is a great idea -- it might have other repercussions), or, add some code on gnome-terminal to be able to "see" and use the xterm bitmap font in its Profile's font list dialog, even if the rest of the Gnome apps can't see that font. In other words, "special case" gnome-terminal, because in all truth, it's a utility that IS special -- in terms of 40 years of usage patterns.

Eugenia Loli-Queru (eloli) wrote :

I made a feature request upstream on gnome bugzilla and they say that they won't add the feature. So the ball is on Ubuntu's court: please either enable bitmap fonts back by default, or special-case gnome-terminal with a patch.

Thomas Hotz (thotz) wrote :

Confirming this bug because it happens to several users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed
Thomas Hotz (thotz) wrote :

Eugenia, can you tell us the link of your upstream bug report on the bugzilla in GNOME. Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers