Ubuntu

Cannot use Ctrl-Tab as keyboard shortcut in gnome-terminal

Reported by Mikael Ståldal on 2007-11-11
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-terminal

It is not possible to use Ctrl-Tab as keyboard shortcut in gnome-terminal.

I would like to use it to switch tabs.

Stoanhart (stoanhart) wrote :

I agree. It seems that the tab key can not be used, regardless of what the combo is. I would like consitent tab management between firefox and gnome-terminal.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, that's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=123994

comment from upstream:

"There are a couple of keys which are not candidates to be keyboard
accelerators, independently of the modifiers. Tab is one of those
keys, as it (with various combinations of modifiers) are reserved by
gtk for its own use and the window manager.

Note that validity is decided by calling gtk_accelerator_valid, but
the list of valid accelerator keys seems to be only in the source
(which you can find at
http://cvs.gnome.org/lxr/source/gtk+/gtk/gtkaccelgroup.c#790, in case
you feel like it)
"

Changed in gnome-terminal:
status: New → Invalid
Mikael Ståldal (mikaelstaldal) wrote :

I posted this comment upstream:

"I think that is a serious limitiation to not be able to use Ctrl-Tab as a
keyboard shortcut in Gnome applications.

Elsewhere, it is a convention to use Ctrl-Tab to switch between tabs/subwindows
within an application. You use this in e.g. Mozilla Firefox, and I successfully
configured Eclipse for this behaviour.

Since you use Alt-Tab to switch between applications, it's quite convenient to
be able to use Ctrl-Tab to swtich tab/subwindow within an application."

Keith Hughitt (keith-hughitt) wrote :

I also think it would be great to be able to configure gnome-terminal to use (shift) Control + Tab.

LeviRosol (levi-rosol) wrote :

Agreed that this is a useful, and more and more commonly used keyboard shortcut.

Kyle Lin (luckysolar) wrote :

Agreed. I think it is important to me for using Ctrl +Tab to swith tabs when I write code by vim. Expect we can configure gnome-terminal to use this feature.

Paolo Milani (j-s-sebastian) wrote :

Agreed. I think most users learned about tabs from the firefox browser, so other applications should follow the conventions set by firefox: (shift) ctrl+tab to switch, ctrl-N for a new tab, ctrl-f4 to close a tab

Changed in gnome-terminal (Ubuntu):
status: Invalid → Confirmed
Felipe Amado (amadinho10) wrote :

I agree. And I think all applications should use the same keyboard shortcuts for tabs management (Ctrl + T, Ctrl + W, Ctrl + Tab).

rusik3 (rusik3) wrote :

It is a really not usefull without ctr + tab and ctr+shift_tab

duncan mcnae (duncanmcnae) wrote :

Very much needed to get unity between different programs and their tab behaviour. It is this way in nautilus....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.