terminal gets wrong DISPLAY with dual head xorg

Bug #157708 reported by Sami Nybacka on 2007-10-27
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

Ubuntu Gutsy, gnome-terminal version: 2.18.2-0ubuntu1

I have dual screen (non xinerama) xorg setup (i810), so there is two separate displays, :0.0 and :0.1.

When I open new terminal from
1) Applications > Accessories > Terminal or
2) launcher from panel (type: Application, command: gnome-terminal) or
3) laucher from desktop (type: Application in Terminal, command: zsh)
DISPLAY is sometimes wrong: terminal opened on :0.0 gets DISPLAY=:0.1 and vice versa.

Usually when this starts to happen, it is hard to get it right again. Usually I have to close all terminals in both displays before terminal again gets right DISPLAY. When this starts to happen seems quite random, but is really annoying in dual screen x, where you can't move windows from one screen to another.

Maybe this bug is somehow related to gnome-panel bug, where Workspace Switcher gets attached to wrong display: Bug #110899.

Pedro Villavicencio (pedro) wrote :

thanks for your report, may you send this upstream since you're facing the issue have the setup and can answer to the questions upstream will do it? for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving this as incomplete until that, thanks for your help.

Changed in gnome-terminal:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

any chance to submit this upstream? otherwise i'm going to close this bug.

Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in gnome-terminal:
status: Incomplete → Invalid
Vincent Gerris (vgerris) wrote :

I have the same problem on Ubuntu 9.04 (after upgrade from 8.10).
This might be related to the bug that lets nautilus start on the wrong screen?
Pedro, please be clear in what info you want, i can reproduce this bug.
No use in trying to close bugs all the time, while the idea is to get them fixed and enjoy a properly working Ubuntu i think?

Vincent Gerris (vgerris) on 2009-04-24
Changed in gnome-terminal (Ubuntu):
status: Invalid → Confirmed
Vincent Gerris (vgerris) wrote :

The glibc bug seems to be fixed, a patch is supplied here:
http://bugzilla.gnome.org/show_bug.cgi?id=580103

I have not seen an updated package for ubuntu 9.04 yet.
Does anyone know how to achieve this?

Changed in gnome-terminal (Ubuntu):
status: Confirmed → Fix Committed
Vincent Gerris (vgerris) wrote :

Here is the applied fix.
Can anyone point out how this can be applied to the package?

Vincent Gerris (vgerris) wrote :

Thanks to midnightflash and keepitsimpleengr, here are some pretty nice instructions to get it fixed.

Why on Earth is this not available in update manager???

https://answers.launchpad.net/ubuntu/+source/glib2.0/+question/77380

It worked for me, thank you all for your support!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.