[Patch] CRASH when dragging a tab and later changing its title

Bug #1331864 reported by Egmont Koblinger on 2014-06-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Critical
gnome-terminal (Ubuntu)
Undecided
Unassigned

Bug Description

Gnome-terminal can crash if a tab is dragged across windows, and later the title of the tab is changed.

Since gnome-terminal is one single process for all your terminal windows and tabs, upon a crash all the gnome-terminal windows disappear, easily causing loss of precious unsaved work.

To easily reproduce:

1. Open at 2 (or more) gnome-terminal windows, and in one of them 2 (or more) tabs.

2. In one of these tabs, make the title change constantly:
while sleep 0.1; do echo -ne "\e]0;$(date +%S)\a"; done

3. Drag and drop this tab (with the changing title) to another gnome-terminal window. (Don't drag it within the same window, that won't make it crash.) Repeat this step multiple times.

After a few (usually less than 10) drag-n-drop actions, gnome-terminal crashes.

Please backport this fix from mainstream:
https://git.gnome.org/browse/gnome-terminal/commit/?id=f65261a

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-terminal 3.6.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Jun 19 01:37:45 2014
InstallationDate: Installed on 2012-05-30 (749 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to trusty on 2014-03-25 (85 days ago)

Egmont Koblinger (egmont-gmail) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-terminal (Ubuntu):
status: New → Confirmed

I experience this bug every couple of days, loosing all the open tabs and being left with e.g. lot of vim swap files.

The bug description is perfect and easy to reproduce in 1 minute. The linked patch is plausible, small and just should be merged!

Changed in gnome-terminal:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.