shares-admin crashed with SIGABRT in __libc_message()

Bug #932570 reported by John Gary
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu precise (development branch)
Release: 12.04

gnome-system-tools 3.0.0-2ubuntu1

I wanted to install samba (to accomodate my local public library system's Windows NT server set up).

I attempted to launch shares-admin in Terminal and it crashed. (Feb. 15, 2012 up-to-date Xubuntu 12.04 LTS Alpha 2 amd64.)

Here's the output from Terminal:

john@john-Aspire-5517:~$ shares-admin

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:60:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:61:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:69:32: 'none' is not a valid color name

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:119:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:119:13: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:135:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:136:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:151:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:40:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:57:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:110:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:155:19: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:155:23: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:155:25: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:170:19: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:170:21: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:170:23: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:170:25: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:219:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:239:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:257:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:263:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:268:18: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:294:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:321:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:329:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:347:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:360:21: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:360:23: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:403:23: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:429:18: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:465:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:520:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:521:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:526:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:527:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-buttons.css:527:13: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-frames.css:53:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-frames.css:69:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-frames.css:70:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-frames.css:76:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-frames.css:96:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-frames.css:97:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:15:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:17:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:36:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:38:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:61:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:63:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:75:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:77:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:145:18: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:146:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:175:18: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:176:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:289:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:298:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:313:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:320:13: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:322:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:323:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:347:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:390:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:419:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:432:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-bars.css:438:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:10:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:10:18: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:10:20: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:10:22: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:16:11: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:17:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:41:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:83:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-menus.css:88:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:18:12: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:19:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:20:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:50:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:57:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:69:17: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:71:16: Not using units is deprecated. Assuming 'px'.

Gtk-WARNING **: Theme parsing error: gtk-misc.css:72:11: Not using units is deprecated. Assuming 'px'.

--

I was able to install nfs and samba anyway.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-system-tools 3.0.0-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: fglrx wl
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Wed Feb 15 02:25:25 2012
ExecutablePath: /usr/bin/shares-admin
InstallationMedia: Xubuntu 12.04 "Precise Pangolin" - Alpha amd64 (20120201.1)
ProcCmdline: shares-admin
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 LANGUAGE=en_CA:en
Signal: 6
SourcePackage: gnome-system-tools
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 gst_packages_install ()
Title: shares-admin crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare scanner sudo vboxusers video

Revision history for this message
John Gary (johngaryb) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7f89154e9270 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7f89154e9438 "free(): invalid next size (fast)", ptr=<optimized out>) at malloc.c:5007
 spawn_synaptic (child_pid=0x7fff497a0a0c, path=0x1c6f270 "/tmp/packages.PszZAf", window=0x18a5010) at gst-package.c:142
 gst_packages_install (window=0x18a5010, packages=<optimized out>) at gst-package.c:194
 install_packages (tool=<optimized out>, install_smb=<optimized out>, install_nfs=1) at shares-tool.c:155

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Medium
summary: - shares-admin crashed with SIGABRT in raise()
+ shares-admin crashed with SIGABRT in __libc_message()
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-system-tools (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers