Time-admin's "Synchronize Now" should be enabled even in NTP mode

Bug #90524 reported by Eugenia Loli-Queru on 2007-03-08
70
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
Low
Unassigned

Bug Description

There is a usability problem with time-admin's "synchronize now" button: it's disabled completely when NTP is selected instead of manual. Problem is that I got there from the gnome date applet, it asked me to install NTP, it did, it then loaded the time-admin with NTP selected, and so the "Synchronize now" was never enabled for me when took that route. And that's important to be enabled because after you select a server it does NOT automatically synchronize.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 7 16:41:15 2007
DistroRelease: Ubuntu 7.04
Uname: Linux ubuntu 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux

Chris Rose (chris-vault5) wrote :

Thank you for your bug report. I can reproduce this here, and it is not expected behaviour.

Changed in gnome-system-tools:
importance: Undecided → Low
status: Unconfirmed → Confirmed
assignee: nobody → chris-vault5
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

The "synchrosize now" action is available if you don't use the NTP mode

Eugenia Loli-Queru (eloli) wrote :

My problem is that when I switched the NTP, the time did NOT synchronized immediately. For at least 5 minutes I was getting the wrong time still. You have to either enable that button, OR, make it synchronize immediately after the user changes to NTP mode.

Hi,

> You have to either enable that button,
From ntpdate man page:

 ntpdate will decline to set the date if an NTP server daemon (e.g., ntpd) is running on the same host.

So it has to be:

> OR, make it synchronize immediately after the user changes to NTP mode.

 Or fix the Edgy regression about 'without the full ntp package the button doesn't update the date but screws ntpdate-debian' cf #62745 and #83604 and remove the config manual/internet.

Sebastien Bacher (seb128) wrote :

> My problem is that when I switched the NTP, the time did NOT synchronized immediately

that's what NTP is doing, it doesn't do disruptive changes and do a smooth compensation rather

Eugenia Loli-Queru (eloli) wrote :

I believe the "update now" button exists on both Windows and OSX and it is used quite regularly...

Sebastien Bacher (seb128) wrote :

the GNOME tool also has a "synchronize now"

Schmirrwurst (schmirrwurst) wrote :

The Problem is also that ntp is only synchronizing at startup by me, if I have no connection on startup, then it is not synchronizing at all...

When seting up the clock to sync with servers, the applet is modifying the ntpd.conf, it should also configure it to sync once an hour or something like that, by default

C de-Avillez (hggdh2) wrote :

this, then, looks like a duplicate of bug 90267. Please have a look at the comments there.

A quick summary:

1. if ntp is started before network interfaces are active, then it will not work until restarted.

2. if ntp is running then ntpdate will not run (working as designed)

3. If network-manager is inactive, then ntp works OK (i.e., no issue as in (1))

4. if ntp is installed then the "synchronise now" button is grayed out (working as designed, AFAIK).

5. ntp will not make a big correction to the clock but instead will slowly adjust it (working as designed)

Changed in gnome-system-tools:
assignee: chris-vault5 → nobody
status: In Progress → Confirmed
Schmirrwurst (schmirrwurst) wrote :

Ok, but there are always some issues :

ntp is installed by default on ubuntu, so is also for network-manager.
If I've understood, it means that every user that won't start with network will have this problem. I think there is need to find a better solution, because I don't believe new users are able to stop ntpd by themself, and they even don't will understand that the problem comes from ntpd...

Maybe a solution would be to make network-manager restart ntpd , when link is up ?

Or to disable ntp by default, and enable the ntpdate from the gnome clock, as a beginer will first try to modify things through the gui...

C de-Avillez (hggdh2) wrote :

@schmirrwurst:

yes, this is why I suggested looking at the other bug. I do not see an immediate, simple solution here. Of course, NTP's approach to correcting the clock seems sensible and good, but some users want the clock corrected NOW, and this approach (I mean NTP's) may simply not do the trick here.

Also, "synchronise now" does not make sense when NTP is running (since only ntpdate can do it) -- and, at the same time, will potentially confuse a lot of users. On the other hand, the default behaviour of ntpd is to step differences bigger than ~ 100 ms -- which means instantaneous correction, so this is no big deal, unless you really need your clock accurate to the 10s of ms.

I think this will have to be worked out on discussions by the developers.

kripken (kripkenstein) wrote :

After just installing Feisty, I ran into this exact same problem. I puzzled over it for quite a bit without figuring out what exactly was expected of me. After reading the comments here, I am still very confused. Hopefully this can be sorted out somehow.

Helge Titlestad (helgedt) wrote :

I have another case where a "synchronize now" button should be available:
When running Ubuntu in VMWare, suspending the VMWare session and then resuming it at a later time, the clock is stuck at the time you suspended it. So even though I'm using ntpd to keep the clock in synch, I also want to be able to synchronize it "now" rather than waiting a few years for ntpd to catch up. I'm guessing this is a problem for most suspend solutions.

brianhanna (brianhanna) wrote :

I was just noticed this problem on my Gutsy system. I think the answer's here already but not entirely intuitive. To do a sync "now", you have to go to "manual" mode and hit "synchronize now". I saw my time change when i did that. Then you can go back to "keep synchronized" mode if you want.

wensveen (wensveen) wrote :

Couldn't the "sync now" button do just what brianhanna suggested? That is, stop ntpd, run ntpdate and start ntpd again?
What server does ntpdate use to sync on?

era (era) wrote :

How about (waves hands vaguely) determine whether NTP is present and working, and, if so, change the label to "Synchronization in progress ..." or some such? Then it makes sense for the button to be greyed out.

Maybe we can go with the "brutal" solution to stop ntp, run ntpdate and restart ntp. This is relatively easy to do from the backends. But it seems to me that ntp should be able to handle those problems better on its own.

summary: - Time-admin's "synchronize now" is disabled
+ Time-admin's "Synchronize Now" should be enabled even in NTP mode
Changed in gnome-system-tools (Ubuntu):
status: Confirmed → Triaged
Martin G Miller (mgmiller) wrote :

This is still a problem in 64 bit Lucid. I noticed my clock was off by several minutes and went into system > Admin > Time & Date to set it and discovered that it was set to manual. I set it to use a time server on the internet and when I was done, it still displayed the wrong time. There is no "synchronize now" button, either grayed out or otherwise. I tried logging off and on, but that made no difference. On going back to Time & Date, I noticed it was set back to Manual mode and again set it synch with time servers, but no change happened. I finally set the clock manually, but don't know if it's going to stay synced with correct time of not.

Martin G Miller (mgmiller) wrote :

I should also mention that the first time I ran Time & Date it needed to install ntpd as that was not installed by default.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers