gnome-system-tools version 2.32.0-0ubuntu7 failed to build on amd64

Bug #766040 reported by Matthias Klose on 2011-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-system-tools (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

gnome-system-tools version 2.32.0-0ubuntu7 failed to build on amd64
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2451601

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2451601/+files/buildlog_ubuntu-natty-amd64.gnome-system-tools_2.32.0-0ubuntu7_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 6474 lines into the build log:

 90d2f26e1435098ff4fef2b62f7508a600918793 94318 gnome-network-admin_2.32.0-0ubuntu7_amd64.deb
 817c9c1165d184092b5007947ff3ae91481a0410 236444 gnome-time-admin_2.32.0-0ubuntu7_amd64.deb
Checksums-Sha256:
 07e722c5091e07a655a4eaf449f0b65196eea9dd8ab7478877b5e3b63432b034 341494 gnome-system-tools_2.32.0-0ubuntu7_amd64.deb
 3ea0137fb0796d75fc87c85456d1c8c8b0bca8c292d0cd8f2c0cff08c822eeed 2668031 gnome-system-tools_2.32.0-0ubuntu7_amd64_translations.tar.gz
 199c25a727b4c84ed8b756c3a8f212742a12817e914275b8d25966da5e78cb05 2621848 gnome-system-tools_2.32.0-0ubuntu7_static_translations.tar.gz
 2c15e6bd5562a82fa84a90e1c786a2bca1fc4467c7e7b02da6141e3a6244ae5b 94318 gnome-network-admin_2.32.0-0ubuntu7_amd64.deb
 20248612a6a123242d93a87cd22d32adf1d295dfc02415bcf4366bc95b991acd 236444 gnome-time-admin_2.32.0-0ubuntu7_amd64.deb
Files:
 bf285889feeab9a4be560a44bf1e7d74 341494 gnome optional gnome-system-tools_2.32.0-0ubuntu7_amd64.deb
 687cbb39423cc3593562ba458b19a8b2 2668031 raw-translations - gnome-system-tools_2.32.0-0ubuntu7_amd64_translations.tar.gz
 724a65d0ec43bffd85869ad6546d30ad 2621848 raw-translations-static - gnome-system-tools_2.32.0-0ubuntu7_static_translations.tar.gz
 cfc503882c958d1c3e453fbe98fb0903 94318 gnome optional gnome-network-admin_2.32.0-0ubuntu7_amd64.deb
 83a468e9c5ebfe0c2a89f16557435983 236444 gnome optional gnome-time-admin_2.32.0-0ubuntu7_amd64.deb
Original-Maintainer: Jose Carlos Garcia Sogo <email address hidden>

******************************************************************************
Built successfully
Purging chroot-autobuild/build/buildd/gnome-system-tools-2.32.0

Matthias Klose (doko) on 2011-04-19
Changed in gnome-system-tools (Ubuntu):
importance: Undecided → High
Milan Bouchet-Valat (nalimilan) wrote :

Whats the problem? "Built successfully" isn't exactly a build error to me. ;-)

Matthias Klose (doko) wrote :

well, maybe have a look at the build log?

Our automated build log filter detected the problem(s) above that will
likely cause your package to segfault on architectures where the size of
a pointer is greater than the size of an integer, such as ia64 and amd64.

This is often due to a missing function prototype definition.

Since use of implicitly converted pointers is always fatal to the application
on ia64, they are errors. Please correct them for your next upload.

More information can be found at:
http://wiki.debian.org/ImplicitPointerConversions

Milan Bouchet-Valat (nalimilan) wrote :

Well, it's just that the bug description says "Failed to build", so that's what I was looking for in the build log. So it's actually just a warning.

This kind of report always useful, but I'm not aware of any crash on 64-bit systems, and this package hasn't changed since Maverick (that code even hasn't been touched for ages). So it's indeed just a prototype issue.

As the gnome-system-tools are deprecated I don't plan to fix this warning upstream. So I'm not sure it makes sense for Ubuntu to fix that before Natty is out. Anyway, the exact error is:
> Function `bsearch' implicitly converted to pointer at connection.c:542

Changed in gnome-system-tools (Ubuntu):
milestone: none → oneiric-alpha-3
Changed in gnome-system-tools (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → none
status: New → Confirmed
tags: added: universe
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-system-tools - 2.32.0-0ubuntu8

---------------
gnome-system-tools (2.32.0-0ubuntu8) oneiric; urgency=low

  * Add fix-missing-header-ftbfs-amd64.patch to resolve a missing
    header that caused a FTBFS on amd64/ia64. (LP: #766040)
 -- Daniel T Chen <email address hidden> Tue, 30 Aug 2011 17:55:27 -0400

Changed in gnome-system-tools (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers